Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Getting Started Compiling a Mod

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting Started Compiling a Mod

    These are the basic steps you need to get your mod compiling and running in the game.

    Mod source should be put in My Documents\My Games\Unreal Tournament 3\UTGame\Src, in a subdirectory of your package name. You put the .uc files in a further subdirectory named Classes.

    Next, you need to tell the game that your package should be compiled. In UTEditor.ini under the section [ModPackages], add a line for your mod:
    Code:
    ModPackages=MyCoolMutator
    Run "ut3 make" to compile your mod. The output script goes into My Documents\My Games\Unreal Tournament 3\UTGame\Unpublished\CookedPC\Script. Note the "unpublished". By default the game does not load files in this tree. This is so that you can choose to "cook" the mod (mostly for faster loading - only really useful for mods with a lot of custom content) or you can simply copy it into the Published branch. Since cooking/copying all the time is tedious, while testing you can pass the game the "-useunpublished" command line parameter to tell it to use the files in the Unpublished branch.

    When you compile a mutator, gametype, or weapon, the compiler will automatically generate an .ini file for your mod package that tells the menus about it. You can opt out of this by setting the property bExportMenuData to false in your class's defaultproperties.

    Feel free to post if you have questions or need help - that's what this forum is for.

  • #2
    I added mypackage to the UTeditor.ini but all i get when i run 'ut3 make -full' is

    core - release
    engine - release
    gameframework - release
    ...
    ...
    ...
    UTGameContent - release

    //edit
    when i run 'ut make' i get this message

    Comment


    • #3
      Thanks for the quick reply Mysterial

      But there is a mistake
      Rypel figured it out: it is ModPackageS, with an S.

      Comment


      • #4
        Thx Mysterial. But theres one typo in your tut. It should be "ModPackageS=MyCoolMutator" with the additional S. Then it works

        Comment


        • #5
          Thanks, fixed the typo.

          Comment


          • #6
            I get a standard windows crash (popup box come up with ut3.exe has encountered a problem etc) when I compile and it gets down to my package and writes "-------vyd-release-----------" like that. Any ideas? I'm pretty sure I followed the instructions

            Comment


            • #7
              Thanks Mysterial you guys rock.
              Now all I need is UT3...

              Comment


              • #8
                I'm trying to run the basic of basic helloworld mutators as a test to make sure everything is working right, and to also get a feel for the engine again. But I'm having some issues.

                I have successfully compiled the mutator, and i'm using the -unpublished and -log flags to get some output. I can see that it's trying to load my mutator, but its just saying...

                Code:
                Error: Error reading attributes for 'C:\Games\Unreal Tournament 3\Binaries\..\UTGame\Unpublished\CookedPC\Script\MutHelloWorld.u'
                No idea's on whats causing this. Although the mutator does appear in the in-game lists. So I try to start a local instant action with my HelloWorld mutator and...

                Code:
                ScriptLog: Mutators MutHelloWorld.HelloWorld
                Warning: Failed to load 'Class MutHelloWorld.HelloWorld': Failed to find object 'Class MutHelloWorld.HelloWorld'
                So I have no ideas at all, anyone else got any?

                Here's the code im using...

                Code:
                class HelloWorld extends UTMutator
                	config(Game);
                
                function PostBeginPlay()
                {
                  Super.PostBeginPlay();
                  LogInternal("Hello World");
                }
                
                defaultproperties
                {
                  bExportMenuData=true
                  GroupNames(0)="TEST"
                }
                I'v also tried instead of function "simulated event" as that appears to be used about the place but no dice.

                Comment


                • #9
                  Originally posted by Limi View Post
                  i'm using the -unpublished
                  It's actually "-useunpublished"... I had another typo in my post... guess I didn't proofread it well enough

                  Comment


                  • #10
                    Now I don't have to wait for UDN to open

                    Comment


                    • #11
                      I'd be modding like a madman but I don't have the game yet for some reason, I can't figure out why!

                      Comment


                      • #12
                        so u r just as sick as i am im modding all day ... the only difference is that I HAVE THE GAME !!!!

                        Comment


                        • #13
                          Beat that: I don't have the game, but already coded two mutators.

                          Comment


                          • #14
                            Originally posted by Wormbo View Post
                            Beat that: I don't have the game, but already coded two mutators.
                            HAXXXXXXXXX!

                            Comment


                            • #15
                              Thanks for the info Mysterial! My German UT3 arrived so I can now start trying to get some form of RPG working for UT3 . Do you think the new menu system will allow something similar to UT2004RPG client side configuration with UT3?

                              Comment

                              Working...
                              X