No announcement yet.

Getting Started Compiling a Mod

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

    Error reading attributes for ...

    Okay, I've compiled my HelloWorld.uc okay. I'm getting this runtime error now in the logs, no matter what I do. I run UT3.exe -useunpublished. Here's the code which is similar to what I found in another post:

    class HelloWorld extends UTMutator Config(Game);
    function PostBeginPlay() {
    LogInternal ("Hello World");

    defaultproperties {


      After several trial and errors and googling a lot, the "error reading attributes" is not too meaningful. It will work regardless as long as you include your mutator in the setup screen for Instant Action. My mistake was to just do a new Campaign and I was therefore not including my mutator. If you want to get rid of this error, you can copy your unpublished directory to the C:\Program Files\Unreal tournament 3\ directory but again that is not necessary.


        compiling problems

        i'm also getting compiling problems similar to euchreplayer,

        i'm getting 2 errors and 19 warnings,

        the errors seem to be to do with BEGIN OBJECT PickupLightEnvironment
        which it says is already in use, in the ammo class
        and the BEGIN OBJECT SkeletalMeshComponent0 in the Attachment class, which again it says is already in use?

        any idea's of how to get around these?


          down to 1 error but confused

          hey. i've managed to work this down to 1 error but i'm really confused as to what this error actually is and how to fix it

          as you can see from the error message in the compiler there is an error saying unexpected i (or something similar) in the code. however i can't actually see this error in the code

          can anyone help?



            check your .uc file save as.....
            encoding should be "unicode"


              check your .uc file save as.....
              encoding should be "unicode"
              thanks for the help however i've tried it but still seems to be unsuccessful. same error again.

              EDIT: i' resaved all other files in the mod as unicode files and it them seemed to work. without the fatal error. only 10 warnings to go :P


                The "Unexpected 'ï' " is actually the unicode UTF-8 byte order mark (BOM).


                I recommend saving as ANSI text (also known as ASCII) to avoid any problems or confusion about different unicode formats. Saving as utf-16 might work. I belive the engine understands utf-16 but not utf-8. Oddly enough, the ut3 script source is in utf-8 format, so none of it compiles by default. If you copy Epic's files and tweak a few things it doesn't work unless you also convert the text format too. IIRC what windows calls 'unicode' is utf-16, so what euchreplayer23 says is probably true, but I still recommend ANSI as it works everywhere and you probably aren't using any unicode features anyway.


                uh never mind I see you got it working You responded while I was responding :P


                  thanks for the advice though i appreciate the input.
                  and with some success i have my weapon in game. moderate success anyway. lol

                  i can't yet see the weapon in 1st person view. but can see it in the game. as the below screen will show. any reason why its missing? have i missed a socket in the engine or something in the attachment file?


                    weapon offset

                    hi guys. making some progress but i'm a little confused as to how to properly align the weapon. i've been playing with these 2 properties


                    with player view offset i have been able to move things around so i can see the gun and the arms. (see below) however this seems to only move the view and not the weapon. so after resetting that back to 0.0 on all axis the smallWeaponOffset was the way to go. however this seems to not do too much as the weapon is no w of screens and only a muzzleflash is visible in the top right corner?

                    does anyone know of any standard setting to reset these properly? or to get the gun to sit in the correct place?


                      Hey everybody, first off thanks a bunch for the help-

                      (Surprise, surprise) I'm not a programmer, and am trying to get a custom weapon in- it's killin me! I see the above post has a (whooT!) custom weapon in and showing- heck, that's WAY further than I seem to be getting!

                      basically, I've created the package, animsets/meshes/materials, saved it out into the "My Documents\My Games\Unreal Tournament 3\UTGame\published", copied and modded the needed class files, and put those into the "My Documents\My Games\Unreal Tournament 3\UTGame\Src"- all meticulously per GeoDav's (wonderful, but hard to follow for myself) weapon tutorial. Now, I should open UT3ed and it will ask me to compile? Nope...

                      I'm assuming I messed up at the "scripts" part- now, please don't laugh (haha), but just what are these "scripts" and where/how do i go about getting/making them? I DO know that a "script" in general is a series of commands that tell this or that to do etc etc- lol - but the tutorial just said, quote from GeoDav (again huge thanks):

                      "Ok a quick folder check, your weapon package must be in the unpublished folder tree and in the published folder tree(for testing). Scripts in the Scr folder tree."

                      Eeek! what are the "Scripts" that I put in the "Scr" tree? Also, where the heck is "Scr"? I can find "Src", but no "Scr", although I assumed this was just a typo...

                      Thanks again everybody, REALLY appreciate the help, my ridiculous college refuses to use UT3 and (gag) still uses UT2004 which I LOATH, so am teaching myself UT3 fast as I can to keep passing my classes and getting ready for next gen! I have gotten a character and custom level, but weapon/vehicle is a PAIN so far.



                        well, i looked a few pages back again, and found I had missed/skipped a gem! got my mod to compile- and WOW i broke stuff. haha, see pic...well, I'll be working on that then...if anybody has input on what went wrong, lemme know, please!



                          okay guys, well, moving right along-

                          so i've got it down to FAR fewer crazys- basically, now it's just hootin and a hollerin that my package can't be found- but it's right there! I've checked!

                          I should be saving it to the "mygames...\published\CustomWeapons" directory, right? Or should I have that "CustomWeapons" folder? It seemed to make sense to me.



                            This is where I have ours:

                            For Developing: My Games\Unreal Tournament 3\WarmGun\Unpublished\CookedPC\Weapons

                            For Release: My Games\Unreal Tournament 3\WarmGun\Published\CookedPC\Weapons


                              Hey Austin-

                              thanks for the input, tried that luck. Is there somewhere that I need to specify to the engine where to look for the .upk file?? I did that exact path, no luck. need I say ARG? lol...

                              oh too everybody I now have a full and detailed description of the error, plus all my UC files right on this forum:



                                great, well, now using "Make -unpublished", and some other minor fixes, it finishes compiling, claims to write a script- then crashes (the usual "Unreal 3 has Encounterd and Error. We apologize for the inconvenience. yada yada..."). No script to be found.

                                when i place the same .upk file in teh same place, but in the Published tree, it simply won't find the .upk file still.

                                I just know I'm going to smack myself in teh head when i figure this one out...