Announcement

Collapse
No announcement yet.

Intel G630, Geforce GT440 + UT3 = stutter

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Do you wanna push your Gt440's overclock? Make sure to have evga or msi fan slope at 0% fan speed at 0C, and 100% fan speed at 65C to maintain temps better and have a pleasing fan sound note. The fan curve will be 100% linear from 0%-0C to 100%-65C.

    The first thing you guy's need to be aware of that 99.9% of stutter is hard drive related and total system memory you have on your system. If you have less than 80% free space on your C:\ Windows Drive, PREPARE FOR STUTTER GALORE! The Unreal Engine uses texture streaming as we all know. What this does is, it caches textures etc to places other than VIDEO MEMORY. So where would it cache the textures from? The Hard Drive. It caches these textures on the Hard drive to take video memory load off your GPU which is actually pretty darn stupid. Try setting TextureStreamingEnabled=False it may help you out a lot if you have less than 80% free space on your C:\ drive. We are also talking about the drive in total including Partitions so if the ENTIRE hard drive as a whole has less than 80% free space you will have stutter and there's no way around it.

    I have 95% free space on my GF108 rig, and my other rigs and get no stutter at all especially with the below settings.

    GPU utilization low is very bad and it can be fixed with the below settings to get 99% to 100% gpu utilization for way better frame rates on ANY GPU no matter if it's GF108...

    Yeah the latest drivers are ideal. What I noticed is to get the best fps and stutter free gameplay on GF108 is minsmoothed=0, maxsmoothed=60, mindesiredframerate=30 or 60 or even 120. What the minsmoothed, and max smoothed means the engine will smooth the frames from 0 frames a second up to 60 frames a second. The mindesired will push gpu utilization until the mindesired is achieved and if it never achieves it it'll run 100% or 99% gpu utilization continuously which is a good thing.

    Set your maxsmoothed to 120 if you have 120hz lcd, and set mindesired to 120 and the same applies as above.

    One thing is 120% for sure the GF108 simply cannot handle 1920x1080, ambient occlusion, and shadows all at the same time. If tweaked it can handle 1920x1080. The GF108 is a fermi so it's power house in terms of computing tesselation in dx11 etc.

    So to get great quality texture detail and lighting etc on the GF108, you have to tweak some things. Set maxshadowresolution from 1536 to 512, and wholescenedominantshadows to 512 as well but you will have to find the best setting for the game. Doing that alone gains 10-20fps for me. Disable ambient occlusion and set ShadowLODBias to 3 for ultra low quality, or 4 for insanely low quality. ShadowLODBais at 0 yields maximum shadow quality, so going up to say a max of 5 or more shadow Level Of Detail goes down and frame rate goes up for the GF108.

    Leave a comment:


  • replied
    Thanks for the reply.
    I switched over to 314.22 drivers and felt no difference.
    I've removed the config files again afterwards and I've found out that the settings having the biggest impact on the performance were One Frame Lag and Frame Smoothing. By leaving these at default, that is Frame Smoothing enabled, 22-60 on Min-MaxSmoothedFrameRate variables, OneFrameThreadLag on True, I've achieved nearly butter smooth 60 FPS. After I've changed it to 1-60 in ranges, as you suggested I didn't see much difference. The GPU usage is around 40-45% which I guess is related to the frame lag.
    If I tried to change the maximum FPS since my refresh rate is higher from 60, perceptible lags would occur whenever the FPS would go down. Performance didn't change too much when I've modified the rest of the settings ingame. I guess at this point the hardware isn't enough already, though a benchmark showed that my card can more than that. I guess that minimal framerate is more important from the average though.
    http://www.techpowerup.com/reviews/A...GT_440/19.html
    I'll try to do some more testing soon.

    Leave a comment:


  • replied
    I think it may be GF108 issues. I am having issues with my GF108 being the GT540M 1GB GDDR3 which is identical to your GT440 except the fact you have GDDR5. Some GT440's come with GDDR3 ram and everything is exactly the same as my GT540M.

    Basically to get your GPU Utilization up just set minsmoothedframerate to 1.0 and maxsmoothedframerate to 60.0 then set your mindesiredframerate to 60.0. After that turn vsync to OFF. That will push your gpu to 99% utilization to get the best performance possible with zero stuttering. Because what it's doing is smoothing your framerate in the range of 1.0 fps to 60.0 fps, and your mindesired frame rate will push the gpu to utilize everything it has to get 60.0fps even if it never achieves 60 fps the gameplay will be ULTRA SMOOTH.

    My GF108 with the above settings get 99% utilization continuously.

    Leave a comment:


  • started a topic Intel G630, Geforce GT440 + UT3 = stutter

    Intel G630, Geforce GT440 + UT3 = stutter

    Hello.
    It seems that UT3 hasn't aged very well and it has trouble cooperating with newer hardware or drivers.
    I'm running on this PC:
    Mobo: Asus P8H61-M LX2/SI
    CPU: Intel Pentium G630 2.7GHz (Socket 1155)
    RAM: 6 GB DDR3 GoodRAM
    GFX: Palit Geforce GT440 GDDR5 1GB
    SOUND: ASUS Xonar DG
    HEADPHONES: AKG K518; Creative Fatal1ty HS-800
    KEYBOARD: Logitech K350 (USB)
    MOUSE: Logitech G400 (USB)
    OS: Windows 7 Ultimate 64 bit
    I run the newest at the moment 320.18 Nvidia graphics drivers.

    The main problem: Microstuttering.
    During the game it's skipping 1-3 frames when I turn around quickly. It annoys a great deal and doesn't allow me to aim precisely. The GPU usage during the game is VERY low and perhaps drops down for a moment during the stutters, as shown in the pictures in the attachments/below, while the CPU is around 70-90%, even in menu. I've done all the tests on first campaign mission in singleplayer, since I'd like to host 4 player matches for my friends from time to time.
    Doing the diagnostics by using the stat engine command in the console, it seemed that my input lag is abnormally high, sometimes jumping up to 90ms, though not always along with the stutter, along with the frametime jumping up to >=120ms along with the stutters.
    Second problem would be quite low FPS hovering around 20-30 FPS in that very first tutorial mission when looking across the map.

    What I've tried is:
    Changing UseMinimalNVIDIADriverShaderOptimization, bSmoothFrameRate, OneFrameThreadLag variables between True or False in config file(s) inside the C:\Users\Anijatsu\Documents\My Games\Unreal Tournament 3\UTGame\Config folder (not the Default*.ini ones)
    Changing PoolSize=158 under [TextureStreaming] to 300, 600, 1024, 2048 in UTEngine.ini
    Changing vsync on/off
    Changing frame limit for the UT3 executable inside Nvidia Inspector

    What I haven't tried yet is:
    Installing GPU drivers version 182.05 from 2009 for a single game that's come out in 2007 and was never properly optimized for PCs.

    GPU usage graph from Nvidia Inspector:
Working...
X