Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Ut3 ps3 help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Ut3 ps3 help

    i have UT3 on my ps3 and i bought it about 3 months ago just to play split screen with my brother, it worked but suddenly i cant get player 2 into the game. in other words, player one appear in the main menu, but when i try enter the sec player by pressing start or X or anything there is no response... nothing happens. can someone please help me... i hate playing realistic fps on my PS3... so im desperate
    NOte: yes the game is updated...

    #2
    Originally posted by Odiseuse View Post
    when i try enter the sec player by pressing start or X or anything there is no response... nothing happens.
    To turn on second controller, you need to press the PS button (not start or X)

    Are you sure you are following the correct steps:

    1. Start PS3 and start UT3.
    2. Go into Splitscreen (not Instant Action), pick your map you want to play
    3. Turn on Second Controller (making sure the #2 light on the controller is on ,not #3 or #4)
    4. Start Match.
    5. When you get in the match, both players should be in the game.

    Sorry for making this sound so obvious, but I really don't understand what else it could be.
    If only one controller was on in Split Screen mode, the game will tell you to turn on another controller before starting the game.

    However, I'm not surprised. UT3 has these bugs all the time.

    Comment


      #3
      splitscreen mode doesnt appear in the main menu, could be that the game needs to be updated if so how to force.
      and is there a way to entirely uninstall UT3 with its update for the ps 3?

      Comment


        #4
        The only I know to update UT3 is to connect your PS3 to the internet.
        You could also go to playstation.com and see if you can put the update on a memory stick. Put the memory stick in the PS3 and do it that way.
        The update you need i believe is 2.0 (released 5 March, 2009)

        Tell me, is the main menu (or when you select instant action, or settings etc) a red colour or black colour?
        That will tell me if you have the update.

        Your UT3 main menu should look like this:
        (except of course, the "Once game starts, select community on menu")

        Comment


          #5
          it used to look like this but not anymore, im gona go update it again.... thanks for the help guys

          Comment


            #6
            No problem, let me know if it works

            Comment


              #7
              yes it worked thanks alot

              Comment

              Working...
              X