No announcement yet.

Serious networking issues - out of options?

  • Filter
  • Time
  • Show
Clear All
new posts

    Serious networking issues - out of options?

    Hi people,

    I'm posting this as a thread because it seems to be impossible to contact Epic via e-mail.

    A while ago I purchased Unreal 3 via Steam, enjoyed a bit of playing online, etc. Because I enjoyed it my wife and my best friend decided they would like to play with me, so they both purchased the game via Steam as well.

    And there the nightmare started...

    What do we want to do? We want to host matches in the comfort of our own home (So: LAN games) but also be able to host the occasional Internet match so my friend can join us. We (my wife and I) and my friend both have cable broadband connections (60mbit down, 6mbit up) with an ISP-provided router (Brand: Ubee) that enables us to do port forwarding, port triggering and DMZ.

    The symptoms: It starts out when I try to host a simple LAN match for me and my wife. When pressing 'Host Game' I get an error message saying "[my] network configuration [might] not be able to host internet matches. Refer to your manual for port forwarding or DMZ."

    That's not an issue for a home match... and surely, I cán start a match and have my wife join in: ONE match. If we play the whole match through and have it reset the same map after a winner is declared, we can keep on playing that map... but if I choose 'disconnect' to pick a new map or a different type of game and launch that LAN game, my wife is unable to join me a second time. The game will tell her '[she] is currently not allowed to join this game'.

    Seriously? Why is she not allowed to? No explanation? The solution is to completely restart both games entirely, and then we can play another (1!) game.

    Symptom #2. The internet matches. Ofcourse, the error message when I choose 'host game' is self-explanatory and ofcourse this does not work. When I host a server, that game does not show up in the central server list online. So I start making preparations to enable myself to host a game, right?

    What I tried on my PC:

    - Enable all 'UT3' traffic through Windows firewall
    - Disable my Windows firewall (I do not have any other Firewalls in place on that PC)
    - Disable Windows Security Essentials (I also do not use any other type of security software on that PC)

    What I tried through my modem/router:

    - Enable all port forwards (UDP, TCP and Both) as found online
    (mainly 7777, 6500 and 13000 but also 27900, 28900, 29900, 29901 and a score of others) to my PC
    - Enable port triggering for 7777, 6500 and 13000 UDP&TCP
    - Disable the firewall in my modem/router
    - Disable ICMP blocking
    - Disable Port Scan Detection
    - Disable IP Flood Detection
    - Disable and Enable UPnP
    - Place my PC in the DMZ (so completely open to the internet)

    What I tried through the software:

    - remove the stunserver URL's from UTEngine.ini
    - remove the stunserver addresses but replace the URL with my WAN IP
    - remove the stunserver addresses but replace the URL with my localhost address
    - completely remove the stunserver lines from UTEngine.ini (but they are replaced at next game start if I do that)
    - set WebServer.Enable = True in UTWeb.ini and add a line ServerName=<WAN IP>

    What I tried in-game:

    - add my friend in-game through 'community' and 'friends'
    - tried joining a game he started (I only get the options 'send message' or 'follow player'
    - invited eachother to a game
    (all these options will result in 'connecting...' for about 1 minute and then 'connection failed' though I get the invites and have the option to accept them, the game will even ask me for the game password if the other chose to set one for that game)

    * Note: When my friend hosts a game we get the same results, the only difference is that he does nót get the 'error' message when he chooses 'host game'.

    I have scoured the internet looking for solutions and have tried literally every option I could find. I have seen explanations concerning terms like 'full cone NAT' and 'PAT routers', why Epic chose to implement a network protocol fit for kitchen appliances (not my words), how I could mangle my network stack to get it to work (and subsequently cripple all others) to setting up complete Internet VPN's between us and my friends' house to be able to play.

    One could not claim I have not extensively tried to solve this problem myself, I've been at it for DAYS now and these kind of problems have NEVER bothered me with ANY game I have EVER played in my WHOLE LIFE. I'm completely out of options here and seriously ****** off at not being able to play the game the way we intended when we purchased it (3 x € 20,- = € 60,- Euro's).

    I have no other option than to assume Epic has botched this game one way or another but am open to suggestions on how to finally solve this.

    For reference and completeness, an overview of our setup:

    Wife: Toshiba Qosmio F60-10M laptop w/ Core i3, 4GB ram, 500GB hd, Wireless-G 54Mbit, 1024MB Nvidia GT330m GPU

    Myself: AMD X2 245e @ 3,7Ghz, 8GB ram, 500GB hd, 1Gbit Wired connection, 512MB Nvidia N9600GT GPU

    *Our router: Ubee Wireless Modem/Router from our ISP (Ziggo)

    Friend: Amd X4 440, 8GB ram, 160GB hd, 100Mbit Wired connection, 1024MB Ati/AMD Radeon 5650 GPU

    *His router: Ubee Wired Modem with a Sitecom Wireless Router/Switch connected to it.

    I have no direct control over his modem/router settings, though I could always pop over to check some stuff. However, the fact that he does not get the 'error' message when hosting games, his network config seems to check out OK with the game. I could try enabling certain port forwards/triggers at his house to see if he would be able to host, but that will not solve the problems I have here (both with LAN and Internet games).

    So Epic, I hereby ask you, as a paying customer, to solve this problem by posting solutions here, or contacting me directly to troubleshoot these issues.
    I hope I do not have to remind you of your warranty responsibilities with the borders of the Netherlands under which this purchase is covered, since all warranty matters are by law settled under local law, should a vendor choose to sell his product in a certain country and thus under its jurisdiction.

    This warranty effectively obligates you to provide me with a fully working product for a period of at least (2!) years, not including factory defects which should always be fixed free of charge in which case non-compliance entitles us to a complete refund of said purchase. My obligation, not literally stipulated but implied, is to coöperate with the vendor in solving said problem, which I am now doing by posting this thread and asking you to provide more options to solving, or a direct fix to the problem.


    Sven from the Netherlands

    Insinuating that it will probably go forever unanswered?

    Because that seems to be the case at the moment - neither the forum admin, the forum itself or the epic support addresss I found 2 days ago care to respond or even acknowledge receiving my complaint.

    Is this a common occurance for Epic's "Support"? Because I have a whole lot of other options to harass them into action.


      It's not their fault that their software does not run on your system. Check if you're able to transmit data through TCP and UDP (these protocols are used on UT3) over your internet connection.
      Another tip: Use the open console command instead of the friend following feature.
      open IP[:PORT]
      You forgot to mention the OS you're running.

      Regarding '[she] is currently not allowed to join this game':
      Why is she disconnecting? In order to play another map, a server admin (or the player who runs the "server") can switch to a map by using console commands like "switchlevel" or "Adminchangemap". Another thing, you can enable voting so both/all players can vote for a map they want to play.

      For my case:
      I just needed to port-forward the specific ports to the specific machine (the computer where the a server is running). If you're using Win Vista (and later), you need to change network settings as Windows is restricting direct (internet) access.