Announcement

Collapse
No announcement yet.

At random, I cannot connect to the server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    At random, I cannot connect to the server

    I'll be playing fine for a while, map changes work ok, match changes work ok etc then suddenly at one map change, the game will crash (generic windows crash dialog) and at that point I will be unable to connect. Anyone else that was playing is already connected and playing by then, so I know it's not the server.

    After a couple reboots with 10 or so tries between, it will finally connect. Sometimes it will actually partially connect, then give a connection error. But usually it just stays stuck at "connecting...". Anyone else ever get this?

    #2
    Do you know what map? Do you need to reboot the system? Do you have a internet connection after crashing (pinging google.com or something)?
    Did you install all the important patches? Titan pack installed? Do you have that custom map cached? Did you change your config? What version of UT3 are you playing - standalone or steam integrated? What server? ...

    If you get a crash, the log file will always provide a hint to the source of the problem.
    My Games\Unreal Tournament 3\UTGame\Logs\Launch.log

    The log file needs to get flushed in order to be written completely, so don't kill the ut3.exe process after a crash.

    Comment


      #3
      Using UT3 with latest patch, on latest server. Internet connection works fine, I always double check to ensure it was not that. I'm usually chatting on msn and ask my friend if he was able to connect and he can connect fine. No custom maps installed yet, though I think I do have the Titan pack. No changes to config other than a few hot keys and video resolution. But it's been that way since the start. The server is ut3.uovalor.com, just a basic server I setup. It seems to crash at the vCTF map Necropolis but I'm not 100% sure if it was always that map.

      I renamed the log so I can start fresh, and now that I know the location I'll check it immediately next time it crashes, but here's something that may help?

      Code:
      ScriptLog: Finished creating custom characters in 3.3203 seconds
      Error: Unknown remote talker specified to MuteRemoteTalker()
      ScriptWarning: UTUITabPage_Scoreboard Transient.MidGameMenu_0:MidGameSafeRegion.TabControl.UITabButton_0.ScoreTab (Function UTGame.UTUITabPage_Scoreboard:SetupButtonBar:015A) Accessed None 'GameSettings'
      ScriptWarning: UTUITabPage_Scoreboard Transient.MidGameMenu_0:MidGameSafeRegion.TabControl.UITabButton_0.ScoreTab (Function UTGame.UTUITabPage_Scoreboard:SetupButtonBar:015A) Accessed None 'GameSettings'
      Error: Unknown remote talker specified to UnmuteRemoteTalker()
      Error: Unknown remote talker specified to MuteRemoteTalker()
      Log: AActor::SyncActorToRBPhysics: Invalid or Missing BodyInstance in CollisionComponent. (check to make certain your object actually has a collision volume) for: UTPawn vCTF-Necropolis.TheWorld:PersistentLevel.UTPawn_16  CollisionComp: No StaticMeshComponent Assigned
      Log: AActor::AttachComponent: Trying to attach 'UTSkeletalMeshComponent_265' to 'UTWeap_Redeemer_Content_1' which IsPendingKill. Aborting
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:001D) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0025) Attempt to assign variable through None
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0077) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:007F) Attempt to assign variable through None
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0086) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0095) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0119) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:001D) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0025) Attempt to assign variable through None
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0077) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:007F) Attempt to assign variable through None
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0086) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0095) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0119) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:001D) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0025) Attempt to assign variable through None
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0077) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:007F) Attempt to assign variable through None
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0086) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0095) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0119) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:001D) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0025) Attempt to assign variable through None
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0077) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:007F) Attempt to assign variable through None
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0086) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0095) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0119) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:001D) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0025) Attempt to assign variable through None
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0077) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:007F) Attempt to assign variable through None
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0086) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0095) Accessed None 'Pawn'
      ScriptWarning: UTPlayerController vCTF-Necropolis.TheWorld:PersistentLevel.UTPlayerController_0 (Function Engine.PlayerController:PlayerFlying.PlayerMove:0119) Accessed None 'Pawn'
      Log: AActor::SyncActorToRBPhysics: Invalid or Missing BodyInstance in CollisionComponent. (check to make certain your object actually has a collision volume) for: UTPawn vCTF-Necropolis.TheWorld:PersistentLevel.UTPawn_44  CollisionComp: No StaticMeshComponent Assigned
      Log: AActor::SetBase : Bone (UpperBody) not found on UTPawn_44 for UTEmit_BloodSpray_38!
      Log: AActor::AttachComponent: Trying to attach 'UTSkeletalMeshComponent_291' to 'UTWeap_LinkGun_12' which IsPendingKill. Aborting
      Log: AActor::AttachComponent: Trying to attach 'UTSkeletalMeshComponent_291' to 'UTWeap_LinkGun_12' which IsPendingKill. Aborting
      ScriptLog: UTInventoryManager_36 (Owned by UTPawn_56 ) is trying to Sync to the currently active weapon (UTWeap_FlakCannon_13)
      Log: AActor::SyncActorToRBPhysics: Invalid or Missing BodyInstance in CollisionComponent. (check to make certain your object actually has a collision volume) for: UTPawn vCTF-Necropolis.TheWorld:PersistentLevel.UTPawn_58  CollisionComp: No StaticMeshComponent Assigned
      Error: Unknown remote talker specified to UnmuteRemoteTalker()
      If there's anything specific I should be looking for let me know. I just grabbed what seems to be like lot of errors. Not even sure if that's from when it crapped out, as I did eventually get on that map after many tries.

      Oh and it's stand alone as far as I know, it's not through steam. The server is running on Linux.

      Comment


        #4
        The last about 20 lines are important if you got a crash.

        Comment


          #5
          Ok got a crash on Necropolis load, oddly I don't see anything in the log about that map, but here's the last couple lines:


          Code:
          ScriptWarning: UTMusicManager VCTF-Sidewinder.TheWorld:PersistentLevel.UTMusicManager_1 (Function UTGame.UTMusicManager:ChangeTrack:04DB) Divide by zero
          Error: Unknown remote talker specified to UnmuteRemoteTalker()
          Error: Can't end an online game that hasn't been created
          ScriptWarning: UTMusicManager VCTF-Sidewinder.TheWorld:PersistentLevel.UTMusicManager_1 (Function UTGame.UTMusicManager:ChangeTrack:028F) Divide by zero
          ScriptWarning: UTUITabPage_Scoreboard Transient.MidGameMenu_3:MidGameSafeRegion.TabControl.UITabButton_0.ScoreTab (Function UTGame.UTUITabPage_Scoreboard:SetupButtonBar:015A) Accessed None 'GameSettings'
          Log: SeamlessTravel to: VCTF-Necropolis
          Log: ClearAllAnimSetLinkupCaches - Took 10.23ms
          Log: Primary PhysX scene will be in software.
          Log: Creating Primary PhysX Scene.
          Log: Bringing World EnvyEntry.TheWorld up for play (90) at 2012.04.16-23.58.43
          Log: Bringing up level for play took: 0.011290
          Critical: appError called:
          Critical: Direct3DDevice->CreatePixelShader((DWORD*)&Code(0),(IDirect3DPixelShader9**)PixelShader.GetInitReference()) failed 
           at .\Src\D3D9Shaders.cpp:18 
           with error E_OUTOFMEMORY
          Critical: Windows GetLastError: The system cannot find the file specified. (2)
          Critical: appError called:
          Critical: Rendering thread exception:
          Direct3DDevice->CreatePixelShader((DWORD*)&Code(0),(IDirect3DPixelShader9**)PixelShader.GetInitReference()) failed 
           at .\Src\D3D9Shaders.cpp:18 
           with error E_OUTOFMEMORY
          
          RaiseException() Address = 0x7c812aeb (filename not found) 
          CxxThrowException() Address = 0x78158e89 (filename not found) 
          Address = 0xbb4f92   (filename not found) 
          Address = 0xe8781b4c (filename not found) 
          
          Critical: Windows GetLastError: The operation completed successfully. (0)
          Log: === Critical error: ===
          Rendering thread exception:
          Direct3DDevice->CreatePixelShader((DWORD*)&Code(0),(IDirect3DPixelShader9**)PixelShader.GetInitReference()) failed 
           at .\Src\D3D9Shaders.cpp:18 
           with error E_OUTOFMEMORY
          
          RaiseException() Address = 0x7c812aeb (filename not found) 
          CxxThrowException() Address = 0x78158e89 (filename not found) 
          Address = 0xbb4f92   (filename not found) 
          Address = 0xe8781b4c (filename not found) 
          
          
          RaiseException() Address = 0x7c812aeb (filename not found) 
          CxxThrowException() Address = 0x78158e89 (filename not found) 
          Address = 0xbb4f92   (filename not found) 
          Address = 0xe8781b4c (filename not found) 
          
          Exit: Executing UObject::StaticShutdownAfterError
          Exit: Executing UWindowsClient::ShutdownAfterError
          Exit: Executing UWindowsClient::ShutdownAfterError
          Exit: UALAudioDevice::ShutdownAfterError
          Log: Shutting down FaceFX...
          Log: FaceFX shutdown.
          Exit: Exiting.
          Exit: Name subsystem shutting down
          Uninitialized: Log file closed, 04/16/12 23:59:36

          Sindwinder was the last map, and worked ok, the game ended and it crashed before it started loading the next map. If I keep trying, it will eventually connect.

          Comment


            #6
            E_OUTOFMEMORY

            What are your specs?

            Comment


              #7
              Hmm know what, never even considered that, my PC is fairly old. Could be a mem leak in the game. It always seems to do it after a few rounds.

              I have 4GB of ram, but in reality 3.5GB given that's XP's limit. CPU is an AMD Athlon 64 X2 and my video card is a Nvidia Gforce 8600GT (250MB of ram). Though still does not explain why I have so much trouble getting reconnected after, kinda odd. Is there maybe a process that keeps running in the background that I should kill?

              Comment


                #8
                The "filename not found" looks like game cannot load something needed. I'd run a disk check + if you have UT3 on Steam, make a cache check.

                Comment


                  #9
                  Ok so seems it's a random map, it's doing it more and more now. It even did it on the first session once, but usually it's after 3 games. I have to do a full blown reboot, multiple times, before it finally works. When it crashes it always does it 3 times. I can see it coming ahead of time because it gets super laggy and slow, and is always at the map loading screen.

                  I have the stock version of UT3 with the Titan pack, nothing else added. this is a fresh install. Not using Steam. The disk check returned no errors. Is my computer just not able to handle it?

                  Also, it seems now when it does it, it also crashes the server. I'm not sure how to get the version number as I just tried so many things from different tutorials that I found until I got it to work, that who knows what version it is now. I'll assume it's the latest, but if there's a way to check I can provide that info.

                  I also get file not found all over the place constantly, on the server it does the same thing. Thing is, there is no file to find, map tutorials just say to upload the .ut3, .upk and the .ini file and I followed those instructions. I don't know what other files it wants me to upload and where it wants them to be. But other than these random crashes all the maps do work fine.

                  Comment


                    #10
                    Generally, UT3 works find without any influences (on a clean updated system).
                    Maybe updating DirectX and your GFX driver (+GFX driver software) would fix this problem. And the VC++ runtimes.

                    I ran UT3 on a lower system than yours. So RAM, CPU and GPU specs won't be a problem imo.

                    Comment


                      #11
                      I don't like the sound of "Stock version with a Titan pack". Titan pack requires v2.0 at least. Try installing patch 2.1 This will make sure your game is up-to-date .

                      Comment


                        #12
                        I think I do have 2.1, I meant I did not add any mods or anything like that. When I first connected to the server it said I had to update so I just went to the UT site and got the latest update. 2.1 sounds familiar, I think it was that, which comes with titan pack right?

                        I will try updating direct X and all that though and see if that helps. Come to think of it, I have not done that in a long time.

                        Comment

                        Working...
                        X