Announcement

Collapse
No announcement yet.

ut3 (steam) stops responding

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ut3 (steam) stops responding

    i havent played ut3 in a long while, so im not sure how recent this issue is, but ive discovered that my UT3 (steam version) will just stop responding after just a minute or so of being on a menu screen or gameplay, forcing it to be closed with the task manager. when it stops responding, gpu usage will drop to zero for the process, and cpu usage will hold at 33%, if that's indicative of anything. ive validated the steam cache (100% fine), and deleted the cache and reinstalled from steam
    i have a retail CD, but i figure it's likely to have the same issue
    have also tried deleting the Documents\My Games\Unreal Tournament 3\ folder and all the assorted configs in it

    its a clean install of ut3 black off the steam servers, no mods, no custom maps, no mutators or player models

    directx and drivers are up to date as i can make them
    catalyst 11.12, MS visual c++ 2008 is current since everything on steam updates that, was suggested that i install the physx redist, and that (version 9.11.1107) fixed the non-responding issue for about a day and a half
    stuff that was installed or updated in that 1.5day interval while ut3 was running fine is a visual c++ 2008 redist because everything on steam installs that, reinstalled the physx package, cdburnerxp, notepad++, dropbox and foxit reader all got updated

    hardware's more than sufficient, turned off unnecessary programs, stopped some non-windows services.
    i dont have kapersky installed as per http://forums.steampowered.com/forum....php?t=1809271 (i use MSE)

    ut3 launch log here: http://dl.dropbox.com/u/446932/Launch.log

    Processor: AMD Athlon(tm) II X3 445 Processor (3 CPUs), ~3.1GHz
    Memory: 4096MB RAM
    Hard Drive: 750 GB Total
    Video Card: XFX Radeon HD 5750
    Monitor: Acer G235HAbd 23'' WideScreen LCD
    Sound Card: Speakers (High Definition Audio Device)
    Speakers Headphones: Logitech S120
    Keyboard: Microsoft SideWinder X4 Keyboard (IntelliType Pro)
    Mouse: Microsoft USB IntelliMouse Optical (IntelliPoint)
    Mouse Surface: Razer Vespula
    Operation System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110622-1506)
    Motherboard: ASRock M3A770DE


    any bright ideas are welcome

    #2
    im guessing ut3 isnt (officially) supported anymore. shame.

    Comment


      #3
      My only suggestion is to delete UT3 completely through steam, and then reinstall it again.

      It seems like it might be a hardware/software issue on your end, because UT3 works just fine here. Steam hasn't changed UT3 for a long time now, so it's the same as it has ever been since the last patch.

      Have you done anything different to your computer? Did you accidentally set your computer into "power saving mode"?

      Edit: Also, you have some warnings with your log, which indicates bad/broken mods or a bad install:

      Warning: USkeletalMeshComponent::InitArticulated : No PhysicsAsset defined for UTFrontEnd.TheWorld:PersistentLevel.UTCustomChar_P review_0.SkeletalMeshComponent_0 with skeletalmesh CH_TwinSouls_Cine.Mesh.SK_CH_TwinSouls_Cine_Female A
      Warning: USkeletalMeshComponent::InitArticulated : No PhysicsAsset defined for UTFrontEnd.TheWorld:PersistentLevel.UTCustomChar_P review_1.SkeletalMeshComponent_11 with skeletalmesh CH_IronGuard_Male.Mesh.SK_CH_IronGuard_MaleA
      Warning: USkeletalMeshComponent::InitArticulated : No PhysicsAsset defined for UTFrontEnd.TheWorld:PersistentLevel.UTCustomChar_P review_2.SkeletalMeshComponent_22 with skeletalmesh CH_IronGuard_Male.Mesh.SK_CH_IronGuard_MaleA
      Warning: USkeletalMeshComponent::InitArticulated : No PhysicsAsset defined for UTFrontEnd.TheWorld:PersistentLevel.UTCustomChar_P review_3.SkeletalMeshComponent_33 with skeletalmesh CH_IronGuard_Male.Mesh.SK_CH_IronGuard_MaleA
      Warning: USkeletalMeshComponent::InitArticulated : No PhysicsAsset defined for UTFrontEnd.TheWorld:PersistentLevel.UTCustomChar_P review_4.SkeletalMeshComponent_44 with
      And this also looks ominous:

      Log: URB_BodyInstance::InitBody : Could not create new Shape: Actor: StaticMeshActor_1292 Component: StaticMeshComponent_128 StaticMesh: HU_Deco2.SM.Mesh.S_HU_Deco_SM_SignWarning02
      Log: FKAggregateGeom::InstanceNovodexGeom: (Actor: StaticMeshActor_1294 Component: StaticMeshComponent_130 StaticMesh: HU_Deco2.SM.Mesh.S_HU_Deco_SM_Sign04) No geometries in FKAggregateGeom.
      Log: URB_BodyInstance::InitBody : Could not create new Shape: Actor: StaticMeshActor_1294 Component: StaticMeshComponent_130 StaticMesh: HU_Deco2.SM.Mesh.S_HU_Deco_SM_Sign04
      Log: FKAggregateGeom::InstanceNovodexGeom: (Actor: StaticMeshActor_750 Component: StaticMeshComponent_101 StaticMesh: HU_Deco2.SM.Mesh.S_HU_Deco_SM_Sign05) No geometries in FKAggregateGeom.
      Log: URB_BodyInstance::InitBody : Could not create new Shape: Actor: StaticMeshActor_750 Component: StaticMeshComponent_101 StaticMesh: HU_Deco2.SM.Mesh.S_HU_Deco_SM_Sign05
      Log: FKAggregateGeom::InstanceNovodexGeom: (Actor: StaticMeshActor_863 Component: StaticMeshComponent_103 StaticMesh: HU_Deco2.SM.Mesh.S_HU_Deco_SM_SignWarning01) No geometries in FKAggregateGeom.
      Log: URB_BodyInstance::InitBody : Could not create new Shape: Actor: StaticMeshActor_863 Component: StaticMeshComponent_103 StaticMesh: HU_Deco2.SM.Mesh.S_HU_Deco_SM_SignWarning01
      PerfWarning: InstanceGeom: 4.709255 ms - 367 Convex, Terrain 0.000000 ms, PerTriSM 3.030274 ms, InitArticulated 0.000000 ms, BodyInst Alloc 3.531460 ms, InitBody 37.695263 ms
      PerfWarning: NxActor Creation: 28.561410 ms
      Unfortunately your log file doesn't show the actual event of your crash, so a direct reason for your problems isn't given.

      Also, these lines worry me as well, but I don't know if these are normal or not.

      Init: IsOnBattery: 0
      Init: BatteryLevel: -1
      ...
      Init: GPU DeviceID not found in ini.
      And furthermore, your CPU is detected as x64, but you are running Windows Vista. Can Vista even run in x64?

      Comment


        #4
        gameslaya, thanks for at least responding.

        OS is win7x64, not vista.

        again, fresh reinstall off steam, no mods or other custom content
        only config change is 1024x768xfullscrene -> 1600x900xwindowed, turned on vsync & turned off bloom
        http://dl.dropbox.com/u/446932/Launch.log fresh launch log
        12.1 catalyst drivers now too

        Comment


          #5
          Hm, the Windows Vista line appears normal, since Win 7 was built after UT3.

          I'm comparing your log with mine, and here are the major inconsistencies:


          YOURS
          Init: NumLogicalProcessors: 3
          Init: NumPhysicalProcessors: 8195
          Init: CoresPerProcessor: 8195

          MINE
          Init: NumLogicalProcessors: 8
          Init: NumPhysicalProcessors: 8
          Init: CoresPerProcessor: 8
          8195 Physical Processors? Is that even normal? Maybe you are doing overclocking on your CPU, which is definitely not recommended for UT3.


          MINE
          Init: IsOnBattery: 0
          Init: BatteryLevel: 100

          YOURS
          Init: IsOnBattery: 0
          Init: BatteryLevel: -1
          Again, the battery thing. I'm running off a laptop, so yours might be fine if you are running of a desktop PC.


          Warning: USkeletalMeshComponent::InitArticulated : No PhysicsAsset defined for UTFrontEnd.TheWorld:PersistentLevel.UTCustomChar_P review_0.SkeletalMeshComponent_0 with skeletalmesh CH_TwinSouls_Cine.Mesh.SK_CH_TwinSouls_Cine_Female A
          Warning: USkeletalMeshComponent::InitArticulated : No PhysicsAsset defined for UTFrontEnd.TheWorld:PersistentLevel.UTCustomChar_P review_1.SkeletalMeshComponent_11 with skeletalmesh CH_IronGuard_Male.Mesh.SK_CH_IronGuard_MaleA
          Warning: USkeletalMeshComponent::InitArticulated : No PhysicsAsset defined for UTFrontEnd.TheWorld:PersistentLevel.UTCustomChar_P review_2.SkeletalMeshComponent_22 with skeletalmesh CH_IronGuard_Male.Mesh.SK_CH_IronGuard_MaleA
          Warning: USkeletalMeshComponent::InitArticulated : No PhysicsAsset defined for UTFrontEnd.TheWorld:PersistentLevel.UTCustomChar_P review_3.SkeletalMeshComponent_33 with skeletalmesh CH_IronGuard_Male.Mesh.SK_CH_IronGuard_MaleA
          Warning: USkeletalMeshComponent::InitArticulated : No PhysicsAsset defined for UTFrontEnd.TheWorld:PersistentLevel.UTCustomChar_P review_4.SkeletalMeshComponent_44 with skeletalmesh CH_IronGuard_Male.Mesh.SK_CH_IronGuard_MaleA
          And these lines here I don't have on my end. I'm unsure what to do here, except to uninstall the game completely, like with REVO uninstaller or something. You know, get rid of all registry entries and leftover files.

          And scrolling through the rest of your log file, it does appear to cut off right in the middle of things:

          Log: Begin Async loading packages for Family 'LIAM':
          Log: - CH_Corrupt_Arms
          Log: Flushing async loaders.
          Log: Family Asset Package Loaded: CH_Corrupt_Arms_SF
          Log: CONSTRUCTIONING: LoadFamilyAsset (
          If I had a guess, it might be something to do with your physical processors being at 8195, perhaps causing a bug to proliferate until the game crashes.

          If you want to look at my log file, here it is: http://dl.dropbox.com/u/38203857/Launch.log

          Keep in mind that I'm running a lot of mods, and my previous play time was a long time, which makes for a longer log file on my end.

          Comment


            #6
            Originally posted by Gameslaya View Post
            Hm, the Windows Vista line appears normal, since Win 7 was built after UT3.
            8195 Physical Processors? Is that even normal? Maybe you are doing overclocking on your CPU, which is definitely not recommended for UT3.
            Again, the battery thing. I'm running off a laptop, so yours might be fine if you are running of a desktop PC.

            3 cores, no OC.
            desktop, no battery (well, UPS, but that doesnt count).


            keeping at it, right now looking like there's a confict with xfire... though i have all the xfire in-game stuff turned off..

            Comment


              #7
              Try this:

              Navigate to

              "C:\Program Files (x86)\Steam\steamapps\common\Unreal Tournament 3\Binaries\UT3.exe"
              Right click on it, and create shortcut. Drag this shortcut to the desktop.

              Right click on the shortcut, and select properties.

              Under the "Target" section, add -onethread to the end of the line, like so:

              "C:\Program Files (x86)\Steam\steamapps\common\Unreal Tournament 3\Binaries\UT3.exe" -onethread
              This is a trick that does magic with the CPU, I think.

              Comment

              Working...
              X