Ok now i know there are like 100000 post's online about this issue with fixes and what not, yes i have looked on this site and others for a solution or i would not be here posting this. so all that aside let me tell you guys whats going. i want to play UT3 co-op campaign with my family that lives in oregon, i in CA. i bought the game for both of them through steam. all are black edition so they all have the titan mod installed already and all games are running version 2.1. At first nothing worked so i went to the net and found you needed to forward some ports which i did and then everything was fine and they could see my game and joined and played, and everything was fine. the very next day we go to resume from where we left off and no-one can see my game. i changed nothing in the time since we first played. i also cant see any games they make. im not running a router its a direct connection to my cable modem. here is a list of the ports i have opened in an attempt to get this P.O.S working.

PLEASE DON'T TRY AND LINK ME TO THIS I HAVE ALREADY READ IT AND TRIED IT AND IT DOESN'T WORK EITHER. ( http://forums.epicgames.com/threads/...-coop-campaign )
( http://forums.epicgames.com/archive/.../t-665969.html )

7778 - UDP
7787 - UDP
13000 - UDP
27900 - UDP
3783 - Both (TCP and UDP)
TCP - 3783, 6667, 28900, 29900, 29901

i have disabled my antivirus altogether, and dropped windows firewalls/ tried with windows firewalls on with exceptions and open ports.

so about an hour or so trying to figure it out i tried to just have us both connect to an online game that we both saw on the master-list. like a death-match or something. we found and tried to connect. However if i connected first then his computer would automatically say Failed to connect when trying to connected to the one i was already in and visa-versa. so i have no idea WTF is going on and its really stupid. worked for one day then all this garbage i just don't understand...

P.S my modem is an (ARRIS: MODEL:WBM750 A/NA) with no way of actually accessing any setting within it directly that i have found (like port forwarding or anything like that)

UPDATED: set up my router port forwarded all those as well. nothing... and then set it up for DMZ and still nothing.............