Announcement

Collapse
No announcement yet.

HD 5770 fps issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HD 5770 fps issues

    Phenom II x2 3.2Ghz
    3Gig DDR3 1600
    HD 5770 Hawk 1gb
    Windows 7 x64

    most sites have the 5770 benched at around 80fps at 1920x1080 with 4x AA and 16x AF (though unreal doesn't technically support AA).

    Im getting at most 60 and it drops as low as 28fps (using tab-> "stat fps").
    In hallways an the like its a solid 60 but in more open areas it drops. I have everything checked and turned to max, post processing set to vivid.

    I tried setting catalyst AI to advanced and un-checking smooth fps and per frame thread what ever that has to do with mouse/keyboard response time. and now it manages to only go as low as the mid 30's but the point being I should be getting in the 80's

    It seems to be limited to unreal 3. Metro 2033 runs silky smooth at max in dx10 mode even with AAA. Modern warfare runs silky smooth on max with 4x AA. crysis is smooth maxed with no AA. Dead Space just runs to **** fast, the game speed is at least 3x normal though it does make it a lot more intense. anyway the point is everything runs perfect maxed at 1920x1080 but unreal 3 is most definitely not.

    Any help is appreciated.

    Edit: Using steam version of UT3 so its fully updated.

    #2
    check steam setting may interfare with gcards settings...maby...

    Comment


      #3
      Issue is not the 5770 its the Phenom II x2 @ 3.2Ghz

      If you can overclock that to 3.6+ you might get a decent min framerate on the stock maps. UT3 requires a good CPU not a good GPU.

      That for min frame rate. For max frame rate disable framerate smoothing and vsync in advanced settings, then change network connection to Lan under player settings.

      Comment


        #4
        The game seems to be broken since april 2010, my performance decreased a lot since then, althougt all the other games are running smooth.
        Hell, i was running the game better on E4300 @3.2ghz & 260GTX than on Q6700@3.5 and 260/6870.
        My advice set details to minimum, borderlands seems to have the same problem, i think gamespy is the guilty for that, though i haven't find a fix yet.
        Random for a game that is almost 4 years old, ut should fly on cpu, that's not the issue.

        Comment

        Working...
        X