Announcement

Collapse
No announcement yet.

What's wrong with the game performance?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    What's wrong with the game performance?

    Greetz.
    I have noticed that game performance is very poor since the begining of april and i don't know what is wrong.
    The interesting thing is that i am not the only one experiencing this problem, all the people i know have ecountered lower framerates like -50%.
    What is wrong? it's gamespy fault again, i mean dude wtf.
    First off all i have noticed far to decreased performance on deck, the average was 100, now it is 60 lol.

    And a little picture, coz a pic is like 1000 words.



    Here i had 95+fps on average, now suddenly it droped to 59. The system hasn't changed a bit, the other games run with the same performance as well, in other words ut3 is the only game where me, and not only me, all the other guys i know have this problem.
    The pc is a Q6700 @3.5, 4gb and 260GTX with the latest drivers.

    Well nuff, said. I don't understand what happened...

    #2
    This is not new but ut3 works poorly on the dual or quad core.
    Personally I run ut3 with this shortcut "C:\Program Files\Unreal 3\Binaries\UT3.exe Tournament" - onethread, which makes me wins + 30fps. You can try, but nothing is guaranteed. What is certain is that it is not your graphics card.

    Comment


      #3
      Got your private message Unit. So here's my answer:

      Frame dips on deck are normal. EVERYONE gets them. Shang is even worse (courtyard area). There is only one game option that will effect these dips. Oneframethreadlag. If disable (that means a filled box in advanced options) your frame rates will dip significantly more. The upside to disabling "oneframethreadlag" is that you will have much less input lag for more responsive game play. If this options has not been changed my guess is you are just getting good enough at the game to notice the dips.

      This will not be a game spy issue nor a video card issue. It is a cpu cache issue.

      If you want to see why this is happening try type "stat engine" in your console (F10). Now walk around and notice that when your frame rate dips the Static Mesh Tris (4th from the bottom) will be much higher than when your fps are lower.

      Because UT3 was optimized for console it relies very heavily on the CPU. The static meshes seem to eat up cpu cache thereby limiting your frame rate. The more cpu cache you have the faster the game will run. The less static meshes in a map, the faster your game will run.

      The -onethread option can help performance with some CPUs. I know the i5/i7/phenom/phenom II cpus under windows 7 run slower with the -onethread option. Older CPUs have been reported to benefit from it however so it's worth a shot. This may have something to do with L3 cache vs l2 cache.

      Here are the UTEngine.ini changes I make to improve game performance/visibility. Remember the file you are modifying is located in your \Documents\My Games\Unreal Tournament 3\UTGame\Config folder.


      Code:
      [Engine.Engine]
      bStaticDecalsEnabled=False
      bDynamicDecalsEnabled=False
      bForceStaticTerrain=True
      bUsePixelShaderComplexity=False
      bUseAdditiveComplexity=False
      PrimitiveProbablyVisibleTime=100.0
      PercentUnoccludedRequeries=0.001
      
      [Engine.GameEngine]
      bForceStaticTerrain=True
      PrimitiveProbablyVisibleTime=100.000000
      PercentUnoccludedRequeries=0.001000
      
      [SystemSettings]
      [SystemSettings]
      StaticDecals=False
      DynamicDecals=False
      DynamicLights=True
      DynamicShadows=True
      LightEnvironmentShadows=True
      CompositeDynamicLights=False
      DirectionalLightmaps=True
      MotionBlur=False
      DepthOfField=False
      Bloom=False
      QualityBloom=False
      Distortion=False
      DropParticleDistortion=False
      SpeedTreeLeaves=False
      SpeedTreeFronds=False
      OnlyStreamInTextures=True
      LensFlares=False
      FogVolumes=False
      FloatingPointRenderTargets=True
      Trilinear=True
      OneFrameThreadLag=False
      UseVsync=False
      UpscaleScreenPercentage=True
      Fullscreen=False
      AllowD3D10=False
      EnableHighPolyChars=False
      SkeletalMeshLODBias=0
      ParticleLODBias=1
      DetailMode=0
      ShadowFilterQualityBias=0
      MaxAnisotropy=16
      MaxMultisamples=1
      MinShadowResolution=32
      MaxShadowResolution=512
      ResX=Your native x resolution (1920 for example)
      ResY=Your native y resolution (1200 for example)
      ScreenPercentage=100.000000
      SceneCaptureStreamingMultiplier=1.000000
      FoliageDrawRadiusMultiplier=1.000000
      ShadowTexelsPerPixel=1.000000

      Hopefully that helps.

      Comment


        #4
        On Vista and Win 7 those dips are normal. The -onethread solves the problem. Essentially, dual core works pretty much bad on those OS-es

        On XP sp3 32bit there is no problems whatsoever with duals and quads

        Comment


          #5
          I have win7 dual core CPU and my UT3 runs like butta on almost everything turned up high. I don't use the -onethread option either.

          -dual core 6850
          -8 gigs ram
          -win7 X64
          -nvidia 9800 GTX PCI express one gig ram

          Could also be a case of too much different hardware out there so it's not going to run the same on every rig.

          Comment


            #6
            Originally posted by Designer0101 View Post
            On Vista and Win 7 those dips are normal. The -onethread solves the problem. Essentially, dual core works pretty much bad on those OS-es

            On XP sp3 32bit there is no problems whatsoever with duals and quads
            On all operating systems dips are normal if you run the game with oneframethreadlag disabled.

            Comment

            Working...
            X