Announcement

Collapse
No announcement yet.

Mouse won't aim in PC version

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Mouse won't aim in PC version

    Whenever I start playing UT3 now it won't let me aim with the mouse; no up, down, left or right. Seems to think there's a controller connected, but I don't even own one (and never have with this computer); is there a way to fix this?

    I have controller/gamepad disabled, I've installed all the latest patches, and I've looked through the settings (and had to manually reset all the other controls to where they should be on the keyboard).

    When I was last playing (probably November; I've since moved back with my parents) everything was working fine and the only thing that's changed now is that its been connected to the internet for more than a couple of minutes to update.

    Any help definitely appreciated!

    #2
    I had the same problem in one instance when I was messing with Console commands trying to show my FPS and my mouse suddenly stopped working ingame.

    However I re-started the game and everything was fine again.


    I don't really know how to fix Your problem, but I can tell you that UT3 has serious problems recognizing non-360 controllers for the game, having a non-360 controller even just plugged in can make the game crash in launch.

    The solution I found to this was using the latest 360-controller emulator for Windows in UT3, so the game recognizes my controller but "thinks" it's a 360 one so it has no problems launching (though I still have to fix the connection problems the game has)

    That's all I can tell you about this issue, I really hope it was useful to you in some way.

    Comment


      #3
      Thanks Leox; my problem's actually to do with using the PC version, I only want to run it with keyboard and mouse and as I said, I don't even own a controller! Its strange though, cause it worked just fine before.

      I've tried restarting and so on, no dice, but thanks anyway.

      Comment

      Working...
      X