Announcement

Collapse
No announcement yet.

What patches do I need for old retail?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    What patches do I need for old retail?

    Hey, I've had UR3 for some time and heard there are mods now for it. So I just reinstalled. Now I see there are several new patches and a map pack. Do I just need the 2.1 patch and map pack or do I need to install them all?

    #2
    just take the newest. older ones are included in newer versions. make sure that you first install the patch and AFTER that the titan pack.

    Comment

    Working...
    X