No announcement yet.

New Patch Makes Game Unplayable - Windows 7??

  • Filter
  • Time
  • Show
Clear All
new posts

    New Patch Makes Game Unplayable - Windows 7??

    Sorry for the vague title, I'll get to the point after I state that I did do some research to find a solution for this particular problem but to no avail. Mostly because this is a very odd problem, I have never seen in a video game before. I'll try to be descriptive to avoid unnecessary questioning.


    So I install the game using the same disk I've always used. I run a test play to make sure everything is pie (cuz cake just isn't honest enough) It runs beautifully. No problems. However, upon remembering earlier installments of this title, I realize that offline mode has no save game option.

    The new patch (patch 5 v2.1) however, allows the game to be saved in offline mode. I download it, install it, and ran the game. Now comes the strangest outcome of a patch install I've ever seen. (Assuming, thats the reason this happened)

    First off, the endless stream of splash screens displaying everything related to UT3 that plays at the launch of the game, shows no video. I can hear them, and I can click through them like normal, but the screen is just black.

    WAIT! It gets worse...

    After the splash screens, the game freezes for about 15 seconds, then shows the log in screen. Everything is peachy. It's all smooth and no problems are visible. I go to play an offline single player campaign. Again, everything loads quickly and the game starts right up...'s the REAL problem.

    Now, I would be ok with this if the splash screens not showing up was the ONLY problem, but that is not the case. While in-game, the only thing that works is the movement commands. On the keyboard, only the A, S, D, W, SPACE, and TAB keys work. The rest of the keys (even Esc) do nothing. On the mouse, scrolling the center wheel down to change weapons works and clicking the mouse wheel down causes Reaper to jump. (Scrolling up does nothing.) The primary and secondary fire (right and left click) do absolutely nothing as well. (which is odd seeing as how they worked though the splash screens, and menu navigation)

    ALT+F4 doesn't even work. The only way to quit out of the game is to either use TAB to bring up the console window and type "exit", hit ALT+TAB to minimize and kill the program using Windows, or use CTRL+ALT+DEL to bring up the Task Manager and kill UT3.exe's process.

    Due to the fact that it takes so long, I am trying to refrain from re-installing the game and the patch unless it's my last, or easiest solution.

    I have tried compatibility mode, and run as administrator and all that. As well as tampered with the gamepad settings in UT3 (remember that the mouse and keyboard fully work in the menus. It's only in-game that they stop functioning correctly.

    The only hunch I have so far is that it's software related and UT3's new patch doesn't like Windows 7 x64. Which would be odd seeing as how the game worked perfectly fine before the patch.

    If anyone has a fix for this issue, please let me know. If you have any further questions, I'll be checking back regularly.

    Now, on to the PC stats to avoid that from being requested...

    Alienware Area-51 m9750 notebook PC
    Operating System ------- Windows 7 Ultimate x64
    Memory ----------------- 2gigs DDR2 RAM*
    Processor --------------- Intel Core 2 Duo 2.0Ghz
    Graphics Processing Unit - 512mb nVidia GeForce 8600m**

    It's a pretty watered down computer for an Alienware, but it gets the job done.

    * - I had 1gig (2x 512mb DDR2 RAM) when the computer arrived. I purchased 4gigs (2x 2gig DDR2 RAM) a few months after from After only about a month into owning the new sticks, one of them failed. I lost the receipts, packaging, and old 512mb sticks in the process of moving so I am stuck with half the RAM I payed for.

    ** - This is NOT SLI. Like I said, watered down.

    Alas, the issue has been resolved. For some reason, after I had installed the patch, the input settings had been reconstructed for a controller. The main and secondary fire were set to left and right trigger. Among other settings that had been configured to what I'm assuming is an X-Box controller.

    On that note, by god who in their right mind would possibly WANT to play a first person shooter with a controller. Without mouse support, it just seems pointless.


      Controller? That would be:Console players . We PC gamers see alot of console trash being implemened in our favourite games, because of the market. I cant blame epic for trying to make money.