Announcement

Collapse
No announcement yet.

UT3 Frames per Second Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UT3 Frames per Second Problems

    I've gotten to the point where I could throw up playing this game on lowest settings and I still get between 30fps-50fps. I want 60+.

    Specs.(Yeah I know I pasted from Xfire)

    Manufacturer: Dell Inc.
    Processor: Intel(R) Pentium(R) 4 CPU 2.80GHz (2 CPUs)
    Memory: 2558MB RAM
    Hard Drive: 325 GB Total
    Video Card: NVIDIA GeForce 9500 GT
    Monitor: Plug and Play Monitor
    Sound Card: SigmaTel Audio
    Speakers/Headphones: Logitech
    Keyboard: Razer
    Mouse: Razer
    Mouse Surface: SmooTh
    Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.080814-1236)

    #2
    Want 60+ frames? Upgrade that cpu, motherboard and maybe your video card, start with the first two and see how much a difference it is first!

    Comment


      #3
      I upgrade one thing and it made massive difference.

      Comment


        #4
        Originally posted by NovaZzZ View Post
        I've gotten to the point where I could throw up playing this game on lowest settings and I still get between 30fps-50fps. I want 60+.

        Specs.(Yeah I know I pasted from Xfire)

        Manufacturer: Dell Inc.
        Processor: Intel(R) Pentium(R) 4 CPU 2.80GHz (2 CPUs)
        Memory: 2558MB RAM
        Hard Drive: 325 GB Total
        Video Card: NVIDIA GeForce 9500 GT
        Monitor: Plug and Play Monitor
        Sound Card: SigmaTel Audio
        Speakers/Headphones: Logitech
        Keyboard: Razer
        Mouse: Razer
        Mouse Surface: SmooTh
        Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.080814-1236)

        HUH?! I have dual 1.9 amd
        3gig ram
        nvidia 8600gt

        and i benchmark at 40+ on MAX, if i tweak the hell out of it i can get 80-100's
        you need to manage ya system better or read tweak guides

        Comment


          #5
          The main problem is your cpu,they made p4 2.8ghz.. like.. 6 years ago it's no wonder ut3 will run like **** on that cpu..

          Get a new motherboard,ram and cpu and it will run ok again.

          Comment


            #6
            I might as well get a new PC if I'm going to get a new motherboard and CPU.

            Comment


              #7
              Graphics card aswell GTX GTS 250+ expensive depending what you get but they come with 1Gb or 2GB onboard. I had to by a new powersupply with my 825w codegen save some money doing it myself.

              Good luck mate.

              Comment

              Working...
              X