Announcement

Collapse
No announcement yet.

Unreal Engine and LOD

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Unreal Engine and LOD

    Hey guys,
    This is the last place to ask my question... Im playing the game that uses Unreal Engine, so Im sure you will know more about it than me.
    The thing that bothers me is LOD... 50% of textures are low ress even when Im standing next to them, I need to "kiss" them with my camera to see the high ress ones... its so annoying, 'cause the game runs smooth and I just want to have high ress textures no matter the distance ;/

    This game has no graphic settings (you can only set the screen resolution) so I played a bit with the config files. I found one, with many useful options and even some LOD ones, but Im a newbie so I just dont know what values to set. So, here are the options I found:

    SkeletalMeshLODBias=0
    ParticleLODBias=0

    Changing these two doesnt seem to have a strong effect (from what I read on other sites, it can be set -2,-1,0,1,2)

    Found also these:
    TEXTUREGROUP_World=(MinLODSize=1,MaxLODSize=4096,L ODBias=0)
    TEXTUREGROUP_WorldNormalMap=(MinLODSize=1,MaxLODSi ze=4096,LODBias=0)
    TEXTUREGROUP_WorldSpecular=(MinLODSize=1,MaxLODSiz e=4096,LODBias=0)
    TEXTUREGROUP_Character=(MinLODSize=1,MaxLODSize=40 96,LODBias=0)
    TEXTUREGROUP_CharacterNormalMap=(MinLODSize=1,MaxL ODSize=4096,LODBias=0)
    TEXTUREGROUP_CharacterSpecular=(MinLODSize=1,MaxLO DSize=4096,LODBias=0)
    TEXTUREGROUP_Weapon=(MinLODSize=1,MaxLODSize=4096, LODBias=0)
    TEXTUREGROUP_WeaponNormalMap=(MinLODSize=1,MaxLODS ize=4096,LODBias=0)
    TEXTUREGROUP_WeaponSpecular=(MinLODSize=1,MaxLODSi ze=4096,LODBias=0)
    TEXTUREGROUP_Vehicle=(MinLODSize=1,MaxLODSize=4096 ,LODBias=0)
    TEXTUREGROUP_VehicleNormalMap=(MinLODSize=1,MaxLOD Size=4096,LODBias=0)
    TEXTUREGROUP_VehicleSpecular=(MinLODSize=1,MaxLODS ize=4096,LODBias=0)
    TEXTUREGROUP_Cinematic=(MinLODSize=1,MaxLODSize=40 96,LODBias=0)
    TEXTUREGROUP_Effects=(MinLODSize=1,MaxLODSize=4096 ,LODBias=0)
    TEXTUREGROUP_Skybox=(MinLODSize=1,MaxLODSize=4096, LODBias=0)
    TEXTUREGROUP_UI=(MinLODSize=1,MaxLODSize=4096,LODB ias=0)
    TEXTUREGROUP_LightAndShadowMap=(MinLODSize=1,MaxLO DSize=4096,LODBias=0)
    TEXTUREGROUP_RenderTarget=(MinLODSize=1,MaxLODSize =4096,LODBias=0)

    It seems that these settings are responsible somehow for the LOD of textures tho I dont know how it is working. When I change the MinLODSize to 256 and Max to 512 of the first 3 strings, many wolrd textures (like ground and plant's leaves) are set to their highest texture resolution no matter the distance, but some objects, like parts of vehicles (not the vehicle you can use, just some random world object) are set to their lowest texture res . Does anyone know, how to tweak those settings to turn off that **** LOD? Or maybe there is a command that I can add to the config file that will disable it (like disableLOD=True or something)? Please help.

    PS.****, I think I placed my first thread in wrong place (modding and scripting) so if any admins will be around, please delete it. Sorry for the trouble.
Working...
X