Announcement

Collapse
No announcement yet.

Custom map with custom content crashes at loading

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Custom map with custom content crashes at loading

    I've made a new custom map for UT3 (not the first, by any means, but the first with custom scripts and external packages). I've published it successfully, but UT3 crashes when loading the map and I have no clue as to why.

    Code:
    ScriptLog: UTUIFrontEnd: Starting game with no splitscreen: Removing all but 1 LocalPlayer.
    ScriptLog: UTUIFrontEnd: Starting Game...open WAR-T_FSCnCRedAlert2_V1?game=UTGameContent.UTOnslaughtGame_Content?MaxPlayers=16?MinNetPlayers=0?NumPublicConnections=16?NumPrivateConnections=0?NumOpenPublicConnections=0?NumOpenPrivateConnections=0?bShouldAdvertise=True?bIsLanMatch=False?bUsesStats=True?bAllowJoinInProgress=True?bAllowInvites=True?bUsesPresence=True?bAllowJoinViaPresence=True?bUsesArbitration=False?bIsDedicated=False?bIsListPlay=False?OwningPlayerName=?GameMode=2?Difficulty=1?PureServer=1?LockedServer=0?Campaign=0?ForceRespawn=1?GoalScore=3?TimeLimit=20?ServerDescription=?NumPlay=16?name=Tsumetai?alias=Tsumetai
    Log: Browse: WAR-T_FSCnCRedAlert2_V1?name=Tsumetai?team=255?game=UTGameContent.UTOnslaughtGame_Content?MaxPlayers=16?MinNetPlayers=0?NumPublicConnections=16?NumPrivateConnections=0?NumOpenPublicConnections=0?NumOpenPrivateConnections=0?bShouldAdvertise=True?bIsLanMatch=False?bUsesStats=True?bAllowJoinInProgress=True?bAllowInvites=True?bUsesPresence=True?bAllowJoinViaPresence=True?bUsesArbitration=False?bIsDedicated=False?bIsListPlay=False?OwningPlayerName=?GameMode=2?Difficulty=1?PureServer=1?LockedServer=0?Campaign=0?ForceRespawn=1?GoalScore=3?TimeLimit=20?ServerDescription=?NumPlay=16?alias=Tsumetai
    Log: Award progress has now been fully reenabled!
    Log: LoadMap: WAR-T_FSCnCRedAlert2_V1?name=Tsumetai?team=255?game=UTGameContent.UTOnslaughtGame_Content?MaxPlayers=16?MinNetPlayers=0?NumPublicConnections=16?NumPrivateConnections=0?NumOpenPublicConnections=0?NumOpenPrivateConnections=0?bShouldAdvertise=True?bIsLanMatch=False?bUsesStats=True?bAllowJoinInProgress=True?bAllowInvites=True?bUsesPresence=True?bAllowJoinViaPresence=True?bUsesArbitration=False?bIsDedicated=False?bIsListPlay=False?OwningPlayerName=?GameMode=2?Difficulty=1?PureServer=1?LockedServer=0?Campaign=0?ForceRespawn=1?GoalScore=3?TimeLimit=20?ServerDescription=?NumPlay=16?alias=Tsumetai
    ScriptLog: Desc: Warfare
    Log: Starting memory preloaded movie...UT_loadmovie5 ()
    Log: Waiting for memory preloaded movie to finish loading ...
    Log: Playing movie [UT_loadmovie5]
    Log: Got memory preloaded movie event!!!
    Log: Unmute bink movie
    Log: ClearAllAnimSetLinkupCaches - Took 10.20ms
    ScriptLog: Setting image img_Necris01 to visible
    ScriptLog: Clearing online delegates for UTEntryPlayerController_0 (Player:LocalPlayer_0)
    Log: Virtual  memory allocation size: 182.71 MByte (191590400 Bytes)
    Log: Physical memory allocation size:   0.00 MByte (0 Bytes)
    Log: A mod has been loaded via file 'WAR-T_FSCnCRedAlert2_V1_LOC_int', award progress has been disabled...
    Critical: appError called:
    Critical: Assertion failed: GIsEditor || GetSuperClass() || this==UObject::StaticClass() [File:.\Src\UnClass.cpp] [Line: 1975]
    Unable to bind CnCRedAlert2.UTVehicle_Mirage at this time
    Stack: 
    Critical: Windows GetLastError: The operation completed successfully. (0)
    Log: === Critical error: ===
    Assertion failed: GIsEditor || GetSuperClass() || this==UObject::StaticClass() [File:.\Src\UnClass.cpp] [Line: 1975]
    Unable to bind CnCRedAlert2.UTVehicle_Mirage at this time
    Stack:
    It's important I get this resolved ASAP.

    #2
    I have better luck when I use the unrealfrontend.exe to cook maps with custom content. Make sure to list all packages required for your map in the package list, then do a cook, possibly 'full recook'. The 'full recook' clears out your published folder so use caution.

    I've had the game crash on my custom content and it was because I copied the uncooked packages into the cooked folder instead of letting the cooker cook them and put them their.

    Comment


      #3
      That did NOT help. Now I can't even cook the map without it crashing at:
      Code:
      Cooking [Seekfree] WAR-T_FSCnCRedAlert2_V1
      The fix which was posted in another topic, which involved downloading a new GlobalPersistentCookerData.upk isn't helping anymore.

      Comment


        #4
        Bump. Come on, this is important. I need to get this fixed.

        Comment


          #5
          Bump. I got the map to compile again by taking the Stealthbender out of the map. But now I'm back to the first problem where the map crashes at the map loading screen.

          I need to get this resolved. Is there no one here with a solution?

          Comment


            #6
            BUMP!

            If no one here has any advice, can you at least point me somewhere else that maybe could help?

            Comment


              #7
              Bump. Bump in the night.

              Comment


                #8
                did you put this file CnCRedAlert2 in Publish
                any custom files you added have to be in the publish folder too
                CnCRedAlert2 is a vehicle mut so add that in the script folder in publish then try again

                if it works you have to include those files with your map

                Comment


                  #9
                  That file was cooked and put into publish when I ran the front-end. And yes, it is in the Published\CookedPC\Script folder. For the record, that file is not a mutator. I made it.

                  The map runs fine in the editor's in-game test thing, and after I took out the Stealth Bender, it compiles fine it's when I go to run it in the actual game that it crashes.

                  Comment


                    #10
                    zip up your files and send me a link in a pm let me try

                    Comment


                      #11
                      heres your issue your vehicles are not made right you need to remake your vehicles so they appear in the game the only one that comes out is the scorpion so check your code
                      http://img51.imageshack.us/img51/388...iclescript.jpg

                      see the source of captain snarfs vehicles to fix your vehicles
                      http://files.filefront.com/SnarfVehi.../fileinfo.html
                      and this is the forum link for his vehicles so you can see which is which since he renamed them
                      http://forums.epicgames.com/showthread.php?t=600777


                      plus i see this in the log

                      Code:
                      Log: === Critical error: ===
                      Assertion failed: GIsEditor || GetSuperClass() || this==UObject::StaticClass() [File:.\Src\UnClass.cpp] [Line: 1975]
                      Unable to bind CnCRedAlert2.UTVehicle_Mirage at this time
                      Stack: 
                      
                      RaiseException() Address = 0x7c812afb (filename not found) 
                      CxxThrowException() Address = 0x78158e89 (filename not found) 
                      Address = 0xbb4f92   (filename not found) 
                      Address = 0xe8781b4c (filename not found) 
                      
                      Exit: Executing UObject::StaticShutdownAfterError

                      Comment


                        #12
                        .... You know .... I spent months making this map, I've battled this problem for more than a week, and I've waited for help here on this forum for much of that time, and this is all I get? "You did it wrong"?

                        *HEADDESK*

                        *HEADDESK**HEADDESK**HEADDESK**HEADDESK**HEADDESK*

                        Okay... I have a headache. But I'm calm now.

                        I've looked at his code, and I see no real differences between his and mine. I certainly don't see what I'm missing that his code has. As you said, my modified scorpion shows up fine, so why don't any of my others? Why do they show up fine in my UT game editor, but not yours? I've just spent a great deal of time modifying my scripts and map to change what I thought was the difference between his code and mine, and in the end, I sill have the exact same problem.

                        Code:
                        Log: LoadMap: WAR-T_FSCnCRedAlert2_V1?name=Tsumetai?team=255?game=UTGameContent.UTOnslaughtGame_Content?MaxPlayers=16?MinNetPlayers=0?NumPublicConnections=16?NumPrivateConnections=0?NumOpenPublicConnections=0?NumOpenPrivateConnections=0?bShouldAdvertise=True?bIsLanMatch=False?bUsesStats=True?bAllowJoinInProgress=True?bAllowInvites=True?bUsesPresence=True?bAllowJoinViaPresence=True?bUsesArbitration=False?bIsDedicated=False?bIsListPlay=False?OwningPlayerName=?GameMode=2?Difficulty=1?PureServer=1?LockedServer=0?Campaign=0?ForceRespawn=1?GoalScore=3?TimeLimit=20?ServerDescription=?NumPlay=16?alias=Tsumetai
                        ScriptLog: Desc: Warfare
                        Log: Starting memory preloaded movie...UT_loadmovie2 ()
                        Log: Waiting for memory preloaded movie to finish loading ...
                        Log: Playing movie [UT_loadmovie2]
                        Log: Got memory preloaded movie event!!!
                        Log: Unmute bink movie
                        Log: ClearAllAnimSetLinkupCaches - Took 13.44ms
                        ScriptLog: Setting image img_Reaper to visible
                        ScriptLog: Clearing online delegates for UTEntryPlayerController_0 (Player:LocalPlayer_0)
                        Log: Virtual  memory allocation size: 175.47 MByte (183996416 Bytes)
                        Log: Physical memory allocation size:   0.00 MByte (0 Bytes)
                        Log: A mod has been loaded via file 'WAR-T_FSCnCRedAlert2_V1_LOC_int', award progress has been disabled...
                        Critical: appError called:
                        Critical: Assertion failed: GIsEditor || GetSuperClass() || this==UObject::StaticClass() [File:.\Src\UnClass.cpp] [Line: 1975]
                        Unable to bind CnCRedAlert2.UTVehicle_Mirage_Content at this time
                        Stack: 
                        Critical: Windows GetLastError: The operation completed successfully. (0)
                        Log: === Critical error: ===
                        Assertion failed: GIsEditor || GetSuperClass() || this==UObject::StaticClass() [File:.\Src\UnClass.cpp] [Line: 1975]
                        Unable to bind CnCRedAlert2.UTVehicle_Mirage_Content at this time
                        Stack: 
                        
                        RaiseException() Address = 0x776f42eb (filename not found) [in C:\Windows\system32\kernel32.dll]
                        CxxThrowException() Address = 0x70c38e89 (filename not found) [in C:\Windows\WinSxS\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.3053_none_d08d7bba442a9b36\MSVCR80.dll]
                        Address = 0xbb4c52   (filename not found) [in C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe]
                        Address = 0xe870c94c (filename not found) 
                        Address = 0xe870c94c (filename not found) 
                        
                        Exit: Executing UObject::StaticShutdownAfterError
                        Exit: Executing UWindowsClient::ShutdownAfterError
                        Exit: Executing UWindowsClient::ShutdownAfterError
                        Exit: UALAudioDevice::ShutdownAfterError
                        Log: Shutting down FaceFX...
                        Log: FaceFX shutdown.
                        Exit: Exiting.
                        Exit: Name subsystem shutting down
                        Uninitialized: Log file closed, 05/15/09 19:19:45
                        I don't know what this means. I don't know what "unable to bind at this time" means. I don't know what it means by "filename not found at address blah blah blah". I don't know what file name it can't find or, more importantly, why.

                        Comment


                          #13
                          i tried cooking the map and i get alot of warnings in the editor log file about materials and i reopened the map and now the vehicles appear but still no go in instant action

                          Comment

                          Working...
                          X