No announcement yet.

Cooked a level, causes C++ runtime error

  • Filter
  • Time
  • Show
Clear All
new posts

    Cooked a level, causes C++ runtime error

    Okay, this is actually from my Rail Depot map that I made a while back. I noticed a few things that should be changed, so I made those changes and a few more.

    I cooked the map, but now when I tried playing it on my brother's computer it would constantly crash the game everytime I was near a certain area. When I cooked it for the PS3, somehow the userdata.jam file was an absurd 80 megs in size, when my earlier versions were 38, which better matches the normal file size. Then when I tried installing and playing that level, it corrupted my system, and when I tried to play UT3 it would instantly give me an error message and reboot my console. I had to erase all of the UT3 system data to get it working again, which also erased all my custom content.

    Now, the best clue that I have for this problem is the package Test\E3_Temp.upk, which uses a small grass static mesh that I use in my level. Everytime I cooked my level before, and sometime when I closed the editor, it tried to tell me that I had modified that package and it needed to save it. I never modified that package, so I told it not to save it.
    And today, during one of the times I had re-cooked it (I kept finding things I should change) I accidentally told it to save the package.
    I later found that it had created the package anew in my My Documents folders, both in the published and unpublished directories, and so I deleted them, rebuilt, and recooked, but still have the same problem. It still crashes the game on my brother's computer and still made an 80 meg userdata.jam. (I'm not going to even try installing it on my PS3 again.)

    It only crashes the game whenever the player gets to where they should see (and therefor the game should render) the grass meshes, between the building and the railroad tracks. However, as an odd note, when they are seen as part of the terrain in a different section of the map, they operate just fine and crash nothing.

    They don't crash anything on my computer when I'm in the editor, but it does crash just the same in the game. It give a visual c++ runtime error.

    On the off chance that this is actually a problem with just these computers, and also something wrong with my PS3 cooking data, I'm offering people to download the level to see if it bugs up their machines.


    I replaced the static mesh in my level with an alternate one and now the level does not crash the game. Nonetheless I would hope that someone from Epic could identify and fix the problem for the next update. It sound to me like the game not properly checking its resources before using them.


    The PS3 userdata.jam that I create still is 84 megs, and therefor probobly going to corrupt my UT3 system data again.