Announcement

Collapse
No announcement yet.

Weird BSP collision errors.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I fixed the problem by moving an edge slightly to the side on the 4uu grid. If I can recreate the problem, I'll put up a link with a bugged version. I did mess with the brush, but only to get it to align to the 32uu grid.

    Leave a comment:


  • replied
    Once you release your Alpha, please give a link here and tell where exactly you have the problem, OK? Maybe we will be more lucky.

    Another reason I have in mind: if you modified your brushes using the advanced edit mode (moving vertices, edges, faces) you could have screwed a brush somewhere. Check if those brushes contain all faces correctly.

    Leave a comment:


  • replied
    Well the brushes aren't overlapping, so it must be something else. I can't release the map yet as I am working in a mod team for the MSUC. I can't give away any details but the Alpha release will be very soon.

    Leave a comment:


  • replied
    It may be the case that some other objects generate very tiny BSP cuts around the 32uu grid element.
    Also, as suggested by Grayfox - you shouldn't have any double-empty or double-solid spaces. This may cause really strange effects.

    There may be lots of different causes, if you want some definite answer which will apply to your case explicitly, I would suggest you send someone (or make public) that part of your map so we can investigate....

    Leave a comment:


  • replied
    What do you mean by that? If you mean they are touching each other and their faces are parallel then yes

    Leave a comment:


  • replied
    are the BSPs flush with one another?
    are their statics?

    Leave a comment:


  • started a topic Weird BSP collision errors.

    Weird BSP collision errors.

    When I am making a map, I occasionally run into a bugged piece of BSP and I can usually fix it by aligning the points/corners to a larger grid. However, I have come across a BSP object that has a collision error on the 32uu grid, but if I move an edge slighly to the slide on the 4uu grid, the collision is perfect again. Why would this happen?
Working...
X