Announcement

Collapse
No announcement yet.

Memory leak in patch 2.0?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Memory leak in patch 2.0?

    I haven't heard anyone complaining of this, but ever since I patched to 2.0, I've been experiencing severe virtual memory thrashing in WAR-Avalanche. It usually first occurs as I'm charging up the east node (Darkwalker), at which point the game freezes for about 5 seconds, then sputters for another 20-30 seconds with the HD light on solid. Eventually playability returns, with only the occassional stutter, but in the meantime I basically have to wait it out. Is anyone else experiencing this with 2GB of RAM? I never had any problems in 1.3 and every other map I've tried with the new patch plays fine.

    After exiting the game, I notice my peak "Commit Charge" in the task manager reaches 2.2GB! With 1.3 and earlier, I've never seen my peak go above 1.4-1.5GB even after long sessions. It seems to me that the same map suddenly requring a few hundred extra megs of RAM is probably a bug and not an expected consequence of the new patch, right?.

    Also, this probably isn't related, but I noticed the geometry popping near the prime nodes seems to have been fixed. I only mention this because Avalanche is the only map that has given me trouble so far and is the only map that had some visual anomalies in the previous patches.

    AMD A64 X2 5200+ (2x2.6/1MB)
    ATI Radeon X1900 XT 512MB
    2GB DDR2-800 4-4-4-15
    WinXP Pro SP2 (32-bit)
    Running UT3 2.0 with all settings maxed.

    Btw, I'll be upgrading to a Radeon 4850 in the coming days, and while I don't think it will change anything, I'll report back if the problem goes away.

    #2
    I had the same issue multiple times in that same spot. 2GB of Corsair Dominator 8500. Just had to wait it out. Rebooted PC and got same issue in the same spot. The slowness starts as I approach the node just out from the cave entrance behind the node. Charging the node with the Link gun makes it worse and it freezes for a while, then clears and I am able to move again.

    Did not look at peak charge, however I have noticed after exiting UT3 it takes a few minutes for my PC to recover, ie., things clock a long time before opening. After several minutes it gets better, but not to full speed without a reboot. I am on Windows 7 64 Bit Beta, 'cause the game keeps crashing on me in Windows XP Pro SP3 32 bit and that's another story.

    Did not experience any game crashes in Win 7, where Win XP crashes every other map.

    Using a Visiontek ATI HD4870 512MB card.

    Just thought I would say your were not alone on your issue.

    Comment


      #3
      i have the same issue

      look at the log

      my GPU has been timing out since i updated

      Comment


        #4
        Thanks for the replies, glad to know I'm not alone. I guess we'll have to hope that Epic fixes this in the future, though my feeling is that 2.0 may be the last patch we get for this already 16-month-old game. Then again, another 2GB is pretty affordable now, so it's not like this issue can't be worked around (assuming I'm right about it just being about using too much memory).

        Comment


          #5
          I have 4GB RAM, 3.2Ghz Core2duo, and an 8800gts 512 running in XP Pro.
          I can confirm there is in fact a memory leak as of patch 2.0, as I have noticed that extended play in some Warfare maps results in the game stuttering after a while and the average framerate decreasing significantly everywhere. It does not seem to go away until I start a new match, otherwise I never have performance issues in this game.

          Comment


            #6
            i would check the logs before stating memory leak

            i get GPU lag

            but i dont think my UT3 is leaking RAM

            Comment


              #7
              Hmm am new to pc gaming and have noticed some slight what seemed like warping for like a mili second it just warps bank into the game after second of pausing never knew it was memory leaks I always figured it was a hardware problem since its a newly built rig

              Comment


                #8
                Hello, I also noted this stuttering problem as well, on 2 different systems. I started a topic some time ago, when patch 2.0 was released. More details there. It seems to be the same problem you are describing.

                http://forums.epicgames.com/showthread.php?t=663725

                As I've already said, I wonder if EPIC even acknowledges this bug.

                Comment


                  #9
                  i would check the logs before stating memory leak
                  I obviously can't say for sure whether it's a proper leak, but my problem is definitely caused by the RAM being exhausted (see my first post).

                  Comment


                    #10
                    im starting to get the leaks after long play

                    im getting Running low on Ram
                    Vista can end the task to free some memory

                    but it goes away, i found it happens more with the link gun

                    Comment

                    Working...
                    X