Announcement

Collapse
No announcement yet.

I keep spinning round and around. Help.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I keep spinning round and around. Help.

    Hi all.

    I'm hoping you can help me with a problem I'm having with UT3.

    It seems I'm not alone with a technical difficulty in this game.

    I have looked through several posts but did not see my issue.

    Here it goes. I can load up the game successfully. I can play in instant action and campaign mode without any difficulty.

    However, when I press the ESC key during a mission to change a setting, or end the mission and press ESC again to go back into the mission, the screen begins rotating to the right in a circular motion. I have to close the game and load it up again. That fixes the problem.

    I also notice that when I went to adjust my on-line character, the same bug cropped up.

    I have an NVIDIA 8 clone. I'm not sure what drivers it is using. I have a Pentium D 3.0ghz with 2GB ram.

    I downloaded the UT3 Black Titan version. Do I still need to download the latest UT3 patch? Do I need to update the video drivers? If so, can I use the NVIDIA drivers??

    Any suggestions are appreciated.

    SLP

    #2
    Do you have patch 2.0?

    Comment


      #3
      Patch 2.0

      Are you referring to a UT3 patch. I only saw the 1.3 patch on the UT3 site. I have not downloaded any patch. I typically find that the newest patches are contained in the most recent version of the game. Since I downloaded it a week ago, I did not think a new patch was necessary. Is this a foolish assumption?

      Comment


        #4
        Not really. I wasn't aware of any patches when I got UT3. You can get the patch here.

        Comment


          #5
          I looked at the patch, it seems to have many of the features I already have on my version.

          Any other suggestions?

          Comment


            #6
            do you have a joystick or gamepad on your computer? try unplugging/disabling them.

            Comment


              #7
              I have a joystick and gamepad.

              I certainly could unplug the joystick but would hate to have to unplug the gamepad. The game pad is the Fang from Ideazon. It was designed for play with UT2004 and other games. I can't imagine it would not work with UT3.

              Comment


                #8
                Are you sure about this? What colour is your main menu? If it is mostly black/grey with a robot in the background, you have the 2.0 patch.

                Comment


                  #9
                  Ok, regardless of the fact that it 'looks' like you already have the patch, update it anyway. There is no harm in patching twice, it will delete and replace the correct files. As for the titan pack, if you install that before you install the 2.0 patch, you will have some issues. I would try to update using nvidia drivers, I don't quite understand what you mean by an nvidia 8 clone. If it is an nvidia product it is licensed to use their drivers. Go to here: http://www.nvidia.com/Download/index.aspx?lang=en-us select your series (8 series) your card and your os, then click the next button accept the agreement and download away. Install that and then reboot when it asks. That might help you out.

                  Comment


                    #10
                    Very important troubleshooting question:

                    Have you been listening to any songs by the band Dead or Alive?

                    Comment


                      #11
                      Bahaha, very relevent. But to the OP, have you tried my ideas yet?

                      Comment


                        #12
                        This happened to me last night while spectating on the UMG warfare server.
                        I was spectating random people, went to get a drink while the map was switching and when i came back my screen was spinning in circles while looking in the sky Lol, it was funny.
                        I left the server, rejoined and it went back to normal... I have 2.0 + titan

                        Comment


                          #13
                          Ladies and Genetlemen,

                          I think I fixed the problem. With your input, I downloaded the new NVIDIA drivers and it appears to have solved the problem.

                          As an afterthought, I see [2.0] in the top right hand corner of the main menu. I am assuming then that I have the most recent patch. a 1.3 patch is offered on the main UT3 site but I understand that there was a 2.0 patch as well. Are there any additional patches??

                          Thanks again for your input.

                          I will fully test the program this evening and see if there are any new "quirks."

                          Comment


                            #14
                            Ha! Winner winner chicken dinner. Good luck with the testing.

                            Comment


                              #15
                              check mouse senstivity

                              Comment

                              Working...
                              X