Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

ALT+TAB problem ... never come up back !

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    ALT+TAB problem ... never come up back !

    Hi @ all,

    I have ALT + TAB problem with UT3 patched and updated.

    I have POV GTX 260 and Vista Ultimate 64 bit with latest 182.08 drivers.

    During the game if i press ALT+TAB the game goes to the bar.. but never come-up !!
    I have to kill it and restart UT3 ...

    Can you help me ?

    Thank you !

    #2
    How long are you waiting? With some games/hardware you get a significent delay before the game will actually reappear.
    Also, try right clicking on the game in the taskbar and do restore, sometimes left clicking it doesn't work.

    Comment


      #3
      I wait and wait and wait but nothing happens ! Moreover i cannot right-click restore in the taskbar . . .

      Any solutions ?


      Thank you

      Comment


        #4
        Originally posted by MasterJukey View Post
        I wait and wait and wait but nothing happens ! Moreover i cannot right-click restore in the taskbar . . .

        Any solutions ?


        Thank you
        Are you Alt+Tabbing to check something on the internet? If that is the case you may want to use Steam to run UT3. Steam has an available in game browser window you can use. Pretty convenient if you ask me (although it boggles my mind when someone would have enough time while playing UT3 to check a website).

        Comment


          #5
          I am also having this problem

          Comment


            #6
            Sometimes happens to me, or it will occasionally crash. Generally comes back though.

            Comment


              #7
              dont alt tab out of the game like that firs press esc

              Comment


                #8
                Originally posted by coolcat22 View Post
                dont alt tab out of the game like that firs press esc
                And what does pressing esc going to do? I can load UT, leave it on the title screen, minimise and can then not restore it.

                Comment


                  #9
                  Bump! Same here.

                  Windows 7 x64 Ultimate, build 7600.

                  It didn't Alt-Tab back on x86 RC for me, too.

                  Radeon HD4870, if it matters.

                  Comment


                    #10
                    Any fix for this... still having same issue!

                    Comment


                      #11
                      Windows 7 does not mesh well with alt-tabbing most video games. If I were you, I'd avoid using alt-tab. (I have the same problem. Yes, it's a pain in the *** to test all your mods individually after restarting the game every time.)

                      Comment


                        #12
                        Originally posted by Gameslaya View Post
                        Windows 7 does not mesh well with alt-tabbing most video games. If I were you, I'd avoid using alt-tab. (I have the same problem. Yes, it's a pain in the *** to test all your mods individually after restarting the game every time.)
                        This happened in Vista too and only with UT3 (I have 20 other games installed... no problem with alt+tab in these). I also don't use any mods with the game.

                        Comment


                          #13
                          change this in your utengine.ini bInitializeShadersOnDemand=False to True.

                          now you can alt+tab istantly.....atleast this works with xp 32bit...but sometimes when you have been to desktop and returning to the game, it will have micro stutterings, atleast happends for me 1 out of 10-15 times when alt+tabbing, then only fix i have is restarting game

                          Comment


                            #14
                            Originally posted by Tm'BronsoN View Post
                            change this in your utengine.ini bInitializeShadersOnDemand=False to True.

                            now you can alt+tab istantly.....atleast this works with xp 32bit...but sometimes when you have been to desktop and returning to the game, it will have micro stutterings, atleast happends for me 1 out of 10-15 times when alt+tabbing, then only fix i have is restarting game
                            Thanks for trying but it didn't solve it . When I hover over UT3 in it's minimised state on the taskbar, Windows 7 shows me a little thumbnail preview, this preview is pure black.

                            Comment


                              #15
                              I have a GTX 260 core 216 and windows 7 x64 and can alt tab mostly without issue. Occasionally I have a large drop in FPS after returning to the game. This seems to be what Tm'BronsoN is talking about and he is right that restarting the game is the only way to fix it. The ini setting he mentioned doesn't seem to make a difference to my game. My settings are listed below:

                              [Engine.ISVHacks]
                              bInitializeShadersOnDemand=False
                              DisableATITextureFilterOptimizationChecks=True
                              UseMinimalNVIDIADriverShaderOptimization=False
                              PumpWindowMessagesWhenRenderThreadStalled=False

                              You could try setting pumpwindowmessageswhenrenderthreadstalled=true
                              I have seen that fix some similar problems.

                              deadman_uk seems to have Aero enabled. I have aero disabled. So it could be a factor.

                              Pressing esc before alt tabbing so that the game is in menu as opposed to live action seems to minimize the chances of me having the frame rate issue. This could do the same for your alt tab issue.

                              If I do wait a long time before alt tabbing back some times the game will not re-open. I think this has something to do with the server changing maps while the game is minimized but I'm not sure. This doesn't sound like the issue you are having however.

                              Seems to be happening to nvidia and ati users on different windows versions. Would be nice to find the commonality between these systems.

                              Is anyone/everyone having this problem overclocking and or all parts of their system?
                              Could everyone post their system specs like deadman_uk.
                              Steam and/or xfire and/or any program with an overlay running ?
                              Is anyone forcing any thing through their drivers control panel such as anti aliasing?
                              Physx disable/enabled
                              Game resolution same as windows resolution or different?

                              Also this is a little random to post here but it might fix it and even if it doesn't it seems to make the game run better for most users.

                              If you have a 4+ core cpu. Try running a program like PriFinitty or Bill2's Process Manager. Have the program set to run with windows and set ut3 to high priority and run on your last 3 cores (leaving your first core free to run background processes.) Everyone I know who's tried it has noticed more stable fps and smoother online play. If you have problems getting it running I'm available on xfire to help (random54).

                              Comment

                              Working...
                              X