Announcement

Collapse
No announcement yet.

Found the Slow option in Vista

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Found the Slow option in Vista

    Unreal Tournament III has consistently not performed well in terms of frame-rate on my machine:

    Pentium D 830 @ 3.0Ghz
    3GB RAM
    1.2TB HD
    Asus P5LP-LE main-board
    Ati Radeon HD 4670 512MB GDDR3
    Onboard Realtek HD Audio

    Windows Vista Ultimate 32-bit
    Every Windows Update applied including Service Pack 1. NO non-applied updates exist, all updates have been installed. No core operating system component is beta so no pre-release software such as the Service Pack 2 release candidates.

    Many maps such as Deck and Diesel had areas where frame-rate would consistently drop regardless of many tests of different graphical game settings. Non-performing areas tended to be in poor-to-mid 20's for frame-rate. After the setting described next these problem area frame-rates jumped to low-to-mid 30's consistently across maps with higher resolutions and settings enabled.

    What I did was:

    (with): Create or modify a short-cut to UT3.exe

    -> Right click on that shortcut and choose "Properties" from the context-menu
    -> Click on the "Compatibility" tab
    -> Only check the "Disable desktop composition" mode
    -> Apply and click Ok, use this shortcut to start UT3

    This disables the Windows Vista Aero composition system and gives you a basic resource mode graphically-wise. The startup behavior is also changed. Previous to this setting I would get the splash-screen followed by a black screen for about 15 seconds and then the Copyright and acknowledgment (C & A) text page before the logos. After this setting the splash-screen remains visible and the game only becomes full-screen with the immediate start of the C & A screen. The loading time is still consistent its just the 15 seconds of black is now 15 seconds of splash-screen immediately followed by C & A.

    Disable Aero, people in similar situations please report the effect of this setting in replies. Perhaps the root cause of this situation is worthwhile to address if there turns out to be some commonality across systems.

    Thank you Epic, Unreal Tournament III completely rocks with 2.0 and Titans!

    Edit
    Software configuration:
    Ati Catalyst 9.2
    Realtek HD Audio 2.17
    Appropriate Intel chipset drivers
    WindowBlinds 6.4 for Vista
    ObjectDock Plus 1.9

    All drivers and every-single application on my rig is patched to its latest version at all times. I didn't mention it before because I've discounted the software environment because this situation has existed prior to all these installations and across many different versions of these drivers. The situation has encountered a breakthrough in my particular case: the single setting has a dramatic result after many, many, tweaking iterations.

    More edit
    The new UI is so much better than having to fool around and restarting much more because editing settings used to be outside of UT3. It really helped in testing various configurations. The 2.0 Patch is the Black Edition? Maybe I'll go buy it just because the patch and Titan pack has increased UT3's worth to me a great deal. So, THANK YOU again Epic! You've demonstrated through your actions that you actually care about your franchise where others would have released maybe one patch and let it go to the dogs. You've restored in me faith in your business model - no left high-and-dry. This quantified means I'm much more likely to purchase your successive products because I now know that you will provide superior customer service by patching your products so that the quality will eventually always reflect my real dollars invested in what you promised me. Kudos Epic, thank you, a satisfied customer.

    #2
    I'm getting about 30% increase in frame-rate in the problem areas and overall good frame-rates considering I'm now able to play at 1680x1050 on medium-some-low settings!

    Comment


      #3
      Tried this on Vista x64, using a 4870x2. Nope, still the same generally LOW fps, I'm afraid. Using the same drivers, and having no issues with my other games. Is it worth mentioning having Catalyst A.I. on or off gives me the same general fps while in-game? The menu fps doubles as expected, but it's like my CPU is working overtime while playing.

      I mean sure, I know bots take up more CPU cycles, but surely a Q6600 shouldn't bog down this much (40fps drops). In XP, my minimums were about 90fps in average.

      Comment


        #4
        I've tried disabling desktop composition before, and it helps not one bit for me, unfortunately.

        EDIT: Actually, it does remove the black screen delay at initial boot of the game in Vista.

        What I noticed is that while playing the game, if I look at a certain point that drops the FPS, it only drops it for a second or two, then the average FPS shoots right back up to a steady 60.
        It's like Vista keeps reloading certain parts of the game, and unloads them when I'm not looking at them (if that makes sense). So every time I look at a point of interest that decreases FPS, it's only temporary, but it happens every time.

        Comment


          #5
          Darn it, it works for me! I've had the low fps problem forever, with an HD2600XT and now this HD4670 and changing the desktop composition setting finally worked for me! The frame-rates still aren't stellar but hey its still 1680x1050 out of a $100 card so I'm not complaining. It's too bad it doesn't work for all people . Well, I wish you guys luck finding the "magic" setting, I've found the one for my rig.

          Comment


            #6
            thanks for sharing this tipp!
            Unfortunately, for me there is no difference. My "magic" setting was disblabling "dynamic shadows"

            Comment


              #7
              Has anyone tried this trick with the Steam version of UT3?

              Comment

              Working...
              X