Announcement

Collapse
No announcement yet.

What kind of fps should I be getting?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Something always bottlenecks your performance in these areas. Stand in one and check your cpu load (per core) and gpu load. If one or more of the cpu cores is above 90% the bottleneck then change the settings that effect the cpu. If gpu is the bottle neck then change the settings that effect the gpu. Changing gpu settings will have no effect on fps if cpu is the bottleneck.

    I could be wrong but I believe that these are the only settings that really drag down the CPU:

    [Engine.Engine]
    bUsePixelShaderComplexity=False
    bUseAdditiveComplexity=False

    [SystemSettings]
    DetailMode=0

    Leave a comment:


  • replied
    Tried those to no avail. However, setting Catalyst A.I. to disabled gave me about +6 min fps. My max fps dropped from 200+ to 150fps, but that's fine. That essentially means it's running on just one 4870 1GB. This leads me to believe it's using a ton of CPU power. I really don't get why though... A Q6600 @ 3.4ghz should be enough to get at least 60fps minimum with nothing going on, right? Or heck, 45fps min with 5 bots? That's unacceptable.

    Also yes, this only happened in Vista. XP gave me a minimum of 80fps with 15 bots.

    Leave a comment:


  • replied
    Originally posted by Random54 View Post
    Well for starters I would change MaxAnisotropy=16 to 4 and see the effect. Setting it above 4 gives a fairly minor improvement for a substantial dip in performance.
    Also try changing ShadowTexelsPerPixel=2.000000 to 1. Apparently quality does not improve by setting it higher.

    My settings are a combination of high visibility settings for competitive play and performance tweaks. Here they are:

    StaticDecals=False
    DynamicDecals=False
    DynamicLights=True
    DynamicShadows=True
    LightEnvironmentShadows=True
    CompositeDynamicLights=True
    DirectionalLightmaps=True
    MotionBlur=False
    DepthOfField=False
    Bloom=False
    QualityBloom=False
    Distortion=False
    DropParticleDistortion=True
    SpeedTreeLeaves=False
    SpeedTreeFronds=False
    OnlyStreamInTextures=True
    LensFlares=False
    FogVolumes=True
    FloatingPointRenderTargets=True
    Trilinear=False
    OneFrameThreadLag=True
    UseVsync=True
    UpscaleScreenPercentage=True
    Fullscreen=True
    AllowD3D10=False
    EnableHighPolyChars=False
    SkeletalMeshLODBias=0
    ParticleLODBias=64000
    DetailMode=0
    ShadowFilterQualityBias=1
    MaxAnisotropy=4
    MaxMultisamples=0
    MinShadowResolution=32
    MaxShadowResolution=512
    ResX=1920
    ResY=1200
    ScreenPercentage=100.000000
    SceneCaptureStreamingMultiplier=1.500000
    FoliageDrawRadiusMultiplier=0.500000
    ShadowTexelsPerPixel=1.000000

    The reason some of the settings are lower is because the last thing you want when playing a competitive game is to be distracted by parts of the map moving. Also the Necris skin is much more difficult to see with DepthofField on.
    I find that changing the anisotropic filtering doesn't affect performance whatsoever. Even textures themselves don't affect performance. Even when I had an 8600GT and a 4000+ 2.1ghz dual-core, textures and AF filtering didn't touch my FPS. This wasn't in just UT3 but in ALL games such as CoD4, BF2, World in Conflict, Crysis (yes, even Crysis), etc. Crysis really put strain on that little 8600GT, but textures was one of the settings I could put on "Very high" which gave me huge increase in visuals, but no impact on performance.

    Graphics cards nowadays are too powerful for AF filtering to make a performance hit. Maybe if you're using an nvidia 6 series GPU or something like that...

    Leave a comment:


  • replied
    Well for starters I would change MaxAnisotropy=16 to 4 and see the effect. Setting it above 4 gives a fairly minor improvement for a substantial dip in performance.
    Also try changing ShadowTexelsPerPixel=2.000000 to 1. Apparently quality does not improve by setting it higher.

    My settings are a combination of high visibility settings for competitive play and performance tweaks. Here they are:

    StaticDecals=False
    DynamicDecals=False
    DynamicLights=True
    DynamicShadows=True
    LightEnvironmentShadows=True
    CompositeDynamicLights=True
    DirectionalLightmaps=True
    MotionBlur=False
    DepthOfField=False
    Bloom=False
    QualityBloom=False
    Distortion=False
    DropParticleDistortion=True
    SpeedTreeLeaves=False
    SpeedTreeFronds=False
    OnlyStreamInTextures=True
    LensFlares=False
    FogVolumes=True
    FloatingPointRenderTargets=True
    Trilinear=False
    OneFrameThreadLag=True
    UseVsync=True
    UpscaleScreenPercentage=True
    Fullscreen=True
    AllowD3D10=False
    EnableHighPolyChars=False
    SkeletalMeshLODBias=0
    ParticleLODBias=64000
    DetailMode=0
    ShadowFilterQualityBias=1
    MaxAnisotropy=4
    MaxMultisamples=0
    MinShadowResolution=32
    MaxShadowResolution=512
    ResX=1920
    ResY=1200
    ScreenPercentage=100.000000
    SceneCaptureStreamingMultiplier=1.500000
    FoliageDrawRadiusMultiplier=0.500000
    ShadowTexelsPerPixel=1.000000

    The reason some of the settings are lower is because the last thing you want when playing a competitive game is to be distracted by parts of the map moving. Also the Necris skin is much more difficult to see with DepthofField on.

    Leave a comment:


  • replied
    Here you go:

    [SystemSettings]
    StaticDecals=True
    DynamicDecals=True
    DynamicLights=True
    DynamicShadows=True
    LightEnvironmentShadows=True
    CompositeDynamicLights=False
    DirectionalLightmaps=True
    MotionBlur=True
    DepthOfField=True
    Bloom=True
    QualityBloom=True
    Distortion=True
    DropParticleDistortion=False
    SpeedTreeLeaves=True
    SpeedTreeFronds=True
    OnlyStreamInTextures=True
    LensFlares=True
    FogVolumes=True
    FloatingPointRenderTargets=True
    Trilinear=True
    OneFrameThreadLag=False
    UseVsync=False
    UpscaleScreenPercentage=True
    Fullscreen=True
    AllowD3D10=True
    EnableHighPolyChars=True
    SkeletalMeshLODBias=0
    ParticleLODBias=0
    DetailMode=2
    ShadowFilterQualityBias=1
    MaxAnisotropy=16
    MaxMultisamples=1
    MinShadowResolution=32
    MaxShadowResolution=512
    ResX=1680
    ResY=1050
    ScreenPercentage=100.000000
    SceneCaptureStreamingMultiplier=1.000000
    FoliageDrawRadiusMultiplier=1.000000
    ShadowTexelsPerPixel=2.000000
    TEXTUREGROUP_World=(MinLODSize=256,MaxLODSize=1024 ,LODBias=0)
    TEXTUREGROUP_WorldNormalMap=(MinLODSize=512,MaxLOD Size=1024,LODBias=1)
    TEXTUREGROUP_WorldSpecular=(MinLODSize=256,MaxLODS ize=1024,LODBias=1)
    TEXTUREGROUP_Character=(MinLODSize=512,MaxLODSize= 1024,LODBias=0)
    TEXTUREGROUP_CharacterNormalMap=(MinLODSize=512,Ma xLODSize=1024,LODBias=0)
    TEXTUREGROUP_CharacterSpecular=(MinLODSize=512,Max LODSize=1024,LODBias=0)
    TEXTUREGROUP_Weapon=(MinLODSize=512,MaxLODSize=102 4,LODBias=0)
    TEXTUREGROUP_WeaponNormalMap=(MinLODSize=1024,MaxL ODSize=1024,LODBias=0)
    TEXTUREGROUP_WeaponSpecular=(MinLODSize=512,MaxLOD Size=1024,LODBias=0)
    TEXTUREGROUP_Vehicle=(MinLODSize=1024,MaxLODSize=2 048,LODBias=0)
    TEXTUREGROUP_VehicleNormalMap=(MinLODSize=1024,Max LODSize=2048,LODBias=1)
    TEXTUREGROUP_VehicleSpecular=(MinLODSize=1024,MaxL ODSize=2048,LODBias=1)
    TEXTUREGROUP_Effects=(MinLODSize=256,MaxLODSize=10 24,LODBias=0)
    TEXTUREGROUP_Skybox=(MinLODSize=512,MaxLODSize=204 8,LODBias=0)
    TEXTUREGROUP_UI=(MinLODSize=1024,MaxLODSize=4096,L ODBias=0)
    TEXTUREGROUP_LightAndShadowMap=(MinLODSize=512,Max LODSize=4096,LODBias=0)
    TEXTUREGROUP_RenderTarget=(MinLODSize=1,MaxLODSize =4096,LODBias=0)
    Thanks for trying to help! Greatly appreciated.

    Leave a comment:


  • replied
    Could you post the part of your UTEngine.ini labeled [SystemSettings] ?

    Keep in mind this must be the UTEngine.ini from the Documents\My Games\Unreal Tournament 3\UTGame\Config folder.

    Leave a comment:


  • replied
    I actually already tried the aforementioned changes to UTengine.ini. I don't notice any difference whatsoever in FPS. The -onethread parameter does nothing for me either.

    Leave a comment:


  • replied
    Originally posted by Random54 View Post
    This isn't a magic fix, but it will help if your CPU is the bottleneck. Give these settings a try if changing your resolution does not effect your minimum framerate.



    If your GPU is the bottleneck I'd recommend turning scaling back on AF and AA settings for a start although a 4870x2 shouldn't be having problems.
    Also try changing AllowD3D10=True to AllowD3D10=False

    Leave a comment:


  • replied
    This isn't a magic fix, but it will help if your CPU is the bottleneck. Give these settings a try if changing your resolution does not effect your minimum framerate.

    Originally posted by Random54 View Post

    [Engine.Engine]
    bUsePixelShaderComplexity=False
    bUseAdditiveComplexity=False

    [SystemSettings]
    DetailMode=0
    If your GPU is the bottleneck I'd recommend turning scaling back on AF and AA settings for a start although a 4870x2 shouldn't be having problems.

    Leave a comment:


  • replied
    Originally posted by ArcticZero View Post
    This is what I find odd. I only play at 1680x1050. I have a Q6600 at 3.4ghz, and a 4870x2 using 8.12 drivers in Vista x64. And in, say, Shangri La, I get dips to about 55 or so in certain areas by myself with no other players in the map. Add in bots, and the same view gets about 46fps or so.

    Is there some magic fix I don't know about?

    I think Shangri La is just poorly optimized... at least, in the middle where you're looking at in that screenshot. My FPS goes down to about 30 in the same spot you're in with no bots.

    Leave a comment:


  • replied
    This is what I find odd. I only play at 1680x1050. I have a Q6600 at 3.4ghz, and a 4870x2 using 8.12 drivers in Vista x64. And in, say, Shangri La, I get dips to about 55 or so in certain areas by myself with no other players in the map. Add in bots, and the same view gets about 46fps or so.

    Is there some magic fix I don't know about?

    Leave a comment:


  • replied
    Toms Hardware UT3 performance chart shows a distinct advantage for quad cores but I doubt if thats campbullards problem as I have no issues here even at 2560x1600 but then again my e8400 is OC'd to 3.6ghz and I have a 9800gx2 and that is most like the cause here. His video card on some of the warfare maps will perform poorly with all sliders on max but he should be able to beef his screen resolution up to 1920x1200 or 1680x1050 and get relatively the same performance.

    Leave a comment:


  • replied
    or watch this one:

    http://extreme.pcgameshardware.de/pr...kern-test.html

    well the question was not, if ut3 runs better with a quad core. it does - but i think that the difference is too small for upgrading (considering the price and power consumption/ heat production) and speaking of full advantage.

    i still do not think that his cpu is not the bottleneck in combination with his 9800gtx. maybe if he had a 280gtx, 285gtx or a dual gpu. so i wont say, that his cpu causes the low fps.

    Leave a comment:


  • replied
    Originally posted by Random54 View Post
    oldkawman:

    So quad cores don't make a diffrence yet a 2.4 ghz quad core out performs the 3.12 ghz dual core on UT3? Looks to me like ut3 takes advantage of all 4 cpus. Also, that benchmark only shows average FPS and not minimum (which is all that really matters). Its fair to say that the quad cores will handle a greater load and result in a higher lower minimum framerate than the dual cores.

    Quickest way to find out if your cpu is the bottleneck. Change your resolution to 800x600. If your fps go way up then its not your cpu. If your fps stay relatively similar, then it is your cpu. If thats the case then change the settings I mentioned, put your resolution back up and see if that fixes anything.
    UT3 likes quad cores. It even likes the new Phenom II quads. Here is a set of benchmarks that show median lows.

    http://techreport.com/articles.x/16147/5

    This shows the C2D E8600 beating the Q6600 quad all around.

    Leave a comment:


  • replied
    oldkawman:

    So quad cores don't make a diffrence yet a 2.4 ghz quad core out performs the 3.12 ghz dual core on UT3? Looks to me like ut3 takes advantage of all 4 cpus. Also, that benchmark only shows average FPS and not minimum (which is all that really matters). Its fair to say that the quad cores will handle a greater load and result in a higher lower minimum framerate than the dual cores.

    Sebastien-Nova:
    One of the least constructive posts I've ever seen. You don't mention what operating system you are running. If its XP then your going to get higher FPS in UT3 than some one running Vista. Telling some one something is definitely not the problem when it very well could be is counter productive. UT3 has been giving different people with similar hardware configurations, different results, so his CPU might be bottle necking his system whereas yours is not. If I hurt your feelings by some how by saying that an E8500 might be the bottleneck then I'm sorry, but when troubleshooting you try to eliminate possibilities by testing, not by saying it couldn't be that so I won't even try it.

    Quickest way to find out if your cpu is the bottleneck. Change your resolution to 800x600. If your fps go way up then its not your cpu. If your fps stay relatively similar, then it is your cpu. If thats the case then change the settings I mentioned, put your resolution back up and see if that fixes anything.

    Leave a comment:

Working...
X