No announcement yet.

UT3 game progress \ settings not saved under Vista on Steam platform

  • Filter
  • Time
  • Show
Clear All
new posts

    UT3 game progress \ settings not saved under Vista on Steam platform

    So, I recently purchased UT3 from Steam, downloaded and installed it. Of course, I ran into the infamous CD key error. I also noticed that game progress and settings weren't saved, either. Steam didn't have any updates, so I installed the 1.3 patch from the UT3 website. Once the patch was installed, VIOLA- the CD key is saved, and I am automatically logged in with the profile I created.

    However, the game settings and campaign progress still aren't being saved. My game is installed on my I: drive, and My Documents is redirected to E:. I've noticed that when creating a new folder on C: called Documents and Settings, it is automatically moved under the Users folder, so I'm assuming that Users is the new Documents and Settings. I'm also thinking that, as this is a Steam game, the settings are in the Steam directory on I:.

    Does anyone have any suggestions?

    Try right clicking and running the game in administrator mode. Vista's UAC may be messing you up for some reason?


      Good idea, but not it. I have UAC disabled. I always shut it off when I build a new Vista box.


        I'm kind of confused by the whole 'creating the Documents and Settings' folder thing.

        Anyway, UT3 uses 2 locations to store the game and your settings. Your installation location (your I:\ drive) for the main game information. And your 'My Documents' folder to store your settings and add your custom content. The normal location is:

        C:\Users\*Whatever your username is*\Documents\My Games\Unreal Tournament 3\UTGame

        Since you've moved your 'My Documents' folder, the game doesn't know that it needs to save your settings and stuff in on your E:\ drive. Luckily the patches changed it so the game knows to save your CD Key and login info.

        You'll need to edit your UT3 shortcut. Right-click on your shortcut and open up it's properties. You need to add ' -nohomedir' (you need the space before the - ) to the end of the 'Target' line, outside the quotes if they are there. Should look something like this.

        "I:\Unreal Tournament 3\Binaries\UT3.exe" -nohomedir

        This will tell the game to store everything in your installation folder on your I:\ drive instead of trying to find the 'My Documents' folder. Might need your CD Key so have it handy just in case.

        This will now cause you to store your custom content in your installation folder too. Follow the directions that come with them, but where it says 'My Documents', it will be your I:\ drive directory. And a last little note. If you go to tweak the .ini files manually, don't touch/edit any of the .ini files in the 'Config' folder with the word 'Default' in it.

        Hope this fixes your problem.


          Well, I'll be damned. -nohomedir did funkall for my system before I patched to 1.3, but lo and behold- it is the cure for my ails now! Thank you for pointing out what I should have tried before, good sir, and cheers,