No announcement yet.

Patches 1.2 and 1.3 Force the Left Arrow Key

  • Filter
  • Time
  • Show
Clear All
new posts

    Patches 1.2 and 1.3 Force the Left Arrow Key

    In the past, I downloaded patch 1.2, and no matter how many times I reinstalled UT3 and reapplied the patch, UT3 "thought" that I was continually pressing the left arrow key. This made the game totally unplayable because all slider options immediately slid to the far left side, and that my view while ingame perpetually rotated to the left. (In truth, it's a little bit more powerful than if I were to press the left arrow key myself, because holding down the RIGHT arrow key all the time does not cancel out the effect. Everything moves to the left, just less so.)

    So, I ended up reinstalling UT3 and not installing any patches for it. Today, I installed 1.3, hoping that 1.2's problem would not happen again.

    Unfortuantely, I was wrong.

    As soon as I opened UT3, I knew that something was wrong. As I hovered over the Main Menu's options with my mouse, the letters over which I was hovering flickered between the unselected white color and the selected black color, staying at black when I stopped moving the mouse, another indicator that UT3 was registering a command I was not entering (left arrow key). When I selected a slider in the settings section, it immediately slid to the left, just like with 1.2. Finally, when I started a Deathmatch, as soon as the map loaded and it said "Press 'Fire' to begin," the view quickly and continually turned to the left, making it unplayable. Again, the registered 'left' command is slightly stronger than the left arrow key itself, as holding down the right arrow key while playing only slowed down the rapid rotating.

    I have tried reinstalling both UT3 and the patch, but to no avail. I really don't want to play without this patch, so does anybody have any suggestions for my problem? Thanks in advance.

    Untick the allow joystick option, if that not work unplug all steering wheels, joysticks



      Thank you so much. I can't believe it worked. You don't know how glad I am to be able to play with the updates.

      *dances a jig*

      Should this thread be locked or something now? I don't know.


        you are having an issue not related to ut, it is either what HideInLight said or something to do with your mouse or something like that. Probably would be a good idea to post your system specs to help to diagnose whats up.

        cool cool i see you fixed it never mind my post lol


          In a totally unrelated problem of less urgency, I also found that installing any patches made me lose the privilege of hosting LAN or Internet games. Whereas 1.0 let me do so (there were no problems whatsoever when I did host them), the others give me a cryptic message and put me back in the Multiplayer menu:

          Your network configuration may not be compatible with hosting matches. Please check your router's manual for instructions on setting up 'Port Forwarding' or a "DMZ server'.

          Does anybody know any fixes to this problem? Again, hosting worked fine before, but now it does not allow me to do so. Thanks again for the very quick and helpful responses given so far.