Announcement

Collapse
No announcement yet.

Problems selecting assets in the Editor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problems selecting assets in the Editor

    I installed UT3, and when I opened the editor to start the map-making, I noticed that I couldn't select the static meshes found in the Generic Browser.

    Further, I tried opening one of the maps in the UT3 Folder and I couldn't select any of the static meshes through the viewports either. This map was DM-Heatray.

    Overall the problem is selecting things I need, to figure out how to re-use all of the assets the editor comes with in an attempt to create a level in the identical theme of the Deathmatch map I choose.

    Thanks in advance.

    #2
    To clarify:

    When I try to select static meshes in the Generic Browser or through the viewports it doesn't register, and sometimes it will select a static mesh my cursor is nowhere near.

    This makes everything rather difficult.

    I am wondering if the editor is set to some random default control scheme, but I generally cannot do everything I could when I tried this editor out at school.

    Edit: Sorry for the double post, Edit* button didn't pop up 'cause I timed out.

    Comment


      #3
      Well I noticed that on lower resolutions try cranking up your screen resolution a bit.
      And restart your pc since changing the resolution and opening the editor without restarting won't solve that issue.
      Mine is runing at 1360x1024 and the editor runs perfectly.

      Comment


        #4
        depending on the speed of your computer, it takes a while for the click to register. what you need to do, is click what you want to be selected, but keep your mouse in the same exact place that you clicked until you actually see that the mesh is selected. if you click on something and then move the mouse away before it has time to see that youve clicked there, then the click will register at a later time wherever your mouse is: likely in a different place.

        basically, when you click something, you dont actually select it right away. the editor is doing a list of commands and the actual selection part is at the end of that list. so your computer will be running through that list of commands, meanwhile youre moving the mouse, and when it gets to the actual selection part at the end of the list, the mouse click registers at whatever position that you moved the mouse to: most likely in a different area than what you intended.
        it happens to me as well.

        i hope that made sense to you.

        PS:
        try opening the generic browser and selecting the scene manager tab. then select "persistent level" from the list and you should see a huge list of EVERYTHING in the map. if you check the "auto focus" box, you can simply click on things in that huge list and it will focus on it in the editor. its also very helpful if you want to massively delete all the power ups, or player starts, or the skybox group, or whatever.

        Comment


          #5
          Considering I have a pretty up-to-date machine, I don't see why I am facing this problem here and I never ran into it at school.

          About the only thing the PCs at school have on mine is that their quad-cores display at 3.2 GHz per, where-as my quad-core is 2.51 GHz, other than that I got 4 gigs of RAM, 3 gigs cause of the video card (more than school PCs) GeForce 9800 GX2 (way better than the 7 series they use at school, although they might have switched to 8 series this quarter)

          I've tried beeing patient, nothing happens though. I can't even select rotate tool or mover tool to mess around with the meshes I do somehow manage to get into my level.

          What you're saying seems logical, I just don't understand why a top of the line PC would suffer so.

          Comment


            #6
            thats odd. do you have any other programs running such as, firefox, IE, antivirus, etc?
            also, you might try turning off the real time preview and lighting preview and the post process previews.

            Comment


              #7
              and when you were adressing the selection issue, I didn't see any lag time where it might pick up something other than i intended to click on, it just selects something 3 rows down immidietly

              Comment


                #8
                weird. can you select static meshes from the scene manager?

                Comment


                  #9
                  Ah, yes I can, thank you for that, now just to figure out how to be able to select them in a blank new file. Can't seem to get the package to display.

                  I want to build a short single player scenario using DM-Heatray assets and the little basic kizmet that I do know. I'm sure I can look around for some solutions as well.

                  Comment


                    #10
                    so you cant select static meshes from packages in the generic browser either??

                    whats your screen resolution? try increasing it like voodoomaster said

                    Comment


                      #11
                      1280x1024 (max 4:3 aspect ratio, which is weird... I would have expected it to be higher) = GeForce 9800 GX2

                      I mean when I run 2 editors only 50-60% of the CPU is used
                      and 50-60% of RAM

                      edit: your tip with scene manager helped, that gives me a list of all assets used in one of the game's levels but I cannot see what they are unless i focus on them one by one, and it leaves me the problem of having to constantly jerk back and forth between viewports and the scene manager.

                      It also seems some of the meshes aren't accessible or I am just not looking in the right place. I know you have to fully load the packages for all of its contents to show up, but it seems like there are less assets than the levels themselves hold.

                      Comment


                        #12
                        if you go to the groups tab, the developers of unreal often create groups and place certain parts of the maps in those groups, then when they are working on them, they uncheck them to hide them so they can work without so much clutter. in order to see all of the things and select them in the scene manager, you may need to check all the checkboxes in the groups tab.

                        Comment

                        Working...
                        X