Announcement

Collapse
No announcement yet.

Random framerates

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Random framerates

    I decided to test exactly why I can't get better framerates at lower resolutions. I sometimes get the same fps, and sometimes worse at anything lower than 1680x1050 (my max). At a certain spot in Shangri la I get 38 fps at all details on 1 (1680x1050). If I restart the game I will RANDOMLY get 28 fps at the same spot, same settings! I restarted again and I got 38 again!. I cannot determine what is causing this drop.
    PC specs in sig. I ran this test 3x (so I restarted the game 5-6 times) - got 28 3x, 38 3x
    Here's the spot if anyone wants to try testing.
    [shot]http://img301.imageshack.us/img301/9128/47694840ms4.jpg[/shot]

    #2
    Inconsistent frame rates under a without reason are usually due to background processes.

    Cut down on all background processes see if that helps.

    Comment


      #3
      There were none that weren't essential. Definitely doesn't explain why the drop was so steady. I mean it stays at those 2 numbers pretty consistently no matter how long I stand there. The only difference was a restart of the game, without changing anything else.

      Comment


        #4
        I had to disable cool and quiet in the bios on my mobo. Also, I do not run anything in the background, no AV, nothing.

        Comment


          #5
          Try running ut3 with -onethread (add the line -onethread to the end of the target in the shortcut properties, outside the quotes)
          I still think background applications are the cause but I'll try other things too.

          Disable any cool and quiet apps too as they can cause false cpu reads at application start up, not had the issue with new games but i know unreal had that problem so try it I guess.

          *edit nooooo oldkawman beat me

          Comment


            #6
            I don't have any cool and quiet things in my bios. I did try the -onethread thing though and it appears to have given more consistent results. I get 37 fps steady every time now. Though another problem that still remains is that I get that framerate at all resolutions. I would think that lowering it would give much more but it's the same (even at 800x600). I can get 60+ if I look at other spots but it remains that I can not get anything higher than anything on my maximum resolution. Framerate smoothing is off too.

            Comment


              #7
              Originally posted by theeDEATHMASTER View Post
              I don't have any cool and quiet things in my bios. I did try the -onethread thing though and it appears to have given more consistent results. I get 37 fps steady every time now. Though another problem that still remains is that I get that framerate at all resolutions. I would think that lowering it would give much more but it's the same (even at 800x600). I can get 60+ if I look at other spots but it remains that I can not get anything higher than anything on my maximum resolution. Framerate smoothing is off too.
              When lowering the res does not help framerate, it means your cpu limited.

              You have an AMD athlon 64 mobo, cool 'n quiet should be under System Health or Power Management in the BIOS.

              Some boards do have unresolved issues;
              http://www.silentpcreview.com/article172-page1.html

              Also, have you installed NVidia Ntune? If not, you should. You can monitor your cpu and video card freq, voltages, and temps with it as well as adjust all your settings.

              How about latest nvidia mobo chipset drivers?

              Comment


                #8
                if your video card has it's own settings that it is forcing upon the game try disabling them all.
                this helped me.
                I was having the same issue. You could run the whole map then hit one spot in one particular direction and get a huge FPS drop.
                Refer to this thread.
                http://utforums.epicgames.com/showth...1#post25456061

                Comment


                  #9
                  I checked BIOS again, there is no such option. The closest thing was Smart Fan Control.
                  I'm not sure what you mean to disable. Something here?:
                  [shot]http://img182.imageshack.us/img182/3558/47377391fb9.jpg[/shot]

                  Comment


                    #10
                    Eh while you are there you can set max pre-rendered frames to 0 and Multi-display/mixed- GPU acceleration to single display performance mode.

                    Comment


                      #11
                      Well it didn't do anything for UT3 but thanks for the help.

                      Comment


                        #12
                        yeah, disable or turn all the setting to use "application settings"

                        Comment


                          #13
                          Originally posted by theeDEATHMASTER View Post
                          Well it didn't do anything for UT3 but thanks for the help.
                          What motherboard do you have?

                          Comment


                            #14
                            I think NVIDIA nForce6100

                            Comment


                              #15
                              Originally posted by theeDEATHMASTER View Post
                              I think NVIDIA nForce6100
                              That definitely has AMD cool and quiet. It also has integrated graphics, but I am not familiar with that type of board. What brand and model is it? You can download the mobo manuals online in pdf format, it will have details about what's in the bios and where. They always have info on the cool and quiet and power management. Unless it's an OEM board like Compaq or HP that has very limited bios you can access.

                              Comment

                              Working...
                              X