Announcement

Collapse
No announcement yet.

Turning Mouse acceleration off completely and making mouse feel like ut2004

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Turning Mouse acceleration off completely and making mouse feel like ut2004

    Has anyone found the definitive answer ? I've tried the "viewaccelerationdisabled" line, but the crosshair still seems jumpy and irregular in speed depending on speed of movement.
    The ini settings changes that I've read on this forum seem to all describe different values to work with. Any success out there ?

    #2
    strange. Don't have that issue ... I have a mouse where I can actually change the DPI settings on the fly through a button on it.
    FYI - I didn't install any special divers. plain windows drivers only. Enough for UT3

    Comment


      #3
      http://utforums.epicgames.com/showth...e+acceleration

      here you go

      Comment


        #4
        OK...Below is what I found to be the most authoritative explanation of what to change from ProUnreal. It still doesnt say what each line change accomplishes.....has anyone had any luck deciphering what each numerical value affects for the mouse ? I notice that the "absolute axis" is changed to zero in this tweak from a default value of 100....what is the absolute axis ? The other changes seems to ADD this lilttle bit " Axis aMouseY Speed=2.0" & "Axis aMouseX Speed=2.0". Speed = what? acceleration or sensitivity?




        It takes a bit more than just changing MouseX/MouseY settings to fix the input problems there are new multipliers in place that modify mouse input significantly.

        Here are the settings that need to be changed;

        in UTInput.ini:
        Code:
        [Engine.PlayerInput] 
        LookRightScale=0.000000 
        LookUpScale=0.000000 
        bEnableMouseSmoothing=False 
        ... 
        Bindings=(Name="MouseX",Command="Count bXAxis | Axis aMouseX Speed=2.0",Control=False,Shift=False,Alt=False) 
        Bindings=(Name="MouseY",Command="Count bYAxis | Axis aMouseY Speed=2.0",Control=False,Shift=False,Alt=False) 
        ... (^- as neXus said) 
        Bindings=(Name="LookUp",Command="Axis aLookUp Speed=+25.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=False) 
        Bindings=(Name="LookDown",Command="Axis aLookUp Speed=-25.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=False) 
        ... 
        Bindings=(Name="GBA_TurnLeft",Command="Axis aBaseX Speed=-40.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=False) 
        Bindings=(Name="GBA_TurnRight",Command="Axis aBaseX Speed=+40.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=False) 
         
         
         
        [UTGame.UTPlayerInput] <- same thing in this section as playerinput. 
        LookRightScale=0.000000 
        LookUpScale=0.000000 
        ... 
        Bindings=(Name="MouseX",Command="Count bXAxis | Axis aMouseX Speed=2.0",Control=False,Shift=False,Alt=False) 
        Bindings=(Name="MouseY",Command="Count bYAxis | Axis aMouseY Speed=2.0",Control=False,Shift=False,Alt=False) 
        ... 
        Bindings=(Name="LookUp",Command="Axis aLookUp Speed=+25.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=False) 
        Bindings=(Name="LookDown",Command="Axis aLookUp Speed=-25.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=False) 
        ... 
        Bindings=(Name="GBA_TurnLeft",Command="Axis aBaseX Speed=-40.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=False) 
        Bindings=(Name="GBA_TurnRight",Command="Axis aBaseX Speed=+40.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=False)
        I am not particularly sure about what all of the settings in [UTGame.UTConsolePlayerInput] do, as they are kind of convoluted ... but it wouldn't hurt to make all ViewAccel_* settings = 0.0f


        Adjust your MouseSensitivity according to your preference and what feels right in game with this console command;

        set Engine.PlayerInput MouseSensitivity <x>


        where <x> = a number

        Comment

        Working...
        X