Announcement

Collapse
No announcement yet.

UnrealEd 3 crash when atempt build, vista32

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UnrealEd 3 crash when atempt build, vista32

    hi, I am curently working on an exam project, (due in a few weeks) my previous PC died, I bought a new one, and now it seems I have a problem hehe.

    Simply put, UnrealEd crashes whenever I try to build all, or spesificly lighting for medium to large maps.
    I have buildt the same maps on a considerably slower computer earlier.
    The only notable diference I can think of between them are thatone runing on vista64 and my curent on vista32.

    I've been monitoring the pagefile usage, and when building, the crashes appear to happen when the file hits the aproximate size of slightly less then 4000M (which is prety much always, granted that I have a few upk's loaded)
    then again, the pagefile thing may be just a coincidence.

    My system info:
    4gig Ram (actually 3070mb..)
    Q6600 intel 2.4ghz quadcore cpu (oc'ed to 3ghz using asus pc AI suite, levelup)
    Nvidea 9800GX2 from XFX,
    running on 3x monitors, using dx10.
    My pagefile is by default set to a top of 6339M

    I dont know what else would be essential info, my drivers for prety much everything is up to date to atleast a few weeks back.

    All help greatly appreciated
    -------
    edit:
    I can build the map when I havent yet loaded up any packages, during this process it takes my pagefile up to around 3600M
    However when I load 10-12 enviroment upk files, the pagefile increases in size by about 250-300M pre-build which propotionaly ups the usage during build to 3900-4000M.
    I can ofcourse not be sure that is is the actuall cause and not just a simultanious effect, but either way I havent got the faintest clue how to fix it.
    Any way of limiting what a program considers to be its own boundarys for pagefile usage or something?

    #2
    update:
    Been trying alot at later times with the pagefile being worked up alot beforhand.
    These times the pagefile has had an initial size of 200-300M more then earlier which means it starts of above the amount of what it used to crash at.
    It doesent crash with regular map making and other work, but yet again, about 30% into any build progress.
    So I dont think it has to do with the pagefile after all :/
    Anyone got sugestions?

    Comment


      #3
      About all I could think of is the following MS fix which was not made available via the standard Windows automatic update (though I find it strange this happens on 32 and not 64):

      http://support.microsoft.com/kb/940105

      I tried on my 64-bit VISTA system last night and no matter what I loaded and dumped into UnrealED I could not get it to crash when I attempted a build and I know I have the fix above installed. Give it a shot and see if it works, it addresses an issue with virtual address space usage and MAY be a solution but I make no guarantees.

      In addition, do you have AVG v7 installed by chance? The older version was known to cause issues with other applications when running when discussing virtual address space usage, etc. but the latest versions no longer seem to be an issue.

      Comment


        #4
        Hi, thanks for the reply
        What you suggest seems logical, however when I try to Download the file - the standalone installer thingy tells me the update is not valid for my system.
        anyhoo, I do infact also use AVG, but its the 7.5 free edition.
        I'll try some more with installs and uninstalls and share the results.
        Oh and.. I might have downloaded a similar fix a while back when trying to get the witcher to work if you are familiar with that whole bugfest.

        Comment


          #5
          Ya if Windows is telling you its not valid you either got it individually or part of the SP1 update. Out of curiosity, try disabling the AVG application and give it another go...I can't remember the exact version causing the issue but it was a huge nitemare for us that play Supreme Commander to the point I was ready to rip my PC apart . I don't think the uinstall/reinstall is going to do any good some low level process or Windows is having an issue with either memory allocation or perhaps referencing somewhere and the exe therefore steps into unknown memory, bad references, etc.

          Comment


            #6
            Allright, so I figured that the update might be invalid due to some language problems, so I grabed the whole SP1 in which it should be included, instead.
            SP1 semi recently came to support my language thus should have the correct version of the fix aswel if that is the problem I figured.
            Long story short, everything got ****ed and now its fixed again, except the original problem of not being able to build in UT Editor without crashing.

            sigh :P

            Where can I see whether or not that fix has been installed in my system?
            I am only so and so familiar with Vista, I did see that several of the updates from SP1 failed to install in the log, but I'm not sure if that is an error or due to some allready being there.

            EDIT:
            Nevermind, it seems I installed that fix a couple of weeks ago when dealing with the Witcher problems.
            Tho, looking atmemory usage while doing a build process I can see the bars max out completely, which cant be good.

            Comment


              #7
              UnrealEd will use pretty much any and all system resources it can get at whilst building - so don't worry, that's quite normal.

              Comment


                #8
                I spose..
                Now if only there was a way to tell it to only use 90% of what it can grab..
                or any other way of preventing it from crashing.

                Comment


                  #9
                  You can limit it using the task manager, by setting process affinity and priority.

                  Comment


                    #10
                    Strugeling a tiny bit with the terms since I (by no fault of my own) use a Danish Windows.
                    But I think I found the right stuff.
                    I set the priority to BELOW NORMAL.. I dunno if thats the right way to go, and the affinity or atleast what I think is the affinity option - allows me to set which cpu cores the process can use. I removed one of em, thinking perhaps the system needs one to stay alive during the job.
                    But I cant see any option for limiting memory usage?
                    My changes made no diference so far, stil the crash. am I "limiting" correctly?
                    On my to do list is downclocking my cpu again, tho I've put that off for a while since it would be anoying if thats the only solution.
                    2.4 - 3 OC is fairly moderate, and shouldent be a problem on the Q6600, also its done as before mentioned with the automated CPU Levelup system from my asus motherboard.
                    Another possible source of errror I spose would be my GFX card which is dual gpu, and not actually ment for several monitors, tho I run it in multi monitor mode and 3 monitors instead of dual gpu mode and 1 monitor.
                    But I wouldent think the gfx card would have a huge impact on these types of processes.

                    Comment


                      #11
                      Righto, another update.
                      I tried downclocking my cpu to its original settings, and I tried runing the dual-gpu (one monitor standard) settings for my gfx card.
                      Non of which improved the situation.

                      Next I've tried building my map with unrealed, having diferent amounts of enviroment upk's loaded.
                      Turns out I can build it when having non, or only 2-3 loaded, however once I loead up all the LT paks for example (which I dont consider a whole lot) it goes down once it starts on the lighting build.

                      Comment


                        #12
                        With your last note this is sounding more and more like a resource management (or purely available resource) issue since the more you have loaded, the more likely the problem is to occur. Out of curiosity, why do you have your pagefile set to top at 6339, why not just let Windows manage it and see what happens?

                        I've read numerous articles as to WHY you may want to do this but to date I've never found a need. I actually messed with this setting in VISTA 64-bit when TF2 was failing to launch and encountering all sorts of issues (which ended up being a bad mobo driver install) and I quickly reverted it since it had no effect.

                        Comment


                          #13
                          Originally posted by Permafried- View Post
                          With your last note this is sounding more and more like a resource management (or purely available resource) issue since the more you have loaded, the more likely the problem is to occur. Out of curiosity, why do you have your pagefile set to top at 6339, why not just let Windows manage it and see what happens?

                          I've read numerous articles as to WHY you may want to do this but to date I've never found a need. I actually messed with this setting in VISTA 64-bit when TF2 was failing to launch and encountering all sorts of issues (which ended up being a bad mobo driver install) and I quickly reverted it since it had no effect.
                          oh, I expressed myself poorly there, Windows is handeling it, I just listed what was curently listed as the "max" or whatever its called
                          I am far away from competent with memory management and the like, so I just listed whatever data I tought migth prove relevant.

                          It does indeed indicate that somehow it cant manage resources properly, but what strikes me as odd from my technicly limited point of view, is that I ran the exact same map on a far less competent PC.
                          I'de go as far as to saying the computer I run it on now is overall 30-40% better hardwarewise, inluding more and faster ram.
                          On the other PC I buildt this map with all the lighting and paths and whatnot, while having every upk in the environment folder loaded.
                          Granted it took a good 20 minuts, but atleast it dident crash
                          Only thing the worse machine has going in its possible favour is it runs on Vista 64 and mine on 32.

                          Comment


                            #14
                            Sollution! ..sort of :P

                            Hehe, allright.. so I remembered all the bull**** I went trough to get The Witcher to work, seeing as that had/has an adress space issue.
                            And now that you brought that up I figured I'de try the somewhat sketchy fix I tried for Witcher to solve this.
                            I'm just gonna copypaste the explanation from where I found it back then:

                            http://alfred.co.in/how-to/witcher-v...sh-fix-how-to/
                            How to Fix Vista 32-bit Crashes

                            Open the Command prompt as Administrator in Vista
                            (Start > All Programs > Accessories > right click Command Prompt > Choose run as Administrator)

                            Enter BCDEDIT /set IncreaseUserVa 2800
                            Restart the computer and start Witcher

                            Detailed Explanation of the above
                            On a 32-bit system the maximum amount of address space is set by the value of “IncreaseUserVa”.
                            Now the default value of IncreaseUserVa is set to 2048MB. The allowed values for IncreaseUserVa
                            are 2048-3072MB. By increasing the amount of address space available for Witcher, we can prevent
                            it from crashing. Personally I am able to play without crashes for a few hours after doing the above steps.

                            I recommend that you set the value back to 2048MB after you are done playing the game.

                            In addition to the above steps make sure you have KB940105 update from Microsoft installed.
                            I set mine to 2800 and surely enough I can Build fine now with all my precious UPK's loaded.
                            Thanks for all the help Permafried- and ambershee, and I hope this may come to help others that are posibly in the same situation.

                            As a sidenote tho, as was written several places where I found this info to begin with, do it at your own risk, cause I havent the faintest clue what side effects it may have

                            Comment

                            Working...
                            X