Announcement

Collapse
No announcement yet.

No in-game sound. Plz help.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    No in-game sound. Plz help.

    I wouldn't have asked if I had found a solution elsewhere, but numerous searches in google and a lite search of these forums have turned up no fix for my problem.

    When I first installed UT3, I had the same issue as many others; some **** about it encountering errors, namely with the ct_oal.dll. Using information found on these forums I managed to medicate the problem and actually was able to run UT3 [woohoo!] by adding -nosound to the command line. However, there was, of course, no sound, so when I clicked off the OpenAL hardware [it doesn't seem to make a difference whether it's clicked on or off] in the settings and restarted the application [after removing -nosound from the command line, of course] I had sound in cut scenes and in the opening credits, but there is no sound for the actual game or the menus. UT3 is the only game I have this problem with, and I can run games like Crysis, BF2142 and COD4 swimmingly without any problems.

    Please if anyone can offer me any help it would be terrific, it sucks not knowing what people are saying and when people are shooting/walking around you.

    Here are the things I've tried:

    Updating my OpenAL Library [it was worth a try]
    Updating my sound card drivers
    Replacing oal-related .dlls in the binary folder with those from windows/system32
    Scanning through the sound section of the control panel for any other possibilities

    For the record, I have a Creative SB Audigy 2 ZS

    PLEASE HELP MEEEEE

    #2
    Also, I don't think the problem is related to my audio codecs either.

    Comment


      #3
      I have the EXACT same problem as you. I sent a support request to Midway, but they responded with an insultingly unhelpful form letter. Please let me know if you find a solution.

      I've got an SB Audigy 4, by the way. I'm running Windows XP.

      There are a few things I have yet to try... I have a feeling this is a game issue, though. As you stated, I can run all of my other games just fine with full sound.

      Comment


        #4
        Well I guess this means that no one knows what the problem is...
        maybe it's just creative sound cards? It would be interesting to know if someone with a creative soundcard [especially one that is in the audigy series] is NOT having this problem...

        Comment


          #5
          I think the key is in Open AL audio, but I could be wrong. See if you have a mention of Open AL in your Add/Remove Programs list. If the drivers are there even when you don't use them, it may cause a problem.

          Then again, I thought my issue was an audio one because I was getting hangs during the campaign audio briefings and during Warfare core explosion sounds, but my system was cured when I completely uninstalled my VIDEO CARD DRIVERS with Driver Sweeper and installed the latest beta drivers.

          http://www.guru3d.com/index.php?page=driversweeper

          So, like you, I had other next-gen games running fine and I thought I knew what the cause was. But UT3 being the enigma that it is, really surprised me when I fixed it. Worth a try, don't you think?

          Comment


            #6
            Nope, didn't work. I don't really know what the problem is; I don't think it's the Open AL, and I don't think it's my codecs or drivers, and my sound card plays audio from other games fine. I know now that it is not my graphics card, so uhm.

            bump

            Comment


              #7
              Ugh..

              I created a similar thread a few days ago.

              You know, it really sucks spending $50 for a game that fails to run properly. You'd think they could get it right, having released several renditions already.

              Alas, I have the EXACT same problem. I've tried all of above methods. I shouldn't have to clear my harddrive and reinstall all the drivers and tweak .INI files just to get a game to work. It's supposed to work when I buy it.

              Dan

              Comment


                #8
                You guys should post your hardware configuration when asking for help.

                I'd recommend applying the latest patches and deleting all the config files in your UTgame folder. Possibly when they are automatically recreated the problem will be fixced?

                Comment


                  #9
                  I'm running an Intel Dual Core that runs at 2.66ghz. No installed soundcard, just factory default. 1gb of ram, and a GeForce 8400 GS video card.

                  Comment


                    #10
                    Ugh, this is driving me nuts. When I first installed the game I figured this would be a temporary issue that would be fixed in a later patch, but no such luck. LeetHobbit is right; I haven't had this much trouble with a PC game in nearly a decade. Epic needs to fix this **** - I didn't pay $50 for a game that only sort of works. It's pretty hard to play online when you can't hear people shooting at you.

                    Not that I think it makes a difference, but here are my full system specs:

                    Motherboard: ASUS M2N-SLI AM2 PCI-E SATA2
                    Processor: AMD Athlon 64 X2 AM2 5400+ ~2.8Ghz
                    Memory: 2048MB OCZ Gold DDR2-667 Dual Channel RAM
                    Primary Hard Drive: Seagate 7200RPM SATA2 320 GB (UT3 is installed on this drive)
                    Secondary Hard Drive: Seagate 7200RPM SATA2 500 GB
                    Video Card: Radeon X1800 XT 512MB
                    Sound Card: Creative SoundBlaster Audigy 4
                    Monitor: LG 204WT 20.1" widescreen LCD monitor (1680 x 1050)

                    Comment


                      #11
                      Did you try uninstalling OpenAL and disabling it in the UT3 settings?

                      Comment


                        #12
                        My brother had the same problem on his install of ut3, only thing is he had no sound what so ever, at first we thought,
                        maybe it's somethng weird on his pc or with his ut install, or maybe just a bug, so naturally we installed patch 1.1 and
                        checked if that solved it, and it didn't.

                        Next we went on and installed patch 1.2, that didn't solve it either, so we turned to our good friend, Google, needless to say,
                        re-installing the audio codecs did nothing, we even found some drivers for his C-media sound card for vista as we thought
                        maybe it was the windows driver that didn't like the game's sound, last night we saw there is a vista service pack 1 release,
                        434mb later we ran the service pack installed it and started up the game...

                        To our joy, the sound works great.

                        i don't exactly know what fixed it, the only thing i can think of is that the service pack might have had an update that re-installed
                        his sound drivers, but that's everything we tried and the service pack 1 seemed to sort it out...

                        good luck

                        BioG.

                        Comment


                          #13
                          Originally posted by D-Hunter View Post
                          Did you try uninstalling OpenAL and disabling it in the UT3 settings?
                          I don't have OpenAL installed; I'm on XP. Sound actually WORKS on my Vista machine, but that's a laptop which can't really run this game all that well, sooooo...

                          Edit: I installed Vista to a separate partition on this computer and tried running UT3 there. Surprise surprise - sound works! So it looks like I owe Epic an apology; it appears that it's Creative's ****ty drivers preventing sound from working in the game. The problem now is that Creative hasn't updated their drivers in more than a year, and not only that, but they send cease and desist letters to third parties trying to create drivers that don't suck ***... so I'm not sure what to do now.

                          Comment

                          Working...
                          X