Announcement

Collapse
No announcement yet.

Bloom effect without Depth of Field?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bloom effect without Depth of Field?

    ok i've enabled Bloom and Quality Bloom in UT3's "UTEngine.ini", but i still don't get the Bloom effect.

    but if i enable DepthOfField option, i get the Bloom effect, but i personally don't like that Depth of Field effect. it's way too dark sometimes with it enabled.

    how can i keep the bloom effect with the DepthOfField disabled?

    this is how it's configured in UTEngine's SystemSettings field:

    StaticDecals=True
    DynamicDecals=True
    DynamicLights=True
    DynamicShadows=True
    LightEnvironmentShadows=True
    CompositeDynamicLights=True
    DirectionalLightmaps=True
    MotionBlur=False
    DepthOfField=False
    Bloom=True
    QualityBloom=True
    Distortion=True
    DropParticleDistortion=True
    SpeedTreeLeaves=True
    SpeedTreeFronds=True
    OnlyStreamInTextures=True
    LensFlares=True
    FogVolumes=True
    FloatingPointRenderTargets=True
    Trilinear=True
    OneFrameThreadLag=False
    UseVsync=False
    UpscaleScreenPercentage=True
    Fullscreen=False
    AllowD3D10=False
    EnableHighPolyChars=True
    SkeletalMeshLODBias=0
    ParticleLODBias=0
    DetailMode=3
    ShadowFilterQualityBias=1
    MaxAnisotropy=8
    MaxMultisamples=1
    MinShadowResolution=32
    MaxShadowResolution=512
    ResX=1024
    ResY=768
    ScreenPercentage=90.000000
    SceneCaptureStreamingMultiplier=1.000000
    FoliageDrawRadiusMultiplier=1.000000
    ShadowTexelsPerPixel=2.000000

    thanks for helping me.

    #2
    In my experiences, depth of field is one of the most drastic settings in UT3.....it seems that there are a load of other options that are disabled when you disable DOF. try putting your world detail to 4 or 5 and then exiting and turning off depth of field in the .ini file.....the game looks completely different.

    Comment


      #3
      I don't think this is the answer you were hoping for, but according to tweakguides.com it appears the relationship is bugged:

      DepthOfField=True

      This option controls the use of Depth of Field, which is an effect used to simulate the way in which objects within focus are sharper than objects outside our direct field of focus. It's noticeable in particular when zooming in on objects - objects which you are aiming directly at will appear crisp, while surrounding objects will be blurred. You can set this option to False to gain improved performance, or if you just don't like this effect. Note that while standard Depth of Field is not visible (e.g. zooming in with the Sniper Rifle does not display it), disabling this setting seems to alter the impact of Bloom lighting significantly, and has a major impact on image quality; a great deal of Bloom and all blurring is removed. I'm not sure whether this is a glitch or done intentionally.

      Bloom=True

      This setting controls the use of Bloom Lighting, which is a form of lighting that exaggerates the brightness and glow of lights, creating a slightly hazy, more atmospheric look. With this option set to False, Bloom is not supposed to be used, however oddly enough, disabling Bloom (and QualityBloom, see below) doesn't seem to remove bloom lighting as such, while disabling the DepthOfField setting while leaving Bloom enabled does seem to disable most of the bloom lighting. Again I'm unsure as to whether this is done by design, or a bug, as it does not make any sense.

      QualityBloom=True

      As with Bloom above, this setting controls Bloom lighting effects, and if set to True uses a more accurate form of Bloom. Disabling this may gain additional performance without a noticeable change in image quality. Once again, in practice disabling this and/or the Bloom setting above doesn't actually appear to diminish or remove Bloom lighting.
      source: http://www.tweakguides.com/UT3_8.html

      Comment


        #4
        On my end, I can't seem to get DOF to work at all! I have full bloom but no depth of field. World detail set to 5 and no luck

        Sorry, I dont even know how I have that problem to help you.

        Comment


          #5
          RaptorZX3, could you post your UTgame.ini [Engine worldinfo]

          Heres mine:

          [Engine.WorldInfo]
          DefaultGravityZ=-520.0
          RBPhysicsGravityScaling=2.0
          SquintModeKernelSize=128.0
          DecalManagerClassPath=UTGame.UTDecalManager
          DefaultPostProcessSettings=(Bloom_Scale=0.2,DOF_Bl urKernelSize=12.0,DOF_MaxNearBlurAmount=0.0,DOF_Ma xNearBlurAmount=0.0,DOF_FocusInnerRadius=2000.0,DO F_FocusDistance=0.0,)
          EmitterPoolClassPath=UTGame.UTEmitterPool

          Comment


            #6
            What exactly are both DOF and bloom?
            Any screen shots to show this?

            Comment

            Working...
            X