No announcement yet.

The Unfixed C++ Error Thread

  • Filter
  • Time
  • Show
Clear All
new posts

    Does Epic ever read these forums? I'm pretty sure that if someone posted a thread full of stolen CD-Keys and aimbots in this forum, none of the admins would notice.


      They do but it would help if they would even say, We are looking to help you guys but we don't have a solution a.t.m.

      Back to suspense I guess the only thing that doesn't at weird :S


        I have the same ISSUE!!

        Ok.. so most of the people who have this problem like you have nvidia, so you believed it was driver issue.. But i have an ATI card hd3850, & i have the same EXACT issue.. DID YOU EVER GET A RESOLUTION? please help..

        ALSO most of us have ASUS MOTHERBOARDS... (dont know if that is the issue)

        asus maximus formula SE
        4 gb ram
        vista ultra 64 bit


          I HAVE SAME ERROR.. with my asus maximus formla SE, qx9650, hd3850.. HELP


            My brother had similar problems with unreal engine 3 games on his laptop. Laptops simply arn't built for gaming!


              Hi, I just wanted to post some info in hopes that it may help some with this error. I had it happen to me a little while ago after dowloading a beta map and found that maps that contained a sun flare fx to consistently crash UT3. Here's a copy of a post I made on another thread:

              "they shouldn't have to delete all the user content from the folder their storing them in. I place my mods and maps under \My Documents\My Games\Unreal Tournament 3\UTGame\Published\CookedPC\ and what I found was the issue was a map I downloaded that may not have been fully cooked which had a folder called "Effects" with a FlareFX .u or .upk file for the map and went in my CookedPC folder.
              Everytime I played a map like Sanctuary with the flare effect I could be in the map until I looked towards the direction of the map with the sun flare effect and then it would crash to my desktop with a Visual C++ error. Once I figured out it was this file causing the issue I just deleted the flarefx file and the game played fine.
              I would say start by removing folders (and you don't have to delete them, just move the files to another temporary folder outside of your UTGame folder and start up UT3; This way if it didn't fix the issue you can just put them back and keep testing) that have assets that are already part of UT3 like that Effects folder I had the issue with. Maps should be ok if they have the .ini, .u, and .upk files they need. Mods usually only have parts that go into the Config folder and under CookedPC. This isn't always the case as I have mods with folders for say Galtanor's invasion as an example that don't cause any issues and some maps don't always come with an ini file. Start with the latest mods they added and work your way back. Good Luck, I know I had a big headache after I was done testing to narrow it down to that file. "

              This was after reinstalling windows, checking my ram, reinstalling UT3 4 times and trying every tweak I could find in the ini to get it to work and all it was was some map that had not been cooked corectly and I had uncompressed all the files into my UTGame folder without checking what was in the package. Anyways, hopefully this points some people in the right direction.


                Wow - I think you're onto something there.

                I have been wondering why my c++ runtime crashes only occur on 'outside' maps, and why stock maps that used to work fine (like Sanctuary, and Torlan) now no longer do.

                It also puzzled me why I could run around at times for a few seconds in those maps, and only when I looked up did it crash.

                I've spent hours trying every possible suggested solution - new/older gfx drivers, emptying cache - the works. And now, I may finally have the answer!

                Cant wait to get home from work and look for this rogue "Effects" folder!

                I'll keep you all posted!


                  Thanks Bawsy. I actually used Sanctuary for my testing because I could load into to it, but as soon as I looked towards the centre of the map if I spawned outside it would consistantly crash every time. Good luck and hope it works for you.


                    Originally posted by DscytheX View Post
                    Thanks Bawsy. I actually used Sanctuary for my testing because I could load into to it, but as soon as I looked towards the centre of the map if I spawned outside it would consistantly crash every time. Good luck and hope it works for you.
                    No no, thank YOU my friend - problem fixed, and no more C++ runtime errors now. The problem was indeed an "Effects" folder in my custom map directory, the contents of which consisted of one solitary FlareFX.u file.

                    Deleted that, problem gone. Sactuary, Searchlight, Torlan all now work fine. And right enough, every single one has the 'flare' effect somewhere in them!

                    A lot of custom maps also didnt work for me, so I deleted them. Guess I'll need to download them again now, huh? But worth it!

                    Happy camper right here!


                      That's great to hear Bawsy! And thanks for posting back. If you have as many maps as I do I know what a pain it is to have to go back and re-download maps. I find it's easier if you create folders in your CustomMap folder for types of maps as the game will read into them. DM, CTF,VCTF and WAR folders so that it's not a big mess of files if you have to find one in particular.

                      Anyways, I'm glad that helped you out and hope that this will help others with this issue. Happy Fragging!!!



                        Could it be? The solution to all of my (about a quarter of) crashing problems? I did in fact find said Effects folder containing a single Flare FX file, and have deleted it. I will have to test this, and if it works, I can focus on the artifacting, freezing, stuttering, and Window error report crashes.


                          Hey D-Hunter. I hope it works for you. can you post back and let us know how it went? I'm hoping more people can confirm this. Thanks!



                            Net Framework and C+ Redistributes will not solve the problem, in fact they hurt the situation.

                            Here's what you guys should try:

                            1. Uninstall any Microsoft Framework software.

                            2. Uninstall any Microsoft C+ Redistribution software.

                            3. Uninstall Unreal Tournament 3

                            4. Reboot.

                            5. Make sure you have the lastest DirectX version installed, along with the lastest drivers for your hardware.

                            6. If you overclock your CPU, increase voltage to your memory by at least 0.05v. Runtime problems are typically caused by errors in the memory.

                            7. Install Unreal Tournament 3, but this time install it in a different path. Like for me: C:\Games\Unreal Tournament 3. If you are using a 64-bit OS make sure not to put it in the "Program Files (x86)" folder.

                            8. Apply lastest patch and bonus packs if desired.

                            My specs for reference:
                            E-VGA NForce 780i SLI Mainboard
                            Intel Core 2 Duo E8500 3.15 Ghz Stock; OC'd to 4.6 Ghz.
                            8GB of PC1200 Memory GSkill
                            2 NVidia Geforce BFG 8800GTX OC2 Cards
                            Creative X-Fi Soundblaster Fatal1ty Soundcard
                            Silverstone 1500W PSU
                            Windows Server 2003 x64 (a.k.a Windows XP x64 Edition) with Service Pack 2.


                              Hey guys, new member, same problem as you. I think.

                              Im running XP SP2, Pentium D 2.8g, ATI Radeon x1300/1550 driver pack version 8.471 512mb, 1gig ram and onboard sound.

                              I am not technically minded but i have been having the same problem.

                              I loaded UT3 2 days ago and am only playing single player. I can do the first mission fine but when i play the second one it will always crash, sometimes when loading the level. Last night i noticed it said C++ when it was crashing to windows. I didn't get the details (im sure i will have another opportunity) but it also stated that one of the files was not authentic and that i should check it with the original. I have installed the 1.1 patch and downloded the C++ files stated in this thread and also the latest DX. The drivers for the video card are up to date and this is the only game i have a problem with but i do have oblivion installed. I have not tried to run oblivion since getting UT3. If there is more info i need to supply please let me know what and how to retreive it.

                              I will inform you of progress and try some other things from this thread also.

                              Can i be burried with you Makron2n?

                              EDIT: Moshman, if i delete the framework & c+ software do i reinstall it? If not, how will this effect my system?



                                Okay. I just tried the idea of shutting down one of my cores in my proseccor by loading the game, going to task manager and going to processes then right clicking the UT3.exe process and setting affinity and unchecking the CPU1 tab. This worked, i am able to play, but it is over working the processor and overheating (i think) because after about 1/2 hour it crashed then would crash after about 10sec of play. I am going to try the new intel pentium d windows id software and see if that works.