Announcement

Collapse
No announcement yet.

The Unfixed C++ Error Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Check your hardware first

    Comment


      #17
      Originally posted by DrFish View Post
      Check your hardware first
      Say what? My hardware's fine. Or at least my CPU and RAM are. My graphics card - well, given that stability improves with every driver update, I'd say it's not the hardware. Besides which, short of ripping it out, trying a different one and invalidating my warranty (yes I have a pre-build...from Chillblast), there's not a lot I can do. It does run other games...Temps are fine by the way, for example the CPU only reaches 48 degrees in stress tests. There are some huge-*** fans in there.

      Wideman, that pretty much sums up my problem. First map will load, and sometimes I can even complete a game. I completed the first level of the campaign mode yesterday. After that it will either crash when loading a level, or crash during play.

      asdfjkl, I do delete every UT3 directory when I re-install. It doesn't seem to make any difference for me, unfortunately.

      Comment


        #18
        Bump. Sorry.

        I'm still having the same trouble. I'm thinking about re-installing Windows though, since Windows Installer has packed up for no reason. A recent CCleaner scan removed CoD4's occasional texture glitch (somehow), but UT3 remains stubborn.

        Comment


          #19
          i had this error, and it got fixed when i re-applied the 1.1 update

          Comment


            #20
            Originally posted by Devil_Spawn View Post
            i had this error, and it got fixed when i re-applied the 1.1 update
            Do you mean after re-installing the game, or on top of a 1.1 update already installed? I haven't done the latter.

            EDIT: Tried it. Didn't work. However, disabling the Windows Security Centre and Defender services, as well as removing Windows Defender from the statup entries (which I have been doing), gave me a smoother game. For the one game that it lasted before having a C++ error. Still, one game - that's better than normal. If Windows Defender is completely on, the game won't play one game. Graargh!

            Comment


              #21
              What level of detail is the textures set to run at?

              Comment


                #22
                Originally posted by DrFish View Post
                Check your hardware first
                I wanted to blame the game too. But after adding a second 300w PSU to power the dual 7800GTXs all the problems went away. Yeah it's ugly but UT3 runs great now. Sure the hardware might be fine but is there enough power?

                Over on the ASUS forums someone said a 2% power drop is ok and 5% is a crashed machine. Not with UT3, a 2% drop will crash the game.

                Comment


                  #23
                  Texture settings are at 4. I've tried lower, but it doesn't make any difference. Apart from making the game look ugly.

                  I have a Thermaltake TR2-500 500W PSU. Enough? There's an 8800 GTS, an X-Fi, and two fans in there, along with the ol' Core 2 Duo E6550 overclocked to 2.9GHz (I've tried removing the OC, by the way). It's a Chillblast Fusion Colossus, basically, with an NZXT case upgrade and an X-Fi added. (I didn't ask for those, but the courier company got my PC and another guy's mixed up...long story.) To repeat the old mantra - "I can run Crysis y'know" - and so far only driver updates seem to have made any different to my PC's stability. That's Vista for ya.

                  By the way, I do NOT blame the game. I'm just not sure that it's my new-ish PC's hardware that's at fault here. Power connections are solid, too.

                  Comment


                    #24
                    Bump. Sorry. A friend of mine suggested recently that 500W wasn't enough for my PC. Do people here agree? And if so, should I be having words with the company that pre-built it? (Specs above.) I might try getting hold of a more powerful PSU at the weekend.

                    Comment


                      #25
                      A decent 500W PSU is way enough for any single card (BESIDES 3870 x2).

                      It can power my 2900XT (Uses about same power as 2 X1950XTs) and an overclocked Dual-core 3800+ (25% OC, little but it counts)

                      It's all about getting the right PSU. Aka, one with GOOD +12V rails. For a single card, you better have 30A on 1 +12V rail, or 35A +12V combined. The other stuff don't really matter.

                      For 2 graphics cards, 45A-55/60A is a very safe area. 50A should be enough in most cases.


                      As for the OP, *your* specific 500W sucks. It has 2 12V+ rails, one at 14A and another at 15A, but slyly, Thermaltake does not mention maximum load for +12V. Combined, the amps will be LESS than 29A. And the amps are probably peak numbers.

                      Comparing your system to mine, I have a same watt-rated PSU (Cooler Master iGreen Power 500W) that can deliver a constant 33 Amps from +12V, and has dynamic load balancing to cater to heavier draws. It has 3 rails, but the design itself is top-notch.


                      Let's compare: 29A Peak vs 33A Constant!
                      From this link:
                      http://www.atomicmpc.com.au/forums.asp?s=2&c=7&t=9354
                      We know that your 640MB uses 50W less than my XT, so that ammounts to about 4A more power draw on my PSU. So now it's 29A Peak vs 29A Constant.

                      That's pretty much a notable difference, and according to my own experience the difference should be 3-5W, aka 36W-60W supplied.

                      Comparing the other stuff, you have the same ammount of RAM, a bigger harddisk (though I have 2), a software X-Fi (same as my software Audigy) so power might be an issue.

                      My wager is that it's not. (Even though I suggest you replace it, Thermaltake's TR2 is highly infamous for supplying not enough power)

                      I put my blame on the software X-Fi. It's not a true X-Fi soundcard, all emulated in software. Disable OpenAL, and use your onboard audio. Try that first

                      Comment


                        #26
                        Originally posted by XEDR View Post
                        I put my blame on the software X-Fi. It's not a true X-Fi soundcard, all emulated in software. Disable OpenAL, and use your onboard audio. Try that first [/B]
                        Believe me I've tried disabling the entire soundcard before, and it didn't make the slighest jot of difference. VERY helpful and interesting PSU info though, thanks. I'm definitely going to invest in a replacement. Even if it doesn't solve my UT3 problem it'll cover me for the future.

                        Comment


                          #27
                          im bumping this because it was a good read.

                          Comment


                            #28
                            Originally posted by acidicvision View Post
                            im bumping this because it was a good read.
                            My PSU is arriving on Wednesday. I'll post here after I've found out whether or not it makes any difference.

                            Comment


                              #29
                              Originally posted by DrFish View Post
                              Guys, this has nothing to do with the .NET Framework. Trust me.

                              UT3 executable has not been compiled against the .NET Framework.
                              Then can you explain to me why when I installed UT3 the first time it actually installed some .net framework files? Or why after updating the .net framework Ut3 works for me now, when thats the only thing I did.
                              I didn't update any video drivers or replace any hardware.

                              Comment


                                #30
                                Same Problem

                                I just got a new pc custom built for me:
                                Asus Maximus formula se
                                E6550
                                2gb corsair dominator 1066 mhz
                                Asus 3850 512mb
                                550w antec power supply

                                I get the same problem after I install Oblivion. Unreal occasionally crashes but I figured it was driver problems with the 3850. But if I install oblivion, all my other games crash to windows or reset the computer.

                                On a couple of these crashes to windows, I have gotten a C++ error. Then if I go to play unreal it either crashes once a map goes to load up, or it crashes right after I start the program.

                                So I did a restore to a more stable time and Unreal works. Guess no Oblivion for me.

                                Comment

                                Working...
                                X