Announcement

Collapse
No announcement yet.

UT3 Crashes solved!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UT3 Crashes solved!

    Short answer:
    Turn off CPU stepping

    I've had nothing but problems since the demo, but I am finally crash-free! I didn't even have to uninstall anything. I'll spare you the details of the battle, but the following items helped me a lot:

    1. Change PumpWindowMessagesWhenRenderThreadStalled=True
    Going by the name, I believe this made my crashes less severe so I could switch to the task manager and close down the game.

    2. Install the patch! This fixed 90% of the problems.

    3. Turn off CPU stepping. This took care of the rest. I went in the bios and set whatever-they-call-it to Maximum. If your bios doesn't have this option, try a bios update or see below. (I didn't have any problems in Crysis, but perhaps that's because it doesn't have to reset very often and keeps the CPU at full? Total guess since UT2004 doesn't crash.) I have a feeling that changing windows power option to "Always On" will have the same effect, but I haven't tried it yet.

    Now I'm off to finally play the game I've been waiting 4 years for!

    Crappy specs:
    945GCT-M (new bios version)
    E2180
    CM2X1024-5400C4 2GB
    ATI x1300 Pro then ATI Radeon HD 2600 XT
    Windows XP (Linux soon I hope!)

    #2
    wtf to play this im not gonna **** up my bios. Ill wait for epic to make a decent patch. I hope they read the forums.

    Comment


      #3
      I have no idea what CPU stepping is or how to access it (im a real dumbass)

      Please enlighten me

      Comment


        #4
        Originally posted by The Devils Son View Post
        I have no idea what CPU stepping is or how to access it (im a real dumbass)

        Please enlighten me
        The most innocent reply award!
        But I think I have to agree with the second post. Don't wanna f@ck up ma' system by screwin around with the BIOS. My friend had to do a LOT of ***** to fix his comp after he tried to "fine tune" his BIOS.

        Comment


          #5
          I'm away from my computer this week, but try this alternative to messing with your bios:

          Start Button -> Control Panel -> (Click "Switch to Classic View" if you see those words on the left -> ) Power Options

          In the drop-down menu under "Power Schemes," change it to "Always On." Hit OK and try it out. I believe this should turn off CPU stepping.

          Comment


            #6
            I did all that and it still crashed on me.

            Comment


              #7
              Change to Always On

              I had the same issue. Getting thrown back to the desktop either when starting a level or seconds later (locked up then had to ctrl-Alt-delete to close UT.

              I changed the power settings to "always on" as above and have been playing for several hours uninterupted.

              Comment


                #8
                Just so people know what they are changing maybe a simple description is in order. Speed Stepping is used to control the efficiency/temp dissipation of the cpu.

                When your PC is sitting idle the processor multiplier will drop so that instead of your processor running at say 3.0GHz it will run at 2.0GHz. This will bring the operating temperature down saving power etc...

                Whilst there are no major disadvantages to doing this there are some things you may wish to consider:

                1. CPU idle temps will be higher and this may result in your CPU fan running at higher speeds / more noise

                2. Uses more electricity (ok it prob wont even be noticed in your electricity bill but still something to consider)

                3. Increased Temps reduce life expectancy of the CPU.

                TBH non of these are major concerns but may help in making your decision. But hey, if its gets you playing UT3 what else can you do?

                Comment

                Working...
                X