Announcement

Collapse
No announcement yet.

Runtime error after applying patch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Runtime error after applying patch

    I scanned the post list and don't see this yet. I apologize if I missed it.

    I applied the 1.1 patch. Now when I start UT3 I immediately get the error: "Runtime error! This application has requested the runtime to terminate it in an unusual way." Then I get the regular old application crashed, do you want to send a report window.

    I reapplied the patch with the same result. I also tried deleting my .ini files to let UT3 recreate them, with the same result.

    I googled, and Microsoft has a hotfix you need to request if you get this error, but they warn you not to try it unless you really need to. I would rather not try that route if there's an easier solution.

    edited to add my specs:
    WinXP
    Athlon 64 X2 4000
    2 GeForce 8600gt's in SLI mode
    2 gigs RAM

    #2
    Nevermind...Silly me, I had renamed the UT3 exe while experimenting with creating SLI profiles....so the patch made a new exe, while my shortcut was still pointing to the old exe ...I feel really dumb

    Comment


      #3
      Runtime Error

      I am now getting this error after patching to 1.1. I did not rename anything like Wartribble did. Reboot does not help, reapply patch does not help, doubleclick ut3.exe directly or from start menu does not work. Downloading the patch again from secondary site, reapplying does not work.

      Exact error is:

      Microsoft Visual C++ Runtime Library

      Runtime Error
      Program: C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe

      This application has requested the Runtime to terminate it in an unusual way.
      Please contact the application's support team for more information.

      Anybody else ever get this and manage to fix it?

      ARC

      Comment


        #4
        Originally posted by ARCSolo View Post
        I am now getting this error after patching to 1.1. I did not rename anything like Wartribble did. Reboot does not help, reapply patch does not help, doubleclick ut3.exe directly or from start menu does not work. Downloading the patch again from secondary site, reapplying does not work.

        Exact error is:

        Microsoft Visual C++ Runtime Library

        Runtime Error
        Program: C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe

        This application has requested the Runtime to terminate it in an unusual way.
        Please contact the application's support team for more information.

        Anybody else ever get this and manage to fix it?

        ARC
        Havn't seen that issue before, you using Vista or XP? The only suggestion from me is to remove the game and install it again then re-apply the v1.1 patch.

        But you could try searching google for the Visual C++ Runtime files and install those, im sure there are some for C++.

        Comment


          #5
          I have seen that error pop up on me once or twice. A restart of the 'puter and relaunching UT3 worked fine the next time.

          Comment


            #6
            I am using 32 bit Vista.

            Rebooting does not clear it up.

            I reinstalled UT3, it launches fine. Apply the 1.1 patch, same error again. Kinda makes me wish the patch were easily removed!

            So, anybody got any ideas?

            Comment


              #7
              Runtime Error fixed

              It seems I have fixed the problem. I was able to find many forum posts of the exact same error for ut2004. A number of folks were able to fix the issue through updating video drivers or changing video "stuff". So I checked and evga had some new drivers out there.

              So I installed drivers 169.28 (released today) from evga web site, reapplied the 1.1. patch and so far all is good again.

              Thanks for the replies and I hope my solution works for others!

              ARC

              Comment


                #8
                It's baaaack!

                It seems I was too optimistic. The issue, same error is back. This time the app will launch on the third try every time. Strange.

                EDIT: Just saw this http://utforums.epicgames.com/showthread.php?t=597558

                oops!!

                Comment


                  #9
                  dude, i went to it and the linky doesnt work for that random site...
                  i have the same problem with the microsoft runtime error C++...
                  i cant seem to fix it
                  i have vista 64bit and i also have the lates graphics drivers 169.25 WHQL from the nvidia site, i mite try the 169.25 BETA driver nd see if thats any better, i doubt it tho

                  Comment


                    #10
                    this is so homo i cant even login in the login screen now befor i do the error comes up, nd im like WTF GO AWAY U *******!!!!!! i so hate this error now im about to get the game cd nd feed it to my dog

                    Comment


                      #11
                      Try completely uninstalling your drivers in safe mode with Driver Sweeper and reinstalling 169.28.
                      http://www.guru3d.com/index.php?page=driversweeper

                      Comment


                        #12
                        thankyou
                        ill give it a try

                        Comment


                          #13
                          hmm, it seems to be more anoying now, i cant load a map without it happening, all graphics settings are defualt exept for the resolution which i put up to 1680x1050

                          Comment


                            #14
                            PAPA600, have you read Ultron's sticky post? You should probably try the UTEngine.ini tweaks because they report the most success with the least effort. Find that file here:
                            My documents\My Games\Unreal Tournament 3\UTGame\Config\

                            For simplicity, set as follows:

                            [Engine.ISVHacks]
                            UseMinimalNVIDIADriverShaderOptimization=True
                            bInitializeShadersOnDemand=True
                            PumpWindowMessagesWhenRenderThreadStalled=True

                            [SystemSettings]
                            OnlyStreamInTextures=True

                            Make sure Hardware OpenAL audio is disabled in the settings menu and if anything is overclocked, set it back to stock.

                            Comment


                              #15
                              Nope same outcome started 3rd part of campaign nd Windows runtime error C++

                              Comment

                              Working...
                              X