No announcement yet.

Can't re-install UT3!?

  • Filter
  • Time
  • Show
Clear All
new posts

    Can't re-install UT3!?

    It's become impossible for me to get UT3 running so I thought re-installing the game (again) might work. My main problem was that the game would never initiate after the splash screen. No game. No error messages or windows. Nothing. Just the desktop.

    And now after 'supposedly' uninstalling UT3, now I can't re-installing it. The UT3 Launcher on the DVD has 3 buttons (To Launch, To Install, To Uninstall). Both Launch and Uninstall are whited but the Install button is greyed out .

    So I looked into the DVD for the Setup executable for UT3. Double clicked that and a window pops up saying if I wanted to remove the application and all it's features.

    I already uninstalled this thing through Add/Remove Programs in Control Panel and did a registry sweep right after with CCleaner and now it's telling me to uninstall it some more?

    Am I missing something...? lol. Is there a registry file Ut3 snuck in my computer that I don't know of that's confusing the @#$% out of it?

    Take a look in your registry at:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Uninstall
    and delete this folder:

    Try again


      Originally posted by mahe View Post
      Take a look in your registry at:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Uninstall
      and delete this folder:

      Try again
      The folder is non-existent . Can't find it m8 lol.


        go on the cd and execute the install not the cd pop up


          That's exactly what I did after the 'Install' Button was greyed out on the Launcher. Still no go .



            Does anyone know how to resolve this? I've decided to again try my annual attempt at fixing UT3 and have got stuck at this stage with the same problem. I suspect it may be due to not uninstalling it from the CD menu but through the Windows or other (as in my case) uninstaller.

            In any case I have uninstalled the game. The Install button on the CD menu is greyed out. The Uninstall option and Setup.exe run from CD both give errors (would the details on these help?*). I have tried rebooting and I also tried deleting the UT3.exe reg key and cleaning my registry all to no avail.

            I think this happened to me last year also and I managed to get round it somehow but I can't for the life of me remember how.

            Any suggestions would be gratefully received.



            * Edit:
            1. Running SetupUT3.exe - after the preparing to install part it asks if I want to completely remove it (i.e. it thinks it's still installed). If I say "Yes" I get an error saying the action is only valid for products already installed or something like that.
            2. Choosing "Uninstall" from the CD menu gives error "1628: Failed to complete installaion".

            It's stuck in some sort of loop where the CD menu thinks it's already installed but the rest of it can see that it is not. Urggh.


              * It sounds like you still have something installed [mods/ titan mods, cbp3]-
              - you should still be able to run an uninstall- and if ut3 is not installed - it will install.
              - that's right the uninstall button is also an install button..
              - If not - then this might help.
              03-23-2012, 03:41 PM #3
              MSgt. Shooter Person
              Join Date
              Jun 2009

              This is a registry problem. But UT3/UDK is running well portable ... meaning, you don't need to install a version. The InstallShield routine is just browsing for a installed application specified in its Setup.ini. AFAIK, UT3 isn't acessing the registy at all. There something wrong with your system.
              Virus, Malware, CC cleaner, Tweak software, ...

              A lite fix:
              Copy this content
              Windows Registry Editor Version 5.00

              [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Uninstall\InstallShield_{BFA90209-7AFF-4DB6-8E4B-E57305751AD7}]
              "InstallLocation"="C:\\Program Files\\Unreal Tournament 3\\"
              Change the path and save it to a file "temp.reg"
              Doubleclick and import this file into registry (or open "regedit.exe" and import that file)
              Done (check the Launcher)

              The value "BFA90209-7AFF-4DB6-8E4B-E57305751AD7" can be different on a another OS or localized UT3. Therefore you need to change that to ... ehm something. Report if it's not working.

              The full fix would be to add every other value so you can uninstall UT3. But this would take too much time. Just (backup the profile folder, ) install UT3 and unistall.

              PS: UT3 works fine without a disc. You don't need a new one for this problem.


                Check every location on HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER and remove it.

                "SOFTWARE\Microsoft\Windows\CurrentVersion\Uninsta ll\InstallShield_{C019D439-E7F8-49EB-85FA-6D0C8CCBDA23}"
                "SOFTWARE\Microsoft\Windows\CurrentVersion\Uninsta ll\InstallShield_{A007C579-B78D-4FDE-A85A-16987A251E53}"
                "SOFTWARE\Microsoft\Windows\CurrentVersion\Uninsta ll\InstallShield_{FDBBAF14-5ED8-49B7-A5BE-1C35668B074D}"
                "SOFTWARE\Microsoft\Windows\CurrentVersion\Uninsta ll\InstallShield_{69082C6E-1944-4EAD-B119-06DCBF492C3F}"
                "SOFTWARE\Microsoft\Windows\CurrentVersion\Uninsta ll\InstallShield_{BFA90209-7AFF-4DB6-8E4B-E57305751AD7}"
                "SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVer sion\Uninstall\InstallShield_{C019D439-E7F8-49EB-85FA-6D0C8CCBDA23}"
                "SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVer sion\Uninstall\InstallShield_{A007C579-B78D-4FDE-A85A-16987A251E53}"
                "SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVer sion\Uninstall\InstallShield_{FDBBAF14-5ED8-49B7-A5BE-1C35668B074D}"
                "SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVer sion\Uninstall\InstallShield_{69082C6E-1944-4EAD-B119-06DCBF492C3F}"
                "SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVer sion\Uninstall\InstallShield_{BFA90209-7AFF-4DB6-8E4B-E57305751AD7}"