Announcement

Collapse
No announcement yet.

Intermittent Crashes Sometimes Ctrl-Alt-Del'able

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Intermittent Crashes Sometimes Ctrl-Alt-Del'able

    Hello,

    I thoroughly enjoy Unreal Tournament 3, but it crashes (seemingly) randomly and it's really hurting the experience.

    I will be playing Warfare online and anywhere from 5 to 45 minutes in the game will lock up. It stops moving at a certain frame and will not recover. Sometimes the music and sound effects will continue, in those cases the game can be ended by Control-Alt-Delete. Other times the audio stops at the exact second as the video, and a hard reboot is the only option.

    I'm able to play Unreal Tournament 2004 for several hours without crashing, and after ctrl-alt-del'ing some UT3 crashes, I see that my video card is no more than 45 degrees celsius. I'm stumped.

    Here is my hardware information:
    Asus P5K-VM Motherboard
    Intel Core 2 Duo E6750
    WINTEC AMPO 2GB DDR2 800
    Sapphire ATI HD 2600 XT
    Sound Blaster Audigy 2 ZS Platinum Pro
    A recent Installation of Windows XP Pro SP2

    I'm willing to try any ideas (including reformatting) to fix this problem so I can play the game without fear. Please advise!
    Thanks,
    -guyinco6nito

    #2
    Have you tried this yet?

    http://utforums.epicgames.com/showthread.php?t=590086

    Comment


      #3
      Not Yet.

      When I get home I'll try re-installing DirectX, disabling startup items, and disabling OpenAL.
      I'll post back after testing (testing isn't too bad when it's playing this game!)

      _______________
      guyinco6nito

      Comment


        #4
        DirectX and OpenAL Updates Fail

        I updated DirectX and OpenAL to the latest available versions and restarted.

        Playing Warfare I had just crushed the enemy orb carrier under my manta when I got out to link-build the enemy prime node. When I walked back towards the manta I continued walking forwards after I reached it for a fraction of a second, then pressed 'e' and the game crashed.

        I'll now try disabling OpenAL.
        -guyinco6nito

        Comment


          #5
          OpenAL Not the Problem

          I disabled OpenAL and the game frozeas I drove a Hellbender into a wall.
          I was able to ctrl-alt-del and found the UT3.exe was using 99% of my processor and 600 megabytes of ram.

          Not sure what to try next.

          Any Ideas?
          -guyinco6nito

          Comment


            #6
            After changing settings in the .ini save and make the file read only.

            Try setting to what's showen below in the UTEngine.ini:

            Code:
            [SystemSettings]
            OnlyStreamInTextures=True
            OneFrameThreadLag=False
            If that doesn't work then try this next in the UTEngine.ini:

            Code:
            [Engine.ISVHacks]
            DisableATITextureFilterOptimizationChecks=False
            PumpWindowMessagesWhenRenderThreadStalled=True

            Comment


              #7
              Promising Initial Results

              I tried the first 2 changes you suggested, namely:

              -Change C:\Program Files\UT3\Engine\Config\BaseEngine.ini to read-enabled (not read only).
              And then inside that file change:
              -OnlyStreamInTextures=True
              -OneFrameThreadLag=False

              Then set the file back to read-only. When I launched the game it told me I needed to rebuild UTEngine.ini. I said yes, and then was able to play for 2 complete rounds without crashing. That has happened before, so the problem might still persist. I'll play some more tomorrow.

              Thanks, and have good ones,
              -guyinco6nito

              Comment


                #8
                Negative. Proceeding

                My computer crashed while playing Dusk while I was on a hoverboard trying to enter the gun seat of the goliath.

                Now trying your second suggestion, modifying the latter 2 variables in E:\ProgFiles\UT3\Engine\Config.

                ___________________
                guyinco6nito

                Comment


                  #9
                  No Dice

                  No more than 5 minutes in I was in a manta on the way to the enemies core, when my manta was destroyed by an AvRil (Longbow), and the game froze, requiring a restart.

                  I'll be reformatting tomorrow, any advice on a good order of installations could be useful.
                  have good ones,
                  -guyinco6nito

                  Comment


                    #10
                    These changes need to be made in the "My Documents\My Games\Unreal Tournament 3\UTGame\Config" folder not the "Program Files" folder ...

                    And the file your looking for is "UTEngine.ini"

                    Comment


                      #11
                      Scratch That

                      I've fixed it!

                      I had to turn down World Detail and Texture Detail to 2!
                      Since then the game runs more smoothly and doesn't crash after hours of play.

                      Seems the game was pushing my HD 2600 XT too far, and rather than lower the FPS, it crashed it.
                      Thanks for the help, and if you have problems, turn it down!


                      Have good onces,
                      -guyinco6nito

                      Comment


                        #12
                        Scratch THAT

                        I just reformatted, installed UT3, set it to 2, and it crashed 10 seconds in.

                        I would like to update DirectX (still running 9), but the site it inexplicably down, with a Microsoft Sharepoint error page :-(

                        -guyinco6nito

                        Comment


                          #13
                          My problems were exactly the same.

                          Try this:

                          http://utforums.epicgames.com/showthread.php?t=587511

                          I haven't crashed since. Apparently there is a "memory leak" which these two .ini tweaks corrected at least for me and several others.

                          Comment


                            #14
                            Thank you, but I've reached stability

                            Hi,

                            It's funny, since that first crash I last posted about, the game has been completely stable on my reformatted machine.

                            Turning the World Detail and Texture Detail to 2 fixed my crashing problem, and improved my fps to a near-constant 62.

                            Thank you for the help, but unless I could help Epic by testing something, I'm considering the problem solved.
                            -guyinco6nito

                            Comment


                              #15
                              Hey

                              Hey incognito i had the same problem,and i solved it reducing FOV to 80 and the screen percentage to 50,with these settings you can move up in resolution to compensate graphics

                              Leave world & texture details on 2

                              Post results!

                              OmNiPoTeNcE

                              Comment

                              Working...
                              X