No announcement yet.

I cannot create a profile. Game otherwise is fine

  • Filter
  • Time
  • Show
Clear All
new posts

    I cannot create a profile. Game otherwise is fine

    Okay, this is stupid.

    I bought the game yesterday, and as I said above I was having problems just getting to login and create my account.

    When I try to create a new profile I get the error:
    the password you supplied is incorrect for the existing account based on your specified e-mail address.
    I have tried everything from using other email addresses to creating a completely new e-mail address. Same error.

    If I go to to retrieve my password (I created an account for the demo using the in-game process and it was working fine) it just gives me an error
    Error: An error occurred while sending the email.
    I called midway's tech support but it just dumps you to voicemail.

    I don't see **** about this on google or the midway forums. But certainly I can't be the only one having this issue.

    I would really like to play the game I paid $50 for. Has anyone else seen anything about this?

    Why do companies ever ****ing use GameSpy anyways? when was the last time GameSpy was even relevant? 10 years ago when it was a free Quake server browser?

    Hi. So you're saying you can't create a new UT3 profile in-game?

    Have you tried using a fake email address? If that still doesn't work, PM the username and password you'd like to use and I'll try it on our end.


      I am having difficulty as well, The game plays fine offline but when I try to create a profile I get an error as follows:
      The online service is currently unavailable. Please wait and
      try reconnecting again"

      I have tried several times since the game came out, as well as with the beta to no success.


        Have you tried allowing ut3 in your software firewall (assuming you have one) / bypassing your router's firewall?