Announcement

Collapse
No announcement yet.

Trouble modifying UTInput.ini (changes are not saved) UPDATE: workaround

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    If the key you want to use has another reference in "[Engine.PlayerInput]" it wont work so you can put a # at the start of that line and it will be ignored.

    Also if you have the key you want to use set as a bind in the in game settings it wont work. You have to set any reference to that key to something else.

    Comment


      #17
      I tried now in the UTinput.ini:
      Code:
      [Engine.PlayerInput]
      Bindings=(Name="J",Command="suicide")
      
      [UTGame.UTPlayerInput]
      #Bindings=(Name="J",Command="GBA_Taunt1",Control=False,Shift=False,Alt=False)
      What happens is: the change in the upper section stays, and in the lower section, a new line appears with the same content as the out-commented line, so I get:
      Code:
      #Bindings=(Name="J",Command="GBA_Taunt1",Control=False,Shift=False,Alt=False)
      Bindings=(Name="J",Command="GBA_Taunt1",Control=False,Shift=False,Alt=False)
      but the command still does not work.

      €dit:
      Tried the following:
      Code:
      [Engine.PlayerInput]
      Bindings=(Name="J",Command="suicide")
      
      [UTGame.UTPlayerInput]
      Bindings=(Name="J",Command="suicide",Control=False,Shift=False,Alt=False)
      The upper line stays, the lower gets changed back to
      Code:
      Bindings=(Name="J",Command="GBA_Taunt1",Control=False,Shift=False,Alt=False)

      Comment


        #18
        "J" is being used in this line.

        [Engine.PlayerInput]
        Bindings=(Name="J",Command="GBA_Taunt1")

        so change it to this.

        #Bindings=(Name="J",Command="GBA_Taunt1")

        But also J is set in the in game bindings. Settings / input / keys

        Scroll down to "Taunt 1" and click "J" now bind it to a key that is not in use say "x" click accept.

        Exit and restart the game, now it should work.

        Comment


          #19
          You have to change them in both places for some of the bindings to work (not sure if it's all or just some of the keys not listed in the GUI.) Otherwise the top, i.e. default, lines will overwrite the user-modded lines at start. I've had to do this with a few of them...screenshots was one I believe.

          Comment


            #20
            OK, following the post by Zoo, I did the following: I took an unused letter, x in this case, and added in the UTinput.ini:
            Code:
            [Engine.PlayerInput]
            Bindings=(Name="X",Command="suicide")
            I did NOT add this line under [UTGame.UTPlayerInput]. And guess what? It works. So, what I did next was starting the game, and removing all unwanted binds to free more letters. I will now try to bind even more. Update soon to follow.

            Comment


              #21
              Update:
              I removed as many default key-binds as possible. Only 3 remained.
              Next I typed in the console:
              Code:
              setbind a becomeactive
              setbind d disconnect
              setbind h Say Hi
              setbind v behindview
              and these changes are saved in the utinput.ini. They really work now.

              Next I will try to bind voice-orders like "Defend the base" or something to a key. Dunno exactly how I can access them though.

              Comment

              Working...
              X