Announcement

Collapse
No announcement yet.

Trouble modifying UTInput.ini (changes are not saved) UPDATE: workaround

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trouble modifying UTInput.ini (changes are not saved) UPDATE: workaround

    Hi there.
    I just tried to define 2 keys to
    1) suicide
    2) say Hi
    but direct changes in the ini are removed when starting UT3.
    When using the setbind-command via console, I can define the keys to what ever I want, but it is NOT saved to my ini. After restarting UT3, those 2 keys are reset.

    So my question is: HOW exactly do I change my ini, so that my changes are saved and are usable when running the game?

    #2
    Anyone?
    I´d be glad for some help.

    Comment


      #3
      Open UTInput.ini.

      Scroll down a bit and find the keys you want. Then change the action that they are set to (there is loads of them that are there and you would probably learn it as you go along).

      Comment


        #4
        So I took
        Code:
        Bindings=(Name="B",Command="GBA_ToggleSpeaking",Control=False,Shift=False,Alt=False)
        and changed it to
        Code:
        Bindings=(Name="B",Command="suicide",Control=False,Shift=False,Alt=False)
        . Then saved my changes.

        I started the game and the keybind did not work. Afterexiting the game and opening the ini again, the line was back to
        Code:
        Bindings=(Name="B",Command="GBA_ToggleSpeaking",Control=False,Shift=False,Alt=False)
        I must be doing something wrong.

        Comment


          #5
          Your are not modifying the good files. Search ini files in "My Documents" and not in the game directory.

          Comment


            #6
            Nah, I did modify the files in My Games.

            Comment


              #7
              Try changing UTInput.ini, then making it Read-Only.

              Comment


                #8
                Doesn´t work. The only difference with "Read-only" is, my changes in the ini are not changed back when running the game. They are still in the ini, but they don´t work.

                Comment


                  #9
                  I've seen this happen in the demo, but not in the retail version.

                  Try creating another account name and log in with that one to see if that works.

                  Comment


                    #10
                    I have now created another login, but it still does not work.

                    Comment


                      #11
                      Same problem.

                      As a workaround I'd like to be able to use `setbind` along with the pipe "|", no luck yet.

                      Comment


                        #12
                        Did you figure this out yet? I am having the exact same issue. I make changes but they don't do anything.

                        Comment


                          #13
                          When I use
                          Code:
                          setbind a becomeactive
                          in the game (typed in the console) I actually can use that keybind as long as I don´t exit the game. If I restart the game, the bind is gone. Really annoying.

                          Comment


                            #14
                            If you want to change the bindings in the input.ini you have to change the ones at the top "[Engine.PlayerInput]" not the ones at the bottom "[UTGame.UTPlayerInput]".

                            Comment


                              #15
                              I do change the ones at the top, and they stay changed, but they do nothing in the game.

                              Unless there is something wrong with this:

                              Bindings=(Name="Enter",Command="switchweapon 4")

                              I want to use Enter to switch to Shock, is this right?

                              Comment

                              Working...
                              X