Announcement

Collapse
No announcement yet.

UT.exe has encountered a problem and needs to close.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UT.exe has encountered a problem and needs to close.

    Hello all I have been waiting for a patch to fix problems like everyone else. I'm sure others have had the same problems like this one but I guess I will post mine here too. If I try to run the game it locks up after the splash screen and I get the UT3.exe error out. Event View in XP gives me this for the problem:

    Event Type: Error
    Event Source: Application Error
    Event Category: None
    Event ID: 1000
    Date: 12/4/2007
    Time: 8:55:15 PM
    User: N/A
    Computer: RAGE
    Description:
    Faulting application ut3.exe, version 0.0.0.0, faulting module kernel32.dll, version 5.1.2600.3119, fault address 0x00012a5b.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 41 70 70 6c 69 63 61 74 Applicat
    0008: 69 6f 6e 20 46 61 69 6c ion Fail
    0010: 75 72 65 20 20 75 74 33 ure ut3
    0018: 2e 65 78 65 20 30 2e 30 .exe 0.0
    0020: 2e 30 2e 30 20 69 6e 20 .0.0 in
    0028: 6b 65 72 6e 65 6c 33 32 kernel32
    0030: 2e 64 6c 6c 20 35 2e 31 .dll 5.1
    0038: 2e 32 36 30 30 2e 33 31 .2600.31
    0040: 31 39 20 61 74 20 6f 66 19 at of
    0048: 66 73 65 74 20 30 30 30 fset 000
    0050: 31 32 61 35 62 0d 0a 12a5b..

    My specs on my computer are:

    Asus P5WD2-E Premium
    Intel Pentium D 950 3.4GHz
    Western Digital Cavair SE WD800JD
    Western Digital Caviar SE16 WD2500KS SATA 3.0Gb/s
    2 Sapphire Radeon X1600XT 256MB PCI Express x16 Running CrossFire
    2 Crucial Technology 2GB 240-Pin DDR2
    Windows XP SP2
    Running DirectX 9.0c (With November 2007 Updates)
    My video card drivers are Catalyst Software Suite v7.11
    I have onboard Sound Realtek High Definition Audio Drivers are v5.10.05506

    I wish this forum page and a file upload so can can post my DirectX info file.

    I haven't been able to get the game to run at all but I can play other new game that have come out. I would like to play this game since I payed the $50 for it. I like Unreal Tournament games. If anyone knows how to fix this I would like to know.

    Thanks

    #2
    Same Thing

    well i have the same problem as you and still no answers if i get one ill tell you and if u get it tell me plz cuz my parents are ****** off that this game does not work

    Comment


      #3
      Getting the same error as some other people run the install of the game, restart the computer, go to run UT3 first splash screen comes up hangs for about 30 secs.
      Then the error "UT3.exe has encountered a problem and needs to close" pops up and kills the game. Go to event Viewer and get:

      Faulting applicationut3.exe, version 0.0.0.0, faulting module ct_oal.dll, version 5.12.1.441, fault address 0x00010636.

      0000: 41 70 70 6c 69 63 61 74
      0008: 69 6f 6e 20 46 61 69 6c
      0010: 75 72 65 20 20 75 74 33
      0018: 2e 65 78 65 20 30 2e 30
      0020: 2e 30 2e 30 20 69 6e 20
      0028: 63 74 5f 6f 61 6c 2e 64
      0030: 6c 6c 20 35 2e 31 32 2e
      0038: 31 2e 34 34 31 20 61 74
      0040: 20 6f 66 66 73 65 74 20
      0048: 30 30 30 31 30 36 33 36
      0050: 0d 0a ..


      Things I have tried

      updated OpenAL, DirectX, Sound/Video/ Motherboard/PhysX drivers went threw the FAQ for the "Clean Start"
      Ran CCleaner. As well as all the different ini fixes as well

      Specs of my Box:
      AMD Athlon 64 X2 Dual Core 6000+
      2.0 GB of Corsair Ram
      Nvidia EVGA GeForce 8800 GTS 512 Ram
      Asus Crosshair Motherboard ( Chipset Nforce 590 SLI)
      HDD Western Digital Raptor 150
      Windows XP SP2
      DX9.0c w/ November 2007 UPdates
      Sound Card Creative SB Audigy 2 ZS

      Comment


        #4
        Also having the same issue, I can however sometimes get in a multiplayer game for the duration but when we move to the next game it closes out and such, otherwise I could be doing a bot match and it closes due to that error, or it will close right from the start, my friend installed using my disks as well and his will close right after opening, or just freeze up, he has also gotten the same error message. If anyone finds out please let me know, I heard they were supposed to be patching it in December, but I've heard nothing further, and have just registered on forums to start asking questions :P. Thanks.

        Comment


          #5
          Have you tried running the game with either the -nosound or -novideos options? By the error it looks like there's a problem with an OpenAL component.

          A lot of people have been complaining about lockups, and have been presuming it's an issue with the video card, when in fact it's been an OpenAL issue.

          Originally posted by Jakey2.0 View Post
          I have found (thanks to this thread) that just renaming the wrap_oal.dll within the UT3\bin directory gains a similar result - 5.1 surround sound without crashes.

          Digging further, it seems that wrap_oal.dll can work standalone when renamed to openal32.dll, but this will cause the game to enumerate available sound devices slightly differently. Basically, the custom features of the X-Fi are no longer exposed.

          Anyway, there is does seem to be a minor loss of sound quality with the workaround - it doesn't sound quite as "rich". I suspect it's down to the AL_RENDERER being Software based - but at least there's 5.1 sound, and a stable game. A step in the right direction, and acceptable until the issue is hopefully resolved by either Creative or Epic...
          This file can be found here:

          C:\Program Files\Unreal Tournament 3\Binaries

          -

          Originally posted by flikflak View Post
          I run an unpatched UT3 under WinXP with a X-Fi Elite Pro and just fixed this annoying OpenAL problem!

          Here's what to do:

          Copy both OpenAL32.dll and wrap_oal.dll from Windows\system32\ to UT3\Binaries\ replacing Epic's outdated files... And voilĂ ! Switch OpenAL back on in UT3 and restart the game.

          2 rounds WF and 2 DM maps later in OpenAL bliss, not a single crash/freeze!
          Shame on Epic for the old buggy files, but I'm glad it was that simple actually!
          Keep in mind that, in the event the UT3 files are newer than the ones you are trying to replace them with, keep the newest versions where they are in the UT3 Binaries folder.

          -

          Originally posted by OverToad View Post
          So far tonight, I've now played for three hours straight with numerous games on Deck, and haven't locked up. My personal fix?

          UNCHECK OPENAL IN THE IN-GAME MENU SETTINGS.

          Will it work for you? I can't say that, but it did work for me. Goodluck, and thanks to those that offered constructive help!

          Comment


            #6
            Ok I have tried the -nosound and -novideo options. The OpenAL is a Creative Labs file for their X-FI cards. I don't have a Creative Labs card mine is an onboard chip from Realtek, which is from a different company so is there away to turn off OpenAL alltogeter in the ini files or do I have to want for a patch to fix this. I would like to play the game if I can.

            Comment


              #7
              Update your dirvers I think,



              For anyone with an Nvidia card getting a crash in kernel32.dll (this does not affect blue/black screen errors), try this workaround:

              First, make sure you are on 163.71 Nvidia drivers.

              If you are an administrator, Open: Program Files\Unreal Tournament 3 Demo\UTGame\Config\UTEngine.ini
              Otherwise open: My Documents\My Games\Unreal Tournament 3 Demo\UTGame\Config\UTEngine.ini

              Change the line
              bInitializeShadersOnDemand=False
              to
              bInitializeShadersOnDemand=True

              *RESTART BEFORE TRYING TO RUN THE GAME AGAIN*

              Comment


                #8
                That might work for Nvidia cards. I have an ATI card but thanks for the info. I still get the same error and I have tried alot of different steps in the forums to find out why I get the UT3.exe error. I still haven't found out what is the cause or what is causeing it. Thanks for all your guy's input.

                Comment


                  #9
                  Originally posted by Ragepro View Post
                  Ok I have tried the -nosound and -novideo options. The OpenAL is a Creative Labs file for their X-FI cards. I don't have a Creative Labs card mine is an onboard chip from Realtek, which is from a different company so is there away to turn off OpenAL alltogeter in the ini files or do I have to want for a patch to fix this. I would like to play the game if I can.
                  OpenAL is a "free software cross-platform audio API" which means that it's not just for Creative cards. They are behind it, but it's a standard for everyone.

                  I don't know how to disable it in the UTEngine.ini - I suspect it's a matter of specifying the name of the audio device to be used. Either the OpenAL device, or some other name. But I haven't had the time to experiment. I do know this: If you load up the game with the -nosound option, you should be able to go into the Audio Settings in-game and Disable OpenAL. Then restart the game without it.


                  Originally posted by Ragepro View Post
                  That might work for Nvidia cards. I have an ATI card but thanks for the info. I still get the same error and I have tried alot of different steps in the forums to find out why I get the UT3.exe error. I still haven't found out what is the cause or what is causeing it. Thanks for all your guy's input.
                  I see in a previous post made by you on another forum that you are running 2 Radeon X1600XT video cards in Crossfire - so I am also going to recommend that you disable Crossfire for the sake of troubleshooting. SLI and Crossfire often don't work or have problems with many videos games, and it looks like there have been issues with both for UT3 as well. Expect a) new drivers from ATI and Nvidia to help and b) Epic to also provide patches that will help. But these things will take time. Im the meantime, you can try disabling Crossfire and OpenAL and see if that helps.

                  Here are some other options you might try:

                  Edit the UTEngine.ini which can be found in My Documents\MyGames\Unreal Tournament 3\UTGame\Config.

                  [Engine.ISVHacks]
                  DisableATITextureFilterOptimizationChecks=False
                  bInitializeShadersOnDemand=True
                  PumpWindowMessagesWhenRenderThreadStalled=True


                  ...and then...

                  [SystemSettings]
                  OnlyStreamInTextures=True


                  Let us know if that works.

                  Also, if you still have problems, try the other tweaks in my thread, listed in my sig below.

                  Comment


                    #10
                    I have the exact same problem. I'm running VIsta x64 with the following system:
                    Q6600 G0 SLACR @ 3.6 (400x9)
                    ASUS Maximus Formula X38
                    4Gb Crucial Ballistix @ DDR2-1066 5-4-4-12 35
                    Silverstone DA850 PSU
                    2 Diamond HD 2900XTs 1Gb GDDR4 Crossfire Swiftech MCW60||MCP655||BGA Ramsinks
                    Thermalright Ultra 120 Extreme 120mm push/pull
                    X-Fi XtremeGamer PCI with latest drivers
                    OCZ XTC Memory Cooler
                    Thermaltake Armor Silver
                    EK-Multioption RES 250 Rev 2
                    Black Ice 480GTX 8 120mm Yate Loon push/pull
                    Here is the info from event viewer:
                    Faulting application UT3.exe, version 0.0.0.0, time stamp 0x471afd16, faulting module atiumdag.dll, version 7.14.10.540, time stamp 0x473cc5ab, exception code 0xc0000005, fault offset 0x0003a032, process id 0x390, application start time 0x01c8371adf1150c4.
                    System

                    - Provider

                    [ Name] Application Error

                    - EventID 1000

                    [ Qualifiers] 0

                    Level 2

                    Task 100

                    Keywords 0x80000000000000

                    - TimeCreated

                    [ SystemTime] 2007-12-05T08:45:12.000Z

                    EventRecordID 7813

                    Channel Application

                    Computer PWNZERSHRECK

                    Security


                    - EventData

                    UT3.exe
                    0.0.0.0
                    471afd16
                    atiumdag.dll
                    7.14.10.540
                    473cc5ab
                    c0000005
                    0003a032
                    390
                    01c8371adf1150c4

                    Comment


                      #11
                      Darkside, heed the same advice I gave RagePro above. Disable SLI. See what happens. Still a problem? -nosound and disable OpenAL. Still a problem? Go down the list. Let us know what works for you.

                      Comment


                        #12
                        Hi guys. Ultron's giving some great advice. I'd start with disabling crossfire.

                        Enabling OpenAL with a realtek sound card will crash. It comes disabled by default, so nuking your ini files will remove it if you set it manually (default \my docs\my games\unreal tournament 3\utgame\configs...delete all the UT*.inis...leave the ones that start "default*.ini").

                        Comment


                          #13
                          I just want to say that only some Realtek cards might have this problem. I use a Realtek ALC850 chipset on my motherboard and I use OpenAL and I have no such problems. I suspect not all Creative cards, either, though it might be a crapshoot until this problem is resolved.

                          Comment


                            #14
                            I'll try it, but if I have to disable Crossfire to play all of the game types then I just won't play this game until the first patch......

                            Comment


                              #15
                              Thanks Ultron and WarTourist for your input I have tried most of the advice from the different links but still have that same crash. I guess I will have to wait for a patch to come up and see if it fixes it. Ultron I have the Realtek ALC882 chipset on my board. If you need any more info to help in patching or troubleshooting just ask. I will be glad to give it whatever it takes so I can play the game.

                              Thanks again

                              Comment

                              Working...
                              X