Announcement

Collapse
No announcement yet.

good fps but stuttering

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Well, I Played with PoolSize a bit. I'm still not sure what it *exactly* does.

    Comment


      #17
      I'm guessing it's something like 320MB and it's like the size of the cache or something. No idea for sure, however.

      Comment


        #18
        Exactly. I'm interested to know whether this cache is stored in RAM or in framebuffer? or wherever...

        In fact I'd like to know the meaning of all other settings in [TextureStreaming]. I guess that fine-tuning this section is a key for many users whit not-so-constant framerate.

        Comment


          #19
          Hi guys. Can you detail for me how this looks? Is it a non-stop stuttering, a periodic hitch, or something else?

          Thanks for the troubleshooting hukus!

          Comment


            #20
            As you wish WarTourist:

            The stutter, or shall I say short hitches, happen (at my machine) while doing a lot of quick movement - turning the camera, figting, etc. UT3 basicaly works @ 100+ FPS with my preferred settings, but only if I stand still or move slowly. Fast paced action makes my UT stuter - rotation of camera is not smooth but jerky - for example: one quick 180 rotation showed only one or two frames instead of 10-20 frames. Yet 'stat fps' says 65+. The problem seemed to me from begining to be related to background loading, because it happend in places where engine had to stream some new data.

            Or is it input related? I tried runing this command in console:
            stat engine
            It shows the real time statistics on the screen. I was quite surprised to see that the Input Latency moves in pretty high numbers: 40+ milisecs.
            I hope this description is enough.

            One more note:
            If I set OneFrameThreadLag= from True to False, the stutter is unbelievably strong, almost omnipresent :-)
            This might of course have something to do with lower FPS in this mode.

            Comment


              #21
              I think i have this problem too.Sometimes the game just stutters.Only for 2/10th of a second and the sound that plays on the moment it stutters repeads 3 or 4 times very fast,it just stutters.

              When a rocket explodes you hear instead of a normal boom more a b,b,boom.

              Its difficult to explain.

              And what hukus said doesn't work for me.

              It also happens in the menu,strange but true.

              Comment


                #22
                Originally posted by hukus View Post
                I'm still working to find optimum settings in this section:
                [TextureStreaming]
                PoolSize=320
                HysteresisLimit=20
                DropMipLevelsLimit=16
                StopIncreasingLimit=12
                StopStreamingLimit=8
                MinFudgeFactor=0.5
                FudgeFactorIncreaseRateOfChange=0.5
                FudgeFactorDecreaseRateOfChange=-0.4
                MinRequestedMipsToConsider=11
                MinTimeToGuaranteeMinMipCount=2
                MaxTimeToGuaranteeMinMipCount=12
                UseTextureFileCache=FALSE
                Had the changes you made in this section any impact on anything in the game? Cause afaik these settings under [TextureStreaming] are only related to the PS3-version of the game.
                These three settings you posted before are the only ones which alter the streaming-behaviour of the game I think.

                Comment


                  #23
                  No impact that I could spot. Seems you are right about that section.

                  Comment


                    #24
                    There are couple of other sections in the ini which seem to have absolutely no impact on the PC-version.
                    That leads me to the question if there will be a chance to tweak the ini on the PS3. But thats OT now...

                    Anyway the onlyStreamInTextures setting seems to help. Got few more fps while turning around now, thanks

                    Comment


                      #25
                      What are your system specs, Stryke?

                      Comment


                        #26
                        GeForce 8800GTS 640MB
                        Athlon 64 x2 3800+
                        2048MB DDR 400 (4x512MB DualChannel)
                        EPoX nForce4 mobo
                        Vista ultimate x64

                        I think the important thing here is the RAM and the CPU. But I wouldn't really say that the RAM is too slow, cause in benchmarks (everest) I get around 6700mb/s read and 4800mb/s write. Maybe the CPU is not able to shift all the data.

                        Comment


                          #27
                          THX man no stuttering for me anymore

                          Comment


                            #28
                            Originally posted by hukus View Post
                            What I meant to say is that:

                            bUseTextureStreaming=False - removes texture streaming along with textures, so You will see black objects only!

                            yet it helped me to find out that the problem is in streaming, what lead me to another discovery:

                            IF YOU WISH SMOOTH GAMEPLAY WITH NO STUTTER, USE
                            OnlyStreamInTextures=True
                            I meant, thx hukus

                            Comment


                              #29
                              Originally posted by msny View Post
                              Check this thread

                              http://forums.epicgames.com/showthread.php?t=586697

                              ...and this one

                              http://forums.epicgames.com/showthread.php?t=585666

                              First thing to try is to disable OpenAL sound if you have it set in game. If that does not solve it for you go through the threads.

                              Here is what finally worked for me...

                              http://forums.epicgames.com/showpost...5&postcount=25

                              Same here but only for 98%

                              It still happens but not much anymore.

                              Comment


                                #30
                                Originally posted by eXeCuTe View Post
                                Same here but only for 98%

                                It still happens but not much anymore.
                                I installed the newest beta 169.21 drivers last night and the hitching returned with a vengence. I read in the nVida fixes that it contained a hitching fix.

                                So what to do? I've done it all...

                                I remembered from my XP days that I first removed the drivers went into
                                safe mode (F8) then ran Drive Sweeper...so I did that in my Vista32.

                                Reinstalled 169.21 and there great. I have a few very small pauses
                                that I think can be tweaked. DM-Gateway has never played smooth for me
                                anyways.

                                I also noticed the game quality was much better with these.

                                Comment

                                Working...
                                X