Announcement

Collapse
No announcement yet.

Crash on map load, map quit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Crash on map load, map quit

    Hi, im pleased to say that updating the OpenAL file in the UT3 folder did solve some of the crashes, but the game still crashes when starting a game and quitting one, the screen switches from black and gray a couple of times, as if it is trying to render something which isn't there, and then i get the usual pop up that UT has encountered a problem and needs to close. I`m using an X-Fi, 7900gt, all have the latest drivers as far as i`m concerned.

    Any help is appreciated, thanks.

    Edit: my VGA is overclocked, and i`m using a tool to dynamically overclock my CPU when its load % increases. Not sure if it matters, but i thought i should include it.

    #2
    Hi The Gatekeeper. Does disabling OpenAL resolve the crashes entirely?

    If not, can you provide me with the driver version for your video card.

    Lastly, have you tried the first two options in the stickied Faq post?

    Comment


      #3
      Here are my drivers (taken from dxdiag):

      Sound:


      Video:


      Edit: I let the game crash while Xfire was running, and generated this:

      <?xml version="1.0" encoding="utf-8" ?>

      <ExceptionReport Version="4">
      <Application Build="28887" Command="&quot;C:\Games\Unreal Tournament 3\Binaries\UT3.exe&quot; "/>
      <OperatingSystem Type="2"><Version Major="5" Minor="1" Build="2600"/></OperatingSystem>
      <Exception Code="C0000005" Address="00ACCD01"><Module Section="0001" Offset="006CBD01" FileName="C:\Games\Unreal Tournament 3\Binaries\UT3.exe"/></Exception>
      <Registers EAX="000002F9" EBX="00000800" ECX="00000000" EDX="00000008" ESI="02E83488" EDI="00000800" CS="001B" EIP="00ACCD01" SS="0023" ESP="0032DB10" EBP="78134B6C" DS="0023" ES="0023" FS="003B" GS="0000" Flags="00010213"/>
      <BackTrace>
      <Frame ProgramCounter="00ACCD01" StackAddress="0032DB10" FrameAddress="78134B6C">
      <Module Section="0001" Offset="006CBD01" FileName="C:\Games\Unreal Tournament 3\Binaries\UT3.exe"/>
      <StackHexDump From="0032DB10" To="0032DB90">00 08 00 00 2b 01 00 00 6c 4b 13 78 7c f3 ce 01 9f be b2 00 00 00 00 00 f9 02 00 00 b8 d4 8e 01 18 34 e7 02 18 34 e7 02 00 08 00 00 99 cd ac 00 18 34 e7 02 f8 02 00 00 f0 18 7a 01 08 ba ea 02 8c db 32 00 90 dc 32 00 2e df ac 00 7c f3 ce 01 a8 8f 8c 01 94 dd 32 00 8c db 32 00 20 00 00 00 98 de 32 00 90 dc 32 00 01 77 b5 ad fc a5 11 03 fc a5 11 03 2c ff 32 00 01 00 00 00 2e 00 5c 00</StackHexDump>
      </Frame>
      <Frame ProgramCounter="E8781B4C" StackAddress="0032DB10" FrameAddress="6068186A">
      </Frame>
      </BackTrace>
      </ExceptionReport>

      Seems that the game is crashing at the game start aswell (the game loads, but all i see are what appear to be unrendered textures, then the game crashes with the usual "UT has encountered an error and needs to close").

      This is shortly after the game crashed:



      (The desktop gets reduced to a really low resolution, 300 by 200 i believe, and notice how the colours change)

      And this is from the Microsoft error report:

      Rendering thread exception:
      Result failed
      at .\Src\D3D9Viewport.cpp:180
      with error E_OUTOFMEMORY

      RaiseException() Address = 0x7c812a5b (filename not found)
      CxxThrowException() Address = 0x78158e69 (filename not found)
      Address = 0xb2bec2 (filename not found)
      Address = 0xe8781b4c (filename not found)


      RaiseException() Address = 0x7c812a5b (filename not found)
      CxxThrowException() Address = 0x78158e69 (filename not found)
      Address = 0xb2bec2 (filename not found)
      Address = 0xe8781b4c (filename not found)

      I don't know what more information i can provide, hope this is enough.

      I have managed to play the game a little, but most of the time it crashes.

      Comment


        #4
        I'm getting the exact same thing.

        I was playing the campaign ok for a while, turned it off to take a break, came back and tried to jump into an online game and it keeps crashing to desktop and resetting my video resolution to 600x800 and 4 bit color depth.

        I *did* manage to play about 2 and a half minutes of a warfare game BEFORE I played the campaign, but it crashed out on me when that map ended.

        Kind of frustrating. I'm hoping it gets fixed soon.

        --EDIT--

        Just tried to HOST a game, and that let me play, of course, running a host off of a cable modem is a bad idea, but the maps would load and let me run around in them.

        Also, when it crashes, it plays a burst of (quiet) static just before it goes. I have on board sound, I could try to disable that and see how it goes, but the drivers for that are also new (part of the driver downloads I did when this started having issues).

        Oh:

        I'm running a lower end rig:
        AMD 3200 Geforce 6600 with the latest drivers.
        Mobo has the NForce 4 chipset, which I just updated the drivers for once I started experiencing these problems.
        Windows XP Professional SP 2

        Comment


          #5
          Nice to see i am not alone, lets wait for WarTourist to reply shall we?

          Comment


            #6
            Originally posted by TheGatekeeper View Post
            Nice to see i am not alone, lets wait for WarTourist to reply shall we?
            Hi Gatekeeper. Did you disable OpenAL? What happened when you did a clean boot and reinstalled DirectX as suggested in the FAQ?

            Did you try reinstalling the NVIDIA drivers? nv4_disp is their software.

            Lastly, why did you mention xfire? Have you tried running the game without it?

            VMan: Please try the first to possible solutions in the FAQ: http://utforums.epicgames.com/showthread.php?t=590086. If those don't work, what's the driver version you're using for your video card?

            Comment


              #7
              I disabled OpenAL (my CPU and GPU are still overclocked) and tried about 5 matches, they loaded and no crashes, but the sound is horrible, i think its playing at 2.1 or something. I didn't play enough to be sure the crashes are gone 100%, but its better anyway.

              Is there actually an explanation as to why OpenAL crashes the game? Or a fix?

              Its nice to see some support for the game, i was beginning to regret buying it.

              Edit: i disable XFire when playing the game as i know it causes problems while running UT3, i just thought the error report it generated could be useful.

              Comment


                #8
                Originally posted by TheGatekeeper View Post
                Is there actually an explanation as to why OpenAL crashes the game? Or a fix?
                Hi Gatekeeper. Glad it's working with OpenAL disabled. I'll chat with some folks about what the issue is.

                Comment


                  #9
                  Gatekeeper: Could you please email your launch.log (in my documents\my games\unreal tournament 3\utgame\logs) after you get one of these crashes with OpenAL enabled? Send it to jeff@epicgames.com.

                  Thanks!

                  Comment


                    #10
                    My video card driver version is:

                    6.14.11.6375

                    I tried running the "clean boot",
                    just reinstalled direct x

                    actually managed to connect to a game for about 3 minutes.

                    First map was just about over, it switched, I played for about 2 minutes, and it crashed. Same symptoms as before. Next time I'll include my windows diagnostic error report.

                    Comment

                    Working...
                    X