Announcement

Collapse
No announcement yet.

Possible solution for X-Fi and OpenAL related crashes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Originally posted by Xandros View Post
    My mistake. My short attention span resulted in me briefly skimming over that post of yours on the Steam forums and I saw words like "rename" and "errors" etc. and immediately thought you were waffling on about that bogus "workaround" I mention that does completely ****** all other than break hardware acceleration.

    I also do apologise in the respect that I didn't reference what I was talking about here; I meant to write "this very thread", but thanks to said short attention span I forgot to link to it so I suppose you thought I actually meant "this" thread we're posting in right now.
    No problem, understandable mistake.

    Originally posted by Xandros View Post
    As for that other fix of yours, if you're content with soft sound that's up to you. It still doesn't really fix the issue of course, which is that hardware accelerated sound will still result in a crash. And as far as any research into the mater went it was prominent with X-RAM enabled cards, but yes, did also occur on cards without it, but that might have been a different crash related to something else entirely. It was a safe bet back in the day that if your card had X-RAM on it, this game would brick it sooner or later if you had hardware acceleration switched on.
    OK, but to be clear, please understand my "soft sound" fix is not a fix for hardware acceleration at all, obviously. It is a fix for getting true surround sound without hardware acceleration (and therefore without the crashes/bluescreens). That is the whole point of my fix, since yes actual hardware acceleration (which is available only with the Creative OpenAL device) is still a problem (and will be forever apparently).

    Originally posted by Xandros View Post
    Well, never mind. This was an issue I gave up with years ago. Seeing as the updated OpenAL versions (nearly) rectified the issue for me, although I believe also there were crashes involved with the graphics card drivers that never seemed to get fixed but they may have got confused with the X-Fi crash. I've completely forgotten if I fixed the problem in the end with updated drivers or something or if it was on-going when I gave up playing the game altogether. I expect I've had a good moan about it in that thread I just linked to.
    Too bad you gave up the game. OpenAL-Soft was just recently updated to 1.14, which improves performance a bit so there is even less worry of using the software implementation to get surround sound. All I can say in the end is OpenAL-Soft is a miracle to me concerning this age-old problem with the game, and surprisingly works very well getting surround sound without the once thought requirement of needing hardware acceleration on the sound card.

    Cheers

    Comment


      #47
      OK, I'm running into a non-UT3 related issue with my sound card. I just installed the latest drivers for my sound card, but, even though the PC recognizes the sound card, I still can't get any sound. My sound card is a Sound Blaster Audigy XtremeGamer Fatal1ty Pro. Any help would be appreciated!

      P.S. I know that this request for help is off topic, but I don't know exactly where else to ask.

      Comment


        #48
        Originally posted by Flak Master View Post
        OK, I'm running into a non-UT3 related issue with my sound card. I just installed the latest drivers for my sound card, but, even though the PC recognizes the sound card, I still can't get any sound. My sound card is a Sound Blaster Audigy XtremeGamer Fatal1ty Pro. Any help would be appreciated!

        P.S. I know that this request for help is off topic, but I don't know exactly where else to ask.
        Hiya. I'll state some common things that will hopefully help (some very obvious, I know):

        - Make sure the speakers are powered on and properly connected
        - Make sure any volume control on the speakers is up
        - Make sure the speakers device is enabled in Windows
        - Make sure the speakers aren't muted in the Windows mixer
        - Make sure the proper speakers type (2, 5.1, etc.) is selected in Windows, and also the Creative Audio Control Panel
        - Make sure the speakers output is not set to digital, if you are using normal connections (or vice-versa)

        Comment


          #49
          Thanks for the response. I checked everything, but I'm still getting nothing. I might try my headphones out to see if I can get sound from those, but I have a feeling they won't work. Any other ideas?

          Comment

          Working...
          X