Announcement

Collapse
No announcement yet.

kernel32 error report, clarify/confirm

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    kernel32 error report, clarify/confirm

    Hi,

    Firstly thank you for a great game epic, now onto the nitty gritty. UT3 works perfectly on my brother's computer, however on my laptop it crashes during the splash screen with a purported kernel32.dll fault.

    Here is the launch.log:

    Code:
    Log: Log file open, 12/02/07 18:31:31
    Init: Version: 3487
    Init: Epic Internal: 0
    Init: Compiled: Oct 21 2007 03:16:15
    Init: Command line: 
    Init: Base directory: F:\Program Files\Unreal Tournament 3\Binaries\
    Init: Character set: Unicode
    Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTEditor.ini
    Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTEditorUserSettings.ini
    Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTCompat.ini
    Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTEngine.ini
    Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTGame.ini
    Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTInput.ini
    Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTUI.ini
    Log: Deleting old log file Launch-backup-2007.12.02-18.31.31.log
    Init: Computer: HASANLAPTOP
    Init: User: Owner
    Init: CPU Page size=4096, Processors=2
    Init: High frequency timer resolution =3.579545 MHz
    Init: Memory total: Phys=1038380K Pagef=2496916K Virt=2097024K
    Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
    Init: Presizing for 83221 objects not considered by GC, pre-allocating 0 bytes.
    Init: Object subsystem initialized
    Init: WinSock: I am HASAN-laptop (192.168.0.104:0)
    Init: Startup System Settings:
    Init: System Settings:
    Init: 	StaticDecals=false
    Init: 	DynamicDecals=false
    Init: 	DynamicLights=true
    Init: 	DynamicShadows=false
    Init: 	LightEnvironmentShadows=false
    Init: 	CompositeDynamicLights=true
    Init: 	DirectionalLightmaps=false
    Init: 	MotionBlur=false
    Init: 	DepthOfField=true
    Init: 	Bloom=true
    Init: 	QualityBloom=false
    Init: 	Distortion=true
    Init: 	DropParticleDistortion=true
    Init: 	SpeedTreeLeaves=true
    Init: 	SpeedTreeFronds=true
    Init: 	OnlyStreamInTextures=false
    Init: 	LensFlares=false
    Init: 	FogVolumes=true
    Init: 	FloatingPointRenderTargets=true
    Init: 	Trilinear=true
    Init: 	OneFrameThreadLag=true
    Init: 	UseVsync=false
    Init: 	UpscaleScreenPercentage=true
    Init: 	Fullscreen=false
    Init: 	AllowD3D10=false
    Init: 	EnableHighPolyChars=false
    Init: 	SkeletalMeshLODBias=0
    Init: 	ParticleLODBias=2
    Init: 	DetailMode=0
    Init: 	ShadowFilterQualityBias=-1
    Init: 	MaxAnisotropy=0
    Init: 	MaxMultisamples=1
    Init: 	MinShadowResolution=32
    Init: 	MaxShadowResolution=512
    Init: 	ResX=800
    Init: 	ResY=600
    Init: 	ScreenPercentage=100.000
    Init: 	SceneCaptureStreamingMultiplier=1.000
    Init: 	FoliageDrawRadiusMultiplier=0.000
    Init: 	ShadowTexelsPerPixel=2.000
    Log: 	TEXTUREGROUP_World: (MinLODSize= 256,MaxLODSize=1024,LODBias=2)
    Log: 	TEXTUREGROUP_WorldNormalMap: (MinLODSize= 256,MaxLODSize=1024,LODBias=3)
    Log: 	TEXTUREGROUP_WorldSpecular: (MinLODSize= 256,MaxLODSize=1024,LODBias=2)
    Log: 	TEXTUREGROUP_Character: (MinLODSize= 256,MaxLODSize=1024,LODBias=2)
    Log: 	TEXTUREGROUP_CharacterNormalMap: (MinLODSize= 256,MaxLODSize=1024,LODBias=2)
    Log: 	TEXTUREGROUP_CharacterSpecular: (MinLODSize= 256,MaxLODSize=1024,LODBias=2)
    Log: 	TEXTUREGROUP_Weapon: (MinLODSize= 256,MaxLODSize=1024,LODBias=2)
    Log: 	TEXTUREGROUP_WeaponNormalMap: (MinLODSize= 256,MaxLODSize=1024,LODBias=3)
    Log: 	TEXTUREGROUP_WeaponSpecular: (MinLODSize= 256,MaxLODSize=1024,LODBias=2)
    Log: 	TEXTUREGROUP_Vehicle: (MinLODSize= 256,MaxLODSize=2048,LODBias=2)
    Log: 	TEXTUREGROUP_VehicleNormalMap: (MinLODSize= 256,MaxLODSize=2048,LODBias=2)
    Log: 	TEXTUREGROUP_VehicleSpecular: (MinLODSize= 256,MaxLODSize=2048,LODBias=2)
    Log: 	TEXTUREGROUP_Effects: (MinLODSize= 256,MaxLODSize=1024,LODBias=2)
    Log: 	TEXTUREGROUP_Skybox: (MinLODSize= 512,MaxLODSize=2048,LODBias=1)
    Log: 	TEXTUREGROUP_UI: (MinLODSize=2048,MaxLODSize=4096,LODBias=0)
    Log: 	TEXTUREGROUP_LightAndShadowMap: (MinLODSize= 512,MaxLODSize=4096,LODBias=0)
    Log: 	TEXTUREGROUP_RenderTarget: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
    Init: Friendly System Settings:
    Init: 	TextureDetail=Level2
    Init: 	WorldDetail=Custom
    Init: 	bUseVSync=0
    Init: 	bUseMSAA=0
    Init: 	ScreenPercentage=100
    Init: 	UpscaleScreenPercentage=1
    Init: 	ResX= 800
    Init: 	ResY= 600
    Init: 	Fullscreen=0
    Init: OS stats:
    Init: 	Windows XP Service Pack 2
    Init: 	RemoteDesktop=0
    Init: Memory stats:
    Init: 	Physical: 1014MB
    Init: 	Virtual: 2047MB
    Init: 	PageFile: 2438MB
    Init: CPU stats:
    Init: 	MeasuredPerformanceTime: 732.503 (stored result)
    Init: 	Hyperthreaded: 1
    Init: 	NumProcessorsPerCPU: 1
    Init: 	NumLogicalProcessors: 2
    Init: 	NumPhysicalProcessors: 2
    Init: 	MaxSpeed: 1596
    Init: 	CurrentSpeed: 1596
    Init: 	CoresPerProcessor: 2
    Init: 	IsOnBattery: 0
    Init: 	BatteryLevel: 96
    Init: 	Manufacturer: Intel
    Init: 	CPUName: Unknown INTEL CPU
    Init: 	L1CacheSize: 32
    Init: 	L2CacheSize: -1
    Init: 	Architecture: x86
    Init: GPU stats:
    Init: 	VendorID: 00008086
    Init: 	DeviceID: 000027A2
    Init: 	DriverVersion: 6.14.10.4785
    Init: 	DeviceName: Mobile Intel(R) 945GM/GU Express Chipset Family
    Init: 	DriverName: igxprd32.dll
    Init: 	PixelShaderVersion: 2
    Init: 	VertexShaderVersion: 2
    Init: 	VRAMQuantity: 256
    Init: 	DedicatedVRAM: 210
    Init: 	AdapterCount: 2
    Init: 	SupportsHardwareTnL: 0
    Init: Machine  detected compatibility level: Composite: 2. CPU: 3. GPU: 2.
    Init: Previous detected compatibility level: Composite: 2. CPU: 3. GPU: 2.
    Log: Initializing FaceFX...
    Log: FaceFX initialized:
    Log:     version  1.710000
    Log:     licensee Unreal Engine 3 Licensee
    Log:     project  Unreal Engine 3 Project
    Log: Preloading (default) startup map UTFrontEnd
    Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\Core.int
    Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\Engine.int
    Log: Loaded shader cache RefShaderCache-PC-D3D-SM2.CacheObject: 20457 shaders(0 legacy, 0 redundant), 2371 materials
    Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\UnrealScriptTest.int
    Log: GConfig::Find has loaded file:  ..\UTGame\Localization\int\UTGame.int
    Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTWeapon.ini
    Log: GConfig::LoadFile has loaded file:  ..\UTGame\Config\UTCustomChar.ini
    Log: GConfig::LoadFile associated file:  ..\UTGame\Config\UTMap.ini
    Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\OnlineSubsystemGameSpy.int
    Log: 87984 objects as part of root set at end of initial load.
    Log: 0 out of 0 bytes used by permanent object pool.
    Log: Initializing Engine...
    Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\Editor.int
    Log: GConfig::Find has loaded file:  ..\UTGame\Localization\int\UTEditor.int
    Init: UEngine initialized
    Log: Looking for DLC...
    Log: Object size..............: 60
    Log: Actor size...............: 436
    Log: ActorComponent size......: 88
    Log: PrimitiveComponent size..: 448
    Init: ALAudio device requested : Generic Software
    Init: ALAudio device opened    : Generic Software
    Init: AL_VENDOR      : Creative Labs Inc.
    Init: AL_RENDERER    : Software
    Init: AL_VERSION     : 1.1
    Init: AL_EXTENSIONS  : EAX EAX2.0 EAX3.0 EAX4.0 EAX5.0 EAX3.0EMULATED EAX4.0EMULATED AL_EXT_OFFSET AL_EXT_LINEAR_DISTANCE AL_EXT_EXPONENT_DISTANCE
    Init: Device supports: ALC_EXT_EFX
    Init: Found EFX extension with 1 effect slots and 1 potential sends
    Init: ...'reverb' supported
    Init: ...'low pass filter' supported
    Init: ALAudioDevice initialized.
    Init: Client initialized
    Log: GConfig::Find has loaded file:  ..\Engine\Localization\int\Launch.int
    Critical: appError called:
    Critical: Device does not support 1x32 FP render target format.
    Critical: Windows GetLastError: The operation completed successfully. (0)
    Log: === Critical error: ===
    Device does not support 1x32 FP render target format.
    
    RaiseException() Address = 0x7c812a5b (filename not found) 
    CxxThrowException() Address = 0x78158e69 (filename not found) 
    Address = 0xb27972   (filename not found) 
    Address = 0xe8781b4c (filename not found) 
    
    Exit: Executing UObject::StaticShutdownAfterError
    Exit: Executing UWindowsClient::ShutdownAfterError
    Exit: Executing UWindowsClient::ShutdownAfterError
    Exit: UALAudioDevice::ShutdownAfterError
    Log: Shutting down FaceFX...
    Log: FaceFX shutdown.
    Exit: Exiting.
    Exit: Name subsystem shutting down
    Uninitialized: Log file closed, 12/02/07 18:31:47
    "Device does not support 1x32 FP render target format."

    this is what bothers me, more than anything I want to know what that means. I'm guessing that my vid card is not fully dx9.0c compliant (on account of it being an intel chipset...) however I want confirmation.

    I uploaded my dxdiag info to here (too long to post): [link]

    here is my system info:

    OS: Windows XP SP2
    CPU: Genuine Intel(R) CPU T2050 @ 1.60GHz (2 CPUs)
    Video: Mobile Intel(R) 945GM/GU Express Chipset Family
    Sound: SigmaTel Audio - onboard mobo

    any help or clarification would be appreciated, thank you.

    #2
    Welcome to the club...

    Refreshments in the back near the exit...witch is locked...

    So your here for a while...

    Comment


      #3
      That's been reported with exactly the same message. Intel Integrated Videocard is not supported by the game, as it (hardware) does not support hardware Transform & Lightning, which is required by the game.
      Confirmation is here: http://utforums.epicgames.com/showpo...8&postcount=62

      Comment


        #4
        yeah I figured as much, it's actually why I've been reluctant to install it on my laptop... till now

        alright thanks guys

        Comment


          #5
          I hope this helps at least some of you...

          The moral of the story is this: if you can get your direct3D tests in dxdiag to work, you can probably run UT3.

          Please bear in mind that I am running an ATI x1650 pro... see my sig for other details;

          That being said, some of you nvidia folks may want to try this too...

          I tried dxdiag... when I tested direct3D all the tests failed... then I googled the error codes and someone said that their ATI catalylst driver 7.9 and above messing things up...and by going back to 7.8 it worked.

          So I uninstalled my catalyst drivers (I had previously tried 7.11 and 7.9...epic recommends 7.9...) ran driver cleaner, and went back to 7.8... Then I tried the dxdiag again and direct3d worked fine. Now the game starts and runs just fine!!

          Current UTEngine.ini settings:

          [Engine.ISVHacks]
          bInitializeShadersOnDemand=False
          DisableATITextureFilterOptimizationChecks=True
          UseMinimalNVIDIADriverShaderOptimization=True
          PumpWindowMessagesWhenRenderThreadStalled=False

          Curiously, even with Catalyst 7.9 Battlefield 2 ran just fine even though there was something wrong with my direct3D according to dxdiag...

          P.S. I also did some other stuff which I read about involving direct3D, like disabling terminal services... I wouldn't recommend doing that, it made my res settings go bugnuts for awhile... I don't know why... I must just have the most obscure hardware setup in the world...

          Anyway... I would like to know what caused this problem in the first place, but I am satisfied for now... at least since the game works...

          Comment

          Working...
          X