No announcement yet.

Invalid CD key error

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

    Invalid CD key error

    For several days I played the game without any problems.
    Now, I wanted to play again today and it asked me for a cdkey. So I typed in the key. Now it says it's an invalid cdkey although it's an official key (and it worked before).

    I tried it 3 times and my brother tried it once.

    Any solution for this?

    This is happening to me too... Very annoyed.

    After playing the game for ages and becoming addicted, it is denying me.

    Will keep looking for a fix.


    Looks as though lots of people are having this same problem, and this forum has no solutions I can find. I've never experienced a game I've paid top dollar for - played for a week or two - go and ask me for the cdkey again only to tell me that it's invalid! Really bizarre and frustrating.


      OK... Of course the simplest thing fixed this. Restart your computer. Serious, worked for me. Seems a good old restart can fix anything!

      Still don't know why it happened. (My net was online the whole time too). After the restart I didn't even need to enter the key. I did use Ad-Aware and Windows Defender before it happened... Temporary file gone missing maybe?

      Good luck to anyone who has this issue with theirs. Try restarting before you begin uninstalling or anything funny like that.



        OK, I have experienced the same problem as this. However the restart did not solve my problem. I am almost certain that in my case this was a Windows Vista issue (I am running Windows Vista Home Premium). This also coincided with Microsoft Mail losing my credentials and refusing to store them. I found that a windows update to Windows Defender had been installed on the morning that everything started to go pear shaped. My guess was that an update to Windows Defender was doing something strange to registry access and so I turned it off. This didn't help. I restarted my PC and the symptoms were still present. My next thought was that I had a virus that was corrupting the registry entries for several programs and so I turned windows defender back on to perform a scan. Half way through the scan I noticed that windows mail started to behave correctly again. At this point I stopped the scan, ran UT3 and found that it was no longer asking for a CD key. This has to be a Windows issue. The only thing that had changed on my PC since last running UT3 was the automatic update. It is probably worth posting the operating system that you are using to this thread if it happens to you.


          Constant Key Re-entry: Have to enter the product key everytime you start the game.
          Status: OPEN
          Main Thread: