No announcement yet.

X-FI OpenAL Crash

  • Filter
  • Time
  • Show
Clear All
new posts

    up! in case of some news appears (i've tried the blackice files and sound is zzZZzz) ...

    I tried ur method phatnads, and it's still crashing, some others tried what he mentionned?


      Hardware OpenAL UT3 Crash, 2 Yrs, No Fix, and Counting

      Hardware OpenAL still crashes UT3 to this very day, this issue should be solved and fixed by now! Its year 2010!

      Even with UT3 v2.1, X-Fi Titanium Drivers v2.17.0007, OpenAL32.dll v6.14.357.25, and wrap_oal.dll v2.2.0.7. UT3 will still crash or hang within minutes to even a few hours of gameplay due to Hardware OpenAL. And gamers often get these two faulting module errors: msvcr80.dll and ut3.exe. This does not make any sense, particularly the msvcr80.dll file, since its part of .net framework, and ut3.exe is the actual executable for the game which obviously works.

      Its been 391 posts and noone has done ANYTHING to fix this issue. Any such 'progress' was probably given up.

      Gamers have complained about:
      - The misleading 'Sounds Best on X-Fi' advertisements and marketing
      - The need to support 5.1 surround speakers and EAX
      - The inconvenience on the gamers where they have to swap files and so forth just to achieve some expected 5.1 'direct sound' simulation, moreover, it wont even work on Vista
      - Also another inconvenience on gamers having to disable x-ram functionality via Beta drivers and Windows registry editing
      - Most gamers would give up by now and just play it on stereo two channel, default 'generic software' device mode, this is not on.
      - For some gamers, the Hardware OpenAL 'works' after some workarounds or for those 'apparently' with non-x-ram sound cards
      - Even so, there was a previous post #389 where the gamer had a PCI-E X-Fi Titanium OEM sound card, which does not have x-ram according to Creatives' site and also since its not Fatality series, and yet the gamer still experienced crashes due to Hardware OpenAL.

      This Hardware OpenAL does 'function', the sound plays out well and EAX is on at full quality, but what is the reason for causing UT3 to crash and hang after minutes of gameplay??? Despite Creative has managed to 'duplicate' the problem on their own PCs, despite the Senior Producer of Epic Games stating in a very early post that there was some 'progress' to a solution occuring. Yet, the issue remains unfixed and 'forgotten' or 'ignored', and from my experience, any such 'fix' has not been implemented.

      I don't know what happened but this Hardware OpenAL issue has occurred since the Beta Demo of this game. And interestingly, after 5 patchs and a 're-enhancement' of this game (UT3 is Version 2.1, the new version upgrade was the opportunity to fix that OpenAL crash!!!), the Hardware OpenAL functionality that leads to an application crash remains an 'unsolved mystery'.

      This is probably the last prime function that needs fixing via a patch or hotfix. And if it ever is fixed, you have practically a 'AAA' standard game product, finally fully functional as originally intended by the developers.

      So will the Hardware OpenAL crash ever be fixed, bare minimum, despite hundreds of others have asked the same question for 2 years straight???


        I realize that this is an archaic issue but I feel I should contribute anyway as it is, nonetheless, still going. First off, system specifications:
         Video Card: XFX ATI Radeon HD4670 1GB GDDR2
         Sound Card: Creative Sound Blaster Audigy 2 ZS
           Speakers: Creative 5.1 Speakers
        Motherboard: ASUS M2N-SLI Deluxe
          Processor: AMD Athlon 64 X2 Dual-Core 4200+
                RAM: 2048MB (2x102MB) OCZ PC6400 800MHz RAM
                 OS: Windows 7 Home Premium x64
               Game: UT3 Retail activated on Steam. Applied Patch 2.1 and Titan Pack
        The game is perfectly stable when OpenAL is disabled. When I enable OpenAL, I experience the following symptoms:
        • 5.1 sound! Cool!
        • Everything is fine during game menu and map selection.
        • After a map loads, everything continues to be fine for two to four minutes.
        • Then, predicted only by elapsed time, all sound and music becomes a score of nearly unbearable, high-frequency tones.
        • The tones change according to the proximity of ambient sounds and game sounds such as weapons firing or menu slections.
        • Everything else: video, menu, game, all respond just as normal.
        • Quitting the game makes the tones go away.
        • After quitting, my system hard-locks once the process terminates.

        I have tried overwriting the game's two DLL files with every substitute I could find and none have worked. I have gone to the OpenAL website and downloaded their latest version and installed it. I am now using a beta Sound Blaster driver from October/2009 instead of the latest complete driver from July/2009. Everything has resulted in the exact symptoms listed above, save for the BlackSite: Area 51 files which had instead had just reduced the sound output to Stereo, even with OpenAL enabled, and thus defeating their purpose.

        With all of this done and no success, I am just going to play in Stereo mode and stop worrying about it.


          I wish I had found this thread before I went out to buy myself an X-Fi last weekend... it's an X-Fi Titanium (PCIe), no XRAM. Game crashes randomly.


            Originally posted by _3sixty View Post
            hey guys. i was shocked when i found this at how there are only 2 posts in this thread. 1 with the fix, and 1 making it sticky.

            very easy!!! and it works!!!!!!!!!

            That link is dead.. it's now, but I'm afraid the files are no longer available.. Maybe I can have D666 restore them, if needed?


              I had it mirrored here

              and here


                Cr4zyB4st4rd where i install that stuff


                  Oh well i just wanted to dig this to explain what fixed it for me:

                  Config: q6600+abit ip35 pro+ 460gtx+ windows xp sp3 + Creative Xfi titanium

                  System went ape**** after i "installed" last iteration of Super (c) (well all the ad-mal/ware that was brought in the install.exe x))) ) Causing my system to randomly crash (BSOD u name it...).
                  As i like things to be nice and clear, i decided to format, to start from scratch again. Thing i did and that went nicely.

                  Nicely? not so much as i ofc erased what i set to fix this creative **** working with ut3. I foolly installed lastest creative drivers thinking it would have been fixed by that time. BUAHAHAHAHAHAHAHA
                  Now after format c: , system was crashing (no lies there) 30 or more times a day (Ye bsod again, irony heh). I tried everything, new drivers/beta drivers/blackice thingy etc... Each time i was going in safe mode after having uninstalled drivers, running driver sweeper etcetc. Nothing. Spent hours on various forums about this etc... Still nothing. Ofc i could not remember how i fixed it, bah.

                  Was so bored, sooo bored that ut3 was crashing randomly i finally decided to buy an Asus Xonar dx (i think) card. By some very mysterious Magic (or maybe Asus can create some stable drivers, we will never know), no more crash at all, HOW Surprising.......... Played that way 7-10 days i think, but even if it torns my throat apart those creative unreliable N**bs made the xfi titanium so nice... I was so missing the crystal clear sound it was providing that i decided to, candidly, foolishly; give it another try... Bless by the gods of UT, i can't tell and will never be able to explain how but i fixed it.

                  Lets explain now after this little tale of Despairia =) :

                  Prior to this "fix" i tried many more with which it was adviced to install some microsoft c++ package. I installed a sh*tload of windows package but i think the more important one is the one from 2005 or sthg. START by this one microsoft c++ framework 2005 sp2 or something.

                  1)Uninstall everything Creative related. Everything! => Drivers, console launcher, midi player.

                  2) Restart in safe mode, run Driver sweeper that u previously downloaded, search for creative products, clean. switch off

                  3) Plug your xfi titanium, boot. CANCEL the automatic driver installation (who do that anyway for important devices :x )

                  4) Install this version of the driver and NO other else: XFTI_PCDRVBETA_US_2_17_0008C.exe (yes it's a beta, and yes i tried to install the non beta version of more recent drivers, guess what? still not working and random BSOD)

                  5) Once it's done, open regedit and set/create every Dword value for Xram to 1 (yes ONE and not zero

                  lick on start menu->Run->Regedit
                  go to HKEY_LOCAL_MACHINE/SYSTEM/Currentcontrolset/Control/Creative Tech

                  Go to Driver folder.
                  Then look for the PCI&VEN_1102&DEV_XXXX folder that should be there. Then click on the folder.

                  Add a new STRING and name it DisableXRAM, and set it to a string value of 1.
                  If you have more than one PCI&VEN in there, do it for the other folder.
                  6) To put every chances on my side, i decided to install UT3_SOUNDFIX too

                  Once everything listed above is done, you are yourself normally done with the problem and should normally get rid of the bsod. U can know reactivate "hardware open AL" in settings and enjoy. It did the trick for me, i can't swear it would fix it for everyone but ppl with similar config, it should work i guess.

                  Hf i hope :<