Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

X-FI OpenAL Crash

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    X-FI OpenAL Crash

    As mentioned in some other thread, there seems to be a problem with X-FI cards running in OpenAL mode with this game.

    i have got an Opteron 185, with an X-FI Fatal1ty Pro (X-RAM). If OpenAL hardware is enabled, the game chrashes !randomly!. Sometimes, the demo chrashes after start. Most times, it chrashes during match. I testet my Ut3 special edition yesterday, and it behaves the same. OpenAL = Chrash after 3 maps.

    The openal drivers arent updated since Februa 2006 it seems, so i didnt try to download this version of this API.

    So i turned it off, and the game runs fine, except: sound is awful, and the game runs much slwoer

    Nice game by the way. Ut3 rocks. Single play is not that good, but i will play it to the end. But the rest is awesome. And the Bonus-DVD and the mini-artbook rock

    #2
    I would like to ask how did your crashes go?

    Did the CPU usage go up to 100% and you had to ctrl-alt-del out or was it a diff. type of crash that required a hard boot.

    Comment


      #3
      There is a error message, wich will close UT3, or i have to close Ut3 via taskmanager. Bluescreens, reboots? Dont know what this is. if you have trouble of this sort, its a fault of your hardware (RAM/CPU/Mainboard/power-source) most likely, but not of the game or the X-FI.

      Comment


        #4
        afaik the openal feature in ut3 is completely broken somehow. after enabling openal on my audigy2 i started to get constantly crashes, too.
        i've read about that a lot in this forum and it seems we can't use openal the way it's meant to be until epic fixes it.

        dunno exactly what's wrong tho

        Comment


          #5
          i forgot: i noticed some strange behaviour in terms of soundeffects. If OpenAL is enabled, some soundeffects seems to be looped constantly on the position where they have been "created" its extreme annoying. Especially for my ears its pure pain.

          Comment


            #6
            I have been having the same issue since the beta was released! And it's really begining to get on my nerves.

            As soon as I turn on Hardware OpenAL and load up ShangriLa, my computer will hard lock to the point I have to exit the game via Task Manager. It happens with other maps as well, but rather quickly in ShangriLa. I've tried various Forceware drivers with no change. I've gone so far as to setup a clean install of XP SP2 with nothing but the game and drivers for the hardware, but I keep ending up with a lock up and an error stating;

            Faulting application ut3.exe, version 0.0.0.0, faulting module msvcr80.dll, version 8.0.50727.1433, fault address 0x000173d0.

            Hanging application UT3.exe, version 0.0.0.0, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

            The two other rigs in the house have no issues at all, but they're AMD machines with Audigy2 ZS cards instead of the X-Fi Fatal1ty, (rig specs are in the signature). I would appreciate any insight that anyone can offer. I would like to run this game out of a 5.1 system rather than front speakers only.

            Comment


              #7
              How do I disable OpenAL?

              Comment


                #8
                Launch the game with the -nosound option. From there, disable OpenAL in the audio settings area. Then restart the game without that -nosound option.

                -

                Here are two other options for trying to get OpenAL to work:

                Adding this to the thread, since a lot of people have been complaining about lockups, and have been presuming it's an issue with the video card, when in fact it's been an OpenAL issue.

                Originally posted by Jakey2.0 View Post
                I have found (thanks to this thread) that just renaming the wrap_oal.dll within the UT3\bin directory gains a similar result - 5.1 surround sound without crashes.

                Digging further, it seems that wrap_oal.dll can work standalone when renamed to openal32.dll, but this will cause the game to enumerate available sound devices slightly differently. Basically, the custom features of the X-Fi are no longer exposed.

                Anyway, there is does seem to be a minor loss of sound quality with the workaround - it doesn't sound quite as "rich". I suspect it's down to the AL_RENDERER being Software based - but at least there's 5.1 sound, and a stable game. A step in the right direction, and acceptable until the issue is hopefully resolved by either Creative or Epic...
                This file can be found here:

                C:\Program Files\Unreal Tournament 3\Binaries

                -

                Originally posted by flikflak View Post
                I run an unpatched UT3 under WinXP with a X-Fi Elite Pro and just fixed this annoying OpenAL problem!

                Here's what to do:

                Copy both OpenAL32.dll and wrap_oal.dll from Windows\system32\ to UT3\Binaries\ replacing Epic's outdated files... And voilà! Switch OpenAL back on in UT3 and restart the game.

                2 rounds WF and 2 DM maps later in OpenAL bliss, not a single crash/freeze!
                Shame on Epic for the old buggy files, but I'm glad it was that simple actually!
                Keep in mind that, in the event the UT3 files are newer than the ones you are trying to replace them with, keep the newest versions where they are in the UT3 Binaries folder.

                Comment


                  #9
                  Hi guys. Creative Labs has been able to duplicate the issue and we're looking into it. Making progress!

                  Comment


                    #10
                    Originally posted by WarTourist View Post
                    Hi guys. Creative Labs has been able to duplicate the issue and we're looking into it. Making progress!
                    THANK GOD! RIGHT NOW YOU ARE MY HERO!

                    Comment


                      #11
                      Big props to Epic on the update, thx!

                      Comment


                        #12
                        Can you make the music louder too? (without making the death "hit" sounds louder too)

                        Comment


                          #13
                          As LordB. initially reported, if you use the Blacksite Area 51 OpenAL files instead of the OpenAL files that came with UT3 it should stop the crashes.

                          Blacksite Area 51 has the following files in the Binaries folder;
                          OpenAL32.dll (version 2.1.2.0)
                          wrap_oal.dll (version 2.0.1.0)

                          If you replace the same files in the UT3 Binaries folder, it should fix your crashes when you enable Hardware OpenAL in the Audio control panel. I have not had a crash since changing these files.

                          On a side note, the audio isn't quite the same as the default UT3 files. You may experience a slight loss of brightness and slightly less definition in surround, so I don't consider this a fix, but merely a work around until Epic and Creative resolve the issue.

                          Comment


                            #14
                            Thanks for the update. It makes me happy to know that this issue is actually being worked on.

                            Comment


                              #15
                              Originally posted by vläd View Post
                              As LordB. initially reported, if you use the Blacksite Area 51 OpenAL files instead of the OpenAL files that came with UT3 it should stop the crashes.

                              Blacksite Area 51 has the following files in the Binaries folder;
                              OpenAL32.dll (version 2.1.2.0)
                              wrap_oal.dll (version 2.0.1.0)

                              If you replace the same files in the UT3 Binaries folder, it should fix your crashes when you enable Hardware OpenAL in the Audio control panel. I have not had a crash since changing these files.

                              On a side note, the audio isn't quite the same as the default UT3 files. You may experience a slight loss of brightness and slightly less definition in surround, so I don't consider this a fix, but merely a work around until Epic and Creative resolve the issue.
                              That's great, but can someone please share these two files out for those of us who don't have Blacksite Area 51?

                              Comment

                              Working...
                              X