Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

This is what helped me not crash anymore

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    This is what helped me not crash anymore

    I seen Polder post the quote below on a different thread and well it worked for me. Hope this helps all those other frusterated people who had the same problem with the game randomly crashin and freezin.


    " My game was freezing during the intromovie.
    changed the UTEngine.ini and now it works fine!!!


    C:\Documents and Settings\(your username)\My Documents\My Games\Unreal
    Tournament 3\UTGame\Config\UTEngine.ini set

    bInitializeShadersOnDemand=True
    PumpWindowMessagesWhenRenderThreadStalled=True

    XP
    A8N SLI Premium
    AMD 3800+
    XFX 7800GT
    2G memory "



    Let me rephrase what to do for those who are slow with comps. Open my computer on desktop and go here

    C:\Documents and Settings\(your username)\My Documents\My Games\Unreal
    Tournament 3\UTGame\Config\UTEngine.ini set

    Then in the note pad document there will be a bunch of ut engine commands. Scroll down until u get to the 2nd space or gap in the writin then u will see ( bInitializeShadersOnDemand=False ) change that to true and a about 3 or 4 lines more down you will see ( PumpWindowMessagesWhenRenderThreadStalled=False ) change that to true also. Then save it and close out.

    #2
    Thanks, man. I was having this same issues and your fix worked. Just replying to let others that trun across this know that you aren't the only one that had luck with it.

    XP
    EVGA SLI (Only running one card)
    3700+
    EVGA 7800GT
    3 gig RAM

    Comment


      #3
      i tried doing this and when i tried to save it it says it was a read only file or something... someone help?

      Comment


        #4
        open the properties tab on the file and uncheck the 'read only' box. then it makes it work when you 'save' it.

        Comment


          #5
          right click on the file to open the properties tab. If ya didn't know.

          Comment


            #6
            sure this cant do harm ?

            like if patch comes out it errors with this ?

            and what exactly does it do ? turn on / off some charders & ?

            Comment


              #7
              Ya just curious, I'm gonna try it, but does anyone know exactly what these changes do, other than stop it from crashing?

              Comment


                #8
                There is a memory leak in the game that most people includng myself had. Basicly with this simple fix it solves that problem. With both the cinematics and in-game memory leak crashes. There may be a patch that messes this up but hell I'll do this until then cuss it makes my game work and its not that hard to change it back.

                Comment


                  #9
                  Confirmed... I just played for several hours and things ran just fine (just one big hiccup right after I made the change and started the game, so I thought it wouldn't work, but the game recovered and not a pause or crash since). Originally I had set textures to 2 and things were working okay, this reset it to 3, and all was well.

                  Comment


                    #10
                    works for me... thanks!

                    i have a64 x2 3800+ (2.0) / 2048 pc3200 / geforce7800gt / soundblaster x-fi fatality

                    Comment


                      #11
                      BUMP

                      been playing for the past few days
                      not a single crash, and it seems it runs smoother now

                      thanks!

                      Comment


                        #12
                        this solution has not worked for me. UT3 has crashed a number of times for sfter changing the ini. i get this exception code (c0000005) too

                        Comment


                          #13
                          what should i do if i go to this floder and that file isnt there i just got this game today and installed the v1.1 patch and i have problems crashing on the videos i found this tread and looked for the file it isnt there

                          oh and btw yes i looking in right file i know about editing ini files alot

                          Comment


                            #14
                            omg i love u :P... yay 4 ut3

                            Comment


                              #15
                              I tried your Fix. It worked very, I played the game for about 30 minutes and it didn't crash. Thanks.

                              Comment

                              Working...
                              X