Announcement

Collapse
No announcement yet.

ATI x1900 512mb cards causing game lockup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Just to give an update on the situation, that 5-hour stint of no crashes was a fluke.

    They returned the next day as bad as ever.

    Comment


      Originally posted by Sincreator View Post
      This is my opinion on the issues with the 1900 cards.

      This thread should be in the ATI forums.
      Umm... no, actually if you read the entire thread it happens with 2xxx and 3xxx series and I'm guessing 4xxx as well.

      The last response from Epic was that it is a bug and they were having problems reproducing it. I volunteered to loan them a machine for free that would reproduce it quickly. Never even got a response from them.

      It's on their list of issues that they've acknowledged and claim they're looking in to.

      Comment


        To refresh

        I've worked on the problem in the past, done all of the required/suggested tests including cleaning out all drivers etc. It has happened on two different computers using 4 different ATI video cards (1650XT, 1900XT, 2600XT and 3850

        These are very high quality computers with no overclocking and built from all name brand components, large, high quality power supplies etc. etc. etc.

        Last box was an Intel motherboard, E6400, 2GB Kingston RAM, Antec power supply and UT3 locked up on only some maps with the 1650, 1900 and 2600.

        Current box is a Gigabyte P35-DS3L, E8400, 4GB Kingston RAM, Thermaltake 650W and an ATI built HD3850.

        All of my computers are on 24x7 and have no other problems. There are no thermal issues when running Crysis at 1920x1200 for 4 to 5 hours, Bioshock plays fine, Prey, Portal, HE2E2, COD4, TF2 all run flawlessly. The only application on the computer that has a problem is UT3.

        Same lockups on the same maps under the same conditions on all three computers I've installed it on.

        If it were an ATI driver bug I would think that some other application would encounter the same bug, particularly another application based on the Unreal 3 engine but that doesn't seem to be the case. Bioshock, Gears of War, Gears of War 2, Medal of Honor: Airborne, Mortal Kombat vs. DC Universe, Rainbox 6 Vegas and Vegas 2 among many others don't seem to experience the same issue so that seems to make it less likely to be a driver issue.

        Similarly the fact that when it happens, UT3 is the only application to crash makes it sound more like a deadlock issue to me. In full screen it crashes such that you can't context switch away from UT3 but the machine continues to run just fine. If you run the game in a window you can switch away from it (as several of us have proved here by providing screen caps of the crashed game) and the sound gets stuck in a loop which again seems to indicate a deadlock issue more than a driver issue.

        Comment


          Strange... I started playing UT3 on my old machine,(939 3800+ with a x1650pro 512AGP)and didnt have the issue. Then I upgraded my mobo so I could get a pci-e video card, and a better CPU. So I got the 4800+ AM2, and a x1950gt. Still didnt have any issues. Then I upgraded the 4800+ to the 6400+ BE, and added 2 3870's for crossfire. Still no problems.

          Now my system is complete. I replaced the 6400+ with a x3 710 phenom II, and I still have no issues.(Got a HUGE performance increase with this upgrade)

          All of my GPUs were sapphire, all of my CPUs were AMD, and all of my motherboards were ASUS, with ATI chipsets.

          PS: Alot of the people that upgraded from the 1900 series to the 3000/4000 series have said the problem went away.(from in this thread)

          PSX2: They added the sticky for the 1900 series after I made the post with my opinion on the matter, and I still think that this topic should of been in the ATI forums. This game has been out for a year and a half, and they are finally looking into the matter. Which is good, but I bet this would of been looked into a long time ago, if this thread had been in the ATI forums. ATI are constantly updating their drivers to resolve major issues with certain games, but if its not bought to thier attention in abundance, then nothing will happen. I guess epic decided to do that work for everyone here. Good job Epic.

          Comment


            Just wanted to offer that there are two threads (that I know of) that concern this issue and ATI cards.

            http://forums.epicgames.com/showthread.php?t=663752

            Comment


              Well how about that?

              Two years later and they still haven't fixed the threading bug in the game and it's still an "open" bug report?

              I recently upgraded my system to a 4870 w/1GB and upgraded to the most recent ATI drivers. I played Coret about 10 times (which was guaranteed to lock my PC up after only 3 to 5 times) and no problems. I thought perhaps it was a driver problem and now it was fixed.

              Then I started playing a campaign because it seemed like the game would stay running long enough to make that worthwhile. I made it to Deck and guess what? Exactly the same thread deadlock problem. The instant I died, it locked up solid just like everyone else experiences. Fortunately I still didn't trust the game and had it running in a window instead of full screen. I was able to kill off the process and continue on my way.

              This evidence is very strong that it's a threading bug. The timing/performance of the faster GPU seems to have made it less frequent... but it still happens.

              For the record again:

              Gigabyte P35-DS3L
              E8400
              4GB A-Data PC2 6400 RAM (400MHz)
              XFX HD-487A-ZHFC HD4870 w/1GB 256 bit DDR5

              Windows XP SP3, every patch up to current is applied
              DX 9.0c

              All patches have been applied to UT3 as well, I've been through all the debugging steps including removing every device driver, safe booting etc. etc.

              Nothing is overclocked, everything is rock solid and the system runs flawlessly under XP and when dual-booted into Ubuntu 9.10 (64 bit).

              But UT3 is still locking up two years later.

              I've had the same problem with 2 computer systems using 4 different ATI cards and 6 different driver versions.

              Ah well.

              Comment


                It's been awhile since I posted in this thread.lol I have had a few problems in the last couple months. 9.9, and 9.10 catalyst were garbage for me in the Unreal engine 3 games that I play. Actually the 9.8 gave me issues as well, but not near as bad. Most of these issues(Crashes) were happening in UT3 and Gears of War PC. I just keep going back to the trusty 9.7 Catalyst.

                I never had a problem until I hit Catalyst 9.8, 9.9, and 9.10. I think that the last few drivers have been focused mainly on the 4000/5000 series of cards. My buddy has a 4890 and he says the 9.10 was no good for him, but he never had any issues with 9.8/9.9. I have a 5870 on the way, so I will see if this is the case or not soon enough.

                EDIT: I got my 5870 today, and it seems that the 9.10 works fine now with this card. It caused crashes on my crossfire 3870's.

                Comment

                Working...
                X